summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-07 19:38:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-07 19:38:20 +0000
commit6479f8bd44441166ec794fb65ee184afde5a4243 (patch)
treee78a0e00dcf13d5a4a18b5adc572cd661b72c6a3 /media-video/vcdimager
parentamd64 (diff)
downloadgentoo-2-6479f8bd44441166ec794fb65ee184afde5a4243.tar.gz
gentoo-2-6479f8bd44441166ec794fb65ee184afde5a4243.tar.bz2
gentoo-2-6479f8bd44441166ec794fb65ee184afde5a4243.zip
touchups
Diffstat (limited to 'media-video/vcdimager')
-rw-r--r--media-video/vcdimager/vcdimager-0.7.19.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/media-video/vcdimager/vcdimager-0.7.19.ebuild b/media-video/vcdimager/vcdimager-0.7.19.ebuild
index 147ebfb7ba8e..92edb677d955 100644
--- a/media-video/vcdimager/vcdimager-0.7.19.ebuild
+++ b/media-video/vcdimager/vcdimager-0.7.19.ebuild
@@ -1,38 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vcdimager/vcdimager-0.7.19.ebuild,v 1.5 2004/02/01 20:15:32 mholzer Exp $
-
-IUSE="xml2"
+# $Header: /var/cvsroot/gentoo-x86/media-video/vcdimager/vcdimager-0.7.19.ebuild,v 1.6 2004/02/07 19:37:41 vapier Exp $
DESCRIPTION="GNU VCDimager"
-S=${WORKDIR}/${PN}-${PV}-cdio
-SRC_URI="mirror://sourceforge/xine/${P}-cdio.tar.gz"
-RESTRICT="nomirror"
HOMEPAGE="http://www.vcdimager.org/"
+SRC_URI="mirror://sourceforge/xine/${P}-cdio.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ppc ~amd64"
+IUSE="xml2"
-# Ideally this would also include help2man, but it's not yet in portage.
DEPEND=">=dev-libs/libcdio-0.64
xml2? ( >=dev-libs/libxml2-2.5.11 )"
+S=${WORKDIR}/${P}-cdio
+
src_compile() {
local myopts
-
# We disable the xmltest because the configure script includes differently
# than the actual XML-frontend C files.
-
use xml2 \
- && myopts="${myopts} --with-xml-prefix=/usr --disable-xmltest" \
- || myopts="${myopts} --without-xml-frontend"
+ && myopts="${myopts} --with-xml-prefix=/usr --disable-xmltest" \
+ || myopts="${myopts} --without-xml-frontend"
econf ${myopts} || die
emake || die
}
-src_install () {
+src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \