summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-20 22:01:18 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-20 22:01:18 +0000
commit099107fa13bebe485b25fb754deaccc430df91e0 (patch)
treee9526307ff21b7820fabbaf1511e07e2723a2c75 /media-video/vcdimager/vcdimager-0.7.19.ebuild
parentVersionb umped. (diff)
downloadgentoo-2-099107fa13bebe485b25fb754deaccc430df91e0.tar.gz
gentoo-2-099107fa13bebe485b25fb754deaccc430df91e0.tar.bz2
gentoo-2-099107fa13bebe485b25fb754deaccc430df91e0.zip
Versionb umped.
Diffstat (limited to 'media-video/vcdimager/vcdimager-0.7.19.ebuild')
-rw-r--r--media-video/vcdimager/vcdimager-0.7.19.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/vcdimager/vcdimager-0.7.19.ebuild b/media-video/vcdimager/vcdimager-0.7.19.ebuild
new file mode 100644
index 000000000000..60867d92af46
--- /dev/null
+++ b/media-video/vcdimager/vcdimager-0.7.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="xml2"
+
+DESCRIPTION="GNU VCDimager"
+S=${WORKDIR}/${PN}-${PV}-cdio
+SRC_URI="mirror://sourceforge/xine/${P}-cdio.tar.gz"
+HOMEPAGE="http://www.vcdimager.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Ideally this would also include help2man, but it's not yet in portage.
+DEPEND=">=dev-libs/libcdio-0.64
+ xml2? ( >=dev-libs/libxml2-2.5.11 )"
+
+src_compile() {
+ local myopts
+
+ # We disable the xmltest because the configure script includes differently
+ # than the actual XML-frontend C files.
+
+ use xml2 \
+ && myopts="${myopts} --with-xml-prefix=/usr --disable-xmltest" \
+ || myopts="${myopts} --without-xml-frontend"
+
+ econf ${myopts} || die
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog FAQ HACKING INSTALL
+ dodoc NEWS README THANKS TODO
+}