summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-03-10 20:08:45 +0000
committerMarinus Schraal <foser@gentoo.org>2005-03-10 20:08:45 +0000
commitf4480405c407f1d18ef497dc395d462fe2a9159a (patch)
tree05bc88403885d0aceed7802bae8176d3632b4cdc /media-video/totem
parentadd support for m68k (diff)
downloadgentoo-2-f4480405c407f1d18ef497dc395d462fe2a9159a.tar.gz
gentoo-2-f4480405c407f1d18ef497dc395d462fe2a9159a.tar.bz2
gentoo-2-f4480405c407f1d18ef497dc395d462fe2a9159a.zip
dubbed to be stable
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/ChangeLog8
-rw-r--r--media-video/totem/files/digest-totem-1.01
-rw-r--r--media-video/totem/totem-1.0.ebuild93
3 files changed, 101 insertions, 1 deletions
diff --git a/media-video/totem/ChangeLog b/media-video/totem/ChangeLog
index 1cee3cf202b3..17e8ea6a7898 100644
--- a/media-video/totem/ChangeLog
+++ b/media-video/totem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/totem
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.44 2005/01/30 10:18:00 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.45 2005/03/10 20:08:45 foser Exp $
+
+*totem-1.0 (10 Mar 2005)
+
+ 10 Mar 2005; foser <foser@gentoo.org> totem-1.0.ebuild :
+ Gnome 2.10 release, switched default backend over to GST to confirm with upstream
+ Added a whole bunch of useless USE flags because public opinion is that it's right
30 Jan 2005; lanius@gentoo.org totem-0.100-r2.ebuild:
mark amd64
diff --git a/media-video/totem/files/digest-totem-1.0 b/media-video/totem/files/digest-totem-1.0
new file mode 100644
index 000000000000..cc4ca5efe2f4
--- /dev/null
+++ b/media-video/totem/files/digest-totem-1.0
@@ -0,0 +1 @@
+MD5 eddfebd11ccb58caca72edc6485ed22f totem-1.0.tar.bz2 1402642
diff --git a/media-video/totem/totem-1.0.ebuild b/media-video/totem/totem-1.0.ebuild
new file mode 100644
index 000000000000..5de0d151ed5d
--- /dev/null
+++ b/media-video/totem/totem-1.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-1.0.ebuild,v 1.1 2005/03/10 20:08:45 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+IUSE="gnome xine lirc mad mpeg ogg oggvorbis a52 flac theora mad dvd debug"
+
+RDEPEND=">=dev-libs/glib-2.6.3
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/gnome-vfs-2.2
+ >=gnome-base/libglade-2
+ >=gnome-extra/nautilus-cd-burner-2.9
+ >=gnome-base/gnome-desktop-2.2
+ >=gnome-base/libgnomeui-2.4
+ gnome? ( >=gnome-base/nautilus-2.10 )
+ lirc? ( app-misc/lirc )
+ xine? ( >=media-libs/xine-lib-1_rc7
+ >=gnome-base/gconf-2 )
+ sparc? ( >=media-libs/xine-lib-1_rc7
+ >=gnome-base/gconf-2 )
+ !sparc? ( !xine? ( >=media-libs/gstreamer-0.8.9
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-gnomevfs-0.8.8
+ >=media-plugins/gst-plugins-xvideo-0.8.8
+ >=media-plugins/gst-plugins-pango-0.8.8
+ >=media-plugins/gst-plugins-ffmpeg-0.8.3
+ mad? ( >=media-plugins/gst-plugins-mad-0.8.8 )
+ mpeg? ( >=media-plugins/gst-plugins-mpeg2dec-0.8.8 )
+ ogg? ( >=media-plugins/gst-plugins-ogg-0.8.8 )
+ oggvorbis? ( >=media-plugins/gst-plugins-ogg-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8 )
+ a52? ( >=media-plugins/gst-plugins-a52dec-0.8.8 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.8.8 )
+ theora? ( >=media-plugins/gst-plugins-theora-0.8.8 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.8.8 )
+ dvd? ( >=media-plugins/gst-plugins-a52dec-0.8.8
+ >=media-plugins/gst-plugins-dvdread-0.8.8
+ >=media-plugins/gst-plugins-mpeg2dec-0.8.8 )
+ ) )
+ !gnome-extra/nautilus-media"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS TODO"
+
+# gstreamer is default backend
+use xine || G2CONF="${G2CONF} --enable-gstreamer"
+
+# gtk only support broken
+#use gnome \
+# && G2CONF="${G2CONF} --disable-gtk" \
+# || G2CONF="${G2CONF} --enable-gtk"
+
+G2CONF="${G2CONF} \
+ $(use_enable lirc) \
+ $(use_enable debug) \
+ --disable-gtk \
+ --disable-mozilla"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # use the omf_fix for scrollkeeper sandbox
+ # violations, see bug #48800 <obz@gentoo.org>
+ gnome2_omf_fix
+
+ # order the cdrom include (#68087)
+ epatch ${FILESDIR}/${PN}-0.100-cdrom_include.patch
+
+}
+
+pkg_postinst() {
+
+ gnome2_pkg_postinst
+
+ einfo "Note that the default totem backend has switched to gstreamer."
+ einfo "DVD menus will only work with the xine backend."
+
+}
+
+USE_DESTDIR="1"