summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-09-06 21:56:48 +0000
committerHanno Böck <hanno@gentoo.org>2005-09-06 21:56:48 +0000
commitc4cf57aa2f98fb6747bee6c426102ddf516cad03 (patch)
tree0716bc04018132c796f99e015fd77ae748118f32 /media-video/thoggen
parentAdded tiny patch for compiling on ppc and closing bug #100022. (diff)
downloadgentoo-2-c4cf57aa2f98fb6747bee6c426102ddf516cad03.tar.gz
gentoo-2-c4cf57aa2f98fb6747bee6c426102ddf516cad03.tar.bz2
gentoo-2-c4cf57aa2f98fb6747bee6c426102ddf516cad03.zip
thoggen 0.4
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-video/thoggen')
-rw-r--r--media-video/thoggen/ChangeLog7
-rw-r--r--media-video/thoggen/files/digest-thoggen-0.41
-rw-r--r--media-video/thoggen/thoggen-0.4.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/media-video/thoggen/ChangeLog b/media-video/thoggen/ChangeLog
index ec1dea3260f3..71af45c4f6f1 100644
--- a/media-video/thoggen/ChangeLog
+++ b/media-video/thoggen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/thoggen
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/ChangeLog,v 1.3 2005/09/06 09:59:58 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/ChangeLog,v 1.4 2005/09/06 21:56:48 hanno Exp $
+
+*thoggen-0.4 (06 Sep 2005)
+
+ 06 Sep 2005; Hanno Boeck <hanno@gentoo.org> +thoggen-0.4.ebuild:
+ Version bump, removed patch, support for new hal/dbus-API.
06 Sep 2005; Zaheer Abbas Merali <zaheerm@gentoo.org> thoggen-0.3.ebuild:
fix dbus and hal deps
diff --git a/media-video/thoggen/files/digest-thoggen-0.4 b/media-video/thoggen/files/digest-thoggen-0.4
new file mode 100644
index 000000000000..6e31a72e10ac
--- /dev/null
+++ b/media-video/thoggen/files/digest-thoggen-0.4
@@ -0,0 +1 @@
+MD5 62cb2b6f3842978f3007736d5a10935b thoggen-0.4.tar.gz 750910
diff --git a/media-video/thoggen/thoggen-0.4.ebuild b/media-video/thoggen/thoggen-0.4.ebuild
new file mode 100644
index 000000000000..196be3b14663
--- /dev/null
+++ b/media-video/thoggen/thoggen-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/thoggen-0.4.ebuild,v 1.1 2005/09/06 21:56:48 hanno Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="DVD ripper, based on GStreamer and Gtk+"
+HOMEPAGE="http://thoggen.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dts"
+
+DEPEND=">=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.6.0
+ >=gnome-base/libglade-2.4.0
+ >=media-libs/gstreamer-0.8.9
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-mpeg2dec-0.8.8
+ >=media-plugins/gst-plugins-a52dec-0.8.8
+ >=media-plugins/gst-plugins-dvdread-0.8.8
+ >=media-plugins/gst-plugins-theora-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8
+ >=media-plugins/gst-plugins-ogg-0.8.8
+ dts? ( >=media-plugins/gst-plugins-dts-0.8.8 )
+ >=sys-apps/dbus-0.23
+ >=sys-apps/hal-0.4
+ >=media-libs/libdvdread-0.9.4"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus gtk; then
+ eerror "Please merge sys-apps/dbus with 'gtk' in USE flags."
+ die "Need glib support in dbus!"
+ fi
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needed to get around some sandboxing checks
+export GST_INSPECT=/bin/true