summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-03-14 01:16:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-03-14 01:16:31 +0000
commita2888d402ea2b48f5d63e5e2e69f282f99f6b752 (patch)
tree89886029a26be658949afd46a66dfa285a6c41e2 /media-video/sonic-snap
parentversion bump (diff)
downloadgentoo-2-a2888d402ea2b48f5d63e5e2e69f282f99f6b752.tar.gz
gentoo-2-a2888d402ea2b48f5d63e5e2e69f282f99f6b752.tar.bz2
gentoo-2-a2888d402ea2b48f5d63e5e2e69f282f99f6b752.zip
Updated to latest upstream, new homepage, fixed make variables.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'media-video/sonic-snap')
-rw-r--r--media-video/sonic-snap/ChangeLog11
-rw-r--r--media-video/sonic-snap/sonic-snap-1.7.ebuild (renamed from media-video/sonic-snap/sonic-snap-1.5.ebuild)34
2 files changed, 29 insertions, 16 deletions
diff --git a/media-video/sonic-snap/ChangeLog b/media-video/sonic-snap/ChangeLog
index 5bb9d21fc24d..669796c7a996 100644
--- a/media-video/sonic-snap/ChangeLog
+++ b/media-video/sonic-snap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/sonic-snap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/sonic-snap/ChangeLog,v 1.8 2009/08/31 22:29:46 ikelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/sonic-snap/ChangeLog,v 1.9 2011/03/14 01:16:31 nerdboy Exp $
+
+*sonic-snap-1.7 (14 Mar 2011)
+
+ 14 Mar 2011; Steve Arnold <nerdboy@gentoo.org> -sonic-snap-1.5.ebuild,
+ +sonic-snap-1.7.ebuild:
+ Updated to latest upstream, new homepage, fixed make variables. Closes
+ bug #337190.
31 Aug 2009; Mike Auty <ikelos@gentoo.org> sonic-snap-1.5.ebuild:
Making CONFIG_CHECK non-fatal for userland ebuilds, see bug 283320.
diff --git a/media-video/sonic-snap/sonic-snap-1.5.ebuild b/media-video/sonic-snap/sonic-snap-1.7.ebuild
index 27bc6c6622d7..8a3965e167c4 100644
--- a/media-video/sonic-snap/sonic-snap-1.5.ebuild
+++ b/media-video/sonic-snap/sonic-snap-1.7.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/sonic-snap/sonic-snap-1.5.ebuild,v 1.10 2009/09/23 14:36:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/sonic-snap/sonic-snap-1.7.ebuild,v 1.1 2011/03/14 01:16:31 nerdboy Exp $
-EAPI="1"
-inherit eutils linux-info
+EAPI="3"
+inherit eutils linux-info toolchain-funcs
DESCRIPTION="Webcam app for sn9c10x based camera controllers (with optional MPEG4 support)"
-HOMEPAGE="http://bram.creative4vision.nl/sonic-snap/"
-SRC_URI="http://bram.creative4vision.nl/${PN}/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.stolk.org/sonic-snap/"
+SRC_URI="http://www.stolk.org/${PN}/downloads/${P}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
-KEYWORDS="amd64 ~mips ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="mpeg"
DEPEND="x11-libs/fltk:1.1
@@ -28,10 +28,17 @@ CONFIG_CHECK="~USB_SN9C102"
ERROR_USB_SN9C102="Please make sure the SN9C1xx PC Camera Controller driver is \
enabled, under V4L USB devices, as a module in your kernel."
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use mpeg && sed -i -e "s?USE_FAME=0?USE_FAME=1?g" Makefile
+src_prepare() {
+ # fix bad assumptions
+ sed -i \
+ -e "s|\$(HOME)/include|/usr/include|" \
+ -e "s|\$(HOME)/lib|/usr/$(get_libdir)|" \
+ -e "s|CFLAGS=|CFLAGS= ${CXXFLAGS} |" \
+ -e "s|LFLAGS=|LFLAGS= ${LDFLAGS} |" \
+ -e "s/g++-4.0 -O3/$(tc-getCXX)/" \
+ Makefile
+
+ use mpeg || sed -i -e "s?USE_FAME=1?USE_FAME=0?g" Makefile
}
src_compile() {
@@ -41,7 +48,6 @@ src_compile() {
src_install() {
dodir /usr/bin
make DESTDIR="${D}" install || die '"make install" failed.'
- #einstall || die "einstall failed"
dodoc ChangeLog README
doman debian/sonic-snap.1
@@ -49,12 +55,12 @@ src_install() {
pkg_postinst() {
- ewarn
+ elog
elog "This driver is V4L v2 only, so V4L v1 apps will not work."
elog "Finally, only a few image sensors are supported, eg, PAS106B"
elog "so (check dmesg or /var/log/messages for USB device info when"
elog "you plug the cam in)."
elog
elog "Now try sonic-snap-gui /dev/videoX (where X is 0, 1 , etc)."
- ewarn
+ elog
}