summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-01-03 12:16:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-01-03 12:16:53 +0000
commitda8dd123f551f7f47834c4757685970daa38b8c4 (patch)
tree27f65117f78648b1efb65e33da7b11e7005a3f34 /media-video/qdvdauthor
parentFix bug #117529 (bad ${S}). (diff)
downloadgentoo-2-da8dd123f551f7f47834c4757685970daa38b8c4.tar.gz
gentoo-2-da8dd123f551f7f47834c4757685970daa38b8c4.tar.bz2
gentoo-2-da8dd123f551f7f47834c4757685970daa38b8c4.zip
Fix qmake path for qt4/qt3 issue
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild4
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild6
2 files changed, 5 insertions, 5 deletions
diff --git a/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild b/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild
index 431d3f9db7ed..150dff783f00 100644
--- a/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild
+++ b/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild,v 1.1 2005/12/13 01:52:14 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.10.ebuild,v 1.2 2006/01/03 12:16:53 caleb Exp $
inherit eutils qt3
@@ -38,7 +38,7 @@ src_unpack() {
# full-qualify qmake in configure
sed -i -e "s:make;:make ${MAKEOPTS};:g" \
- -e "s:qmake:\${QTDIR}/bin/qmake:g" configure
+ -e "s:qmake:\${QTDIR}/bin/qmake QMAKE=\${QTDIR}/bin/qmake:g" configure
# fixing defaults from /usr/local/bin to gentoo default /usr/bin
sed -i "s:/usr/local/bin:/usr/bin:g" qdvdauthor/qdvdauthor.cpp \
diff --git a/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
index f8bbec8e4aec..f7e5cae82866 100644
--- a/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
+++ b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild,v 1.5 2005/09/04 12:55:19 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild,v 1.6 2006/01/03 12:16:53 caleb Exp $
inherit qt3 eutils
@@ -41,14 +41,14 @@ src_compile() {
#export QT_LIB="$QTDIR"
sed -i "s|/usr/local/bin|/usr/bin|g" qdvdauthor/qdvdauthor.cpp qdvdauthor/dialogexecute.cpp doc/sound.txt
cd qdvdauthor
- ${QTDIR}/bin/qmake qdvdauthor.pro || die 'qmake failed'
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake qdvdauthor.pro || die 'qmake failed'
# fixing Makefile, so that we can use our CFLAGS
sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
emake || die "emake qdvdauthor failed"
cd qslideshow
- ${QTDIR}/bin/qmake qslideshow.pro
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake qslideshow.pro
# fixing Makefile, so that we can use our CFLAGS
sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
emake || die "emake qslideshow failed"