summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 03:16:35 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 03:16:35 +0000
commit724ac532c6edd258bd1196c9b320390e446a6a4b (patch)
treec5fe99886344d127630635935da4b7f7821dd7af /media-video/qdvdauthor
parentFixed #192328 and #204351. (diff)
downloadgentoo-2-724ac532c6edd258bd1196c9b320390e446a6a4b.tar.gz
gentoo-2-724ac532c6edd258bd1196c9b320390e446a6a4b.tar.bz2
gentoo-2-724ac532c6edd258bd1196c9b320390e446a6a4b.zip
version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog10
-rw-r--r--media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc33
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild87
3 files changed, 98 insertions, 2 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 915755b69220..9b536391302f 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/qdvdauthor
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.17 2007/11/18 01:38:47 sbriesen Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.18 2008/01/06 03:16:34 sbriesen Exp $
+
+*qdvdauthor-1.0.0_rc3 (06 Jan 2008)
+
+ 06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +qdvdauthor-1.0.0_rc3.ebuild:
+ version bump
*qdvdauthor-1.0.0_rc2 (18 Nov 2007)
diff --git a/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc3 b/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc3
new file mode 100644
index 000000000000..23057ef34ba4
--- /dev/null
+++ b/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc3
@@ -0,0 +1,3 @@
+MD5 ac7db1c393629970c2b74ddb4cade903 qdvdauthor-1.0.0-3.tar.gz 4069413
+RMD160 0bd5d3c7ea2799c930208ca03b7b1e4df575ca90 qdvdauthor-1.0.0-3.tar.gz 4069413
+SHA256 17073ef414d5ccd8d1e746ab0c3ab9280fae36f737616483a07a95f3c01b63c9 qdvdauthor-1.0.0-3.tar.gz 4069413
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild
new file mode 100644
index 000000000000..1e1250e1d104
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild,v 1.1 2008/01/06 03:16:34 sbriesen Exp $
+
+inherit eutils flag-o-matic qt3
+
+DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P/_rc/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xine mplayer"
+
+DEPEND=">=media-video/dvdauthor-0.6.11
+ >=media-gfx/imagemagick-6.1.8.8
+ >=media-video/mjpegtools-1.6.2
+ >=media-video/dvd-slideshow-0.7.2
+ xine? ( >=media-libs/xine-lib-1.1.0 )
+ mplayer? ( media-video/mplayer )
+ !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
+ $(qt_min_version 3.2)"
+
+RDEPEND="${DEPEND}
+ media-libs/netpbm
+ media-video/videotrans
+ media-sound/toolame
+ media-sound/lame
+ media-sound/sox"
+
+S="${WORKDIR}/${P/_rc*/}"
+
+# TODO:
+# media-video/dvd-slideshow -> optional
+# installing further tools -> needs evaluation
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # do not over-optimize (see bug #147250)
+ replace-flags -O? -O2
+ filter-flags -finline-functions
+
+ # set our C(XX)FLAGS
+ for PRO in */*.pro */*/*.pro; do
+ echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
+ echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
+ done
+
+ # full-qualify qmake in configure and append -nocache (see bug #118697)
+ sed -i -e "s:make;\?[[:space:]]*\$:make ${MAKEOPTS};:g" \
+ -e "s:\(/qmake\):\1 -nocache QMAKE=\$QTDIR/bin/qmake:g" configure
+
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ sed -i -e "s:/usr/local/bin:/usr/bin:g" doc/sound.txt \
+ qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp
+}
+
+src_compile() {
+ local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
+
+ # select backend (VLC is currently broken)
+ #use vlc && myconf="${myconf} --with-vlc-support"
+ use xine && myconf="${myconf} --with-xine-support"
+ use mplayer && myconf="${myconf} --with-mplayer-support"
+
+ # if no backend selected, use XINE as default
+ if ! use xine && ! use mplayer; then
+ myconf="${myconf} --with-xine-support"
+ fi
+
+ ./configure --qt-dir="${QTDIR}" ${myconf} || die "configure failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
+ make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
+
+ dobin bin/{qdvdauthor,qslideshow,qplayer}
+ dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
+
+ domenu qdvdauthor.desktop
+ doicon qdvdauthor.png
+}