summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-15 13:01:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-15 13:01:57 +0000
commit33bb420a7ff775e413d1f7fc2e837302328240a1 (patch)
treef5b03c473454841945a3b527d0f0cef0e77200d6 /media-video/qc-usb/files
parentA new pre-release of mc, a new breakage on Solaris (diff)
downloadgentoo-2-33bb420a7ff775e413d1f7fc2e837302328240a1.tar.gz
gentoo-2-33bb420a7ff775e413d1f7fc2e837302328240a1.tar.bz2
gentoo-2-33bb420a7ff775e413d1f7fc2e837302328240a1.zip
Remove package masked for removal
Diffstat (limited to 'media-video/qc-usb/files')
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.24.patch36
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.26.patch30
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.27.patch25
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.28.patch110
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.30.patch70
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.6-koutput.patch53
6 files changed, 0 insertions, 324 deletions
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.24.patch b/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.24.patch
deleted file mode 100644
index c8974bc5d51d..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.24.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -urNad qc-usb-0.6.6~/qc-driver.c qc-usb-0.6.6/qc-driver.c
---- qc-usb-0.6.6~/qc-driver.c 2006-10-24 04:06:19.000000000 +0200
-+++ qc-usb-0.6.6/qc-driver.c 2007-12-09 17:20:30.000000000 +0100
-@@ -821,7 +821,9 @@
- if (!cr) goto fail2;
- urb->transfer_buffer = kmalloc(qc_i2c_maxbufsize*sizeof(u8), GFP_KERNEL); /* Allocate maximum ever needed */
- if (!urb->transfer_buffer) goto fail3;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- spin_lock_init(&urb->lock);
-+#endif
- urb->complete = qc_i2c_handler;
- urb->context = qc;
- #if (LINUX_VERSION_CODE<KERNEL_VERSION(2,6,9) && !defined(CONFIG_SUSE_KERNEL)) || LINUX_VERSION_CODE<KERNEL_VERSION(2,6,8)
-@@ -3006,7 +3008,9 @@
- static struct video_device qc_v4l_template = {
- name: "QuickCam USB",
- type: VID_TYPE_CAPTURE | VID_TYPE_SUBCAPTURE,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- hardware: VID_HARDWARE_QCAM_USB,
-+#endif
- minor: -1,
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- release: qc_v4l_release,
-diff -urNad qc-usb-0.6.6~/quickcam.h qc-usb-0.6.6/quickcam.h
---- qc-usb-0.6.6~/quickcam.h 2006-11-04 14:38:27.000000000 +0100
-+++ qc-usb-0.6.6/quickcam.h 2007-12-09 17:17:01.000000000 +0100
-@@ -126,7 +126,9 @@
- #define FALSE 0
- #define TRUE (!FALSE)
- typedef unsigned char Bool;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- #define BIT(x) (1<<(x))
-+#endif
- #define SIZE(a) (sizeof(a)/sizeof((a)[0]))
- #define MAX(a,b) ((a)>(b)?(a):(b))
- #define MIN(a,b) ((a)<(b)?(a):(b))
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.26.patch b/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.26.patch
deleted file mode 100644
index a3863372894f..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.26.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From kernel 2.6.26rc2, SetPageReserved and ClearPageReserved changed from
-macros to inline functions, that are generated using macros (among which
-SETPAGEFLAG).
-
-The functions were redefined because they don't exist as macros, and then
-preventing compilation.
-
-This patch allows to compile the quickcam/qce-ga/qc-usb module on kernels
-2.6.26rc2 and later.
-
-An other fix could use #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,26).
-
-Signed-off-by: Guillaume Bedot <littletux@mandriva.org>
---- qc-usb-0.6.6.orig/qc-memory.c 2008-05-27 16:41:19.000000000 +0200
-+++ qc-usb-0.6.6/qc-memory.c 2008-05-27 16:41:35.000000000 +0200
-@@ -81,12 +81,14 @@
- #define pte_offset(pmd,adr) pte_offset_map(pmd,adr) /* Emulation for a kernel using the new rmap-vm */
- #endif /* Fix by Michele Balistreri <brain87@gmx.net> */
-
-+#ifndef SETPAGEFLAG
- #ifndef SetPageReserved
- #define SetPageReserved(p) mem_map_reserve(p)
- #endif
- #ifndef ClearPageReserved
- #define ClearPageReserved(p) mem_map_unreserve(p)
- #endif
-+#endif
- /* }}} */
-
- /* {{{ [fold] kvirt_to_pa(): obtain physical address from virtual address obtained by vmalloc() */
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.27.patch b/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.27.patch
deleted file mode 100644
index 2fb93fa2ada1..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.27.patch
+++ /dev/null
@@ -1,25 +0,0 @@
----
- Patch inspired bug [1]
-
- [1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/268134
---- a/qc-driver.c 2008-10-23 22:55:48.000000000 +0200
-+++ b/qc-driver.c 2008-10-23 22:56:53.000000000 +0200
-@@ -2528,7 +2528,7 @@
- if (qcdebug&QC_DEBUGUSER) PDEBUG("VIDIOCGCAP");
- memset(&b, 0, sizeof(b));
- strcpy(b.name, "Logitech QuickCam USB"); /* Max 31 characters */
-- b.type = qc->vdev.type;
-+ b.type = VID_TYPE_CAPTURE;
- b.channels = 1;
- b.audios = 0;
- b.maxwidth = qc->sensor_data.maxwidth;
-@@ -3007,7 +3007,9 @@
-
- static struct video_device qc_v4l_template = {
- name: "QuickCam USB",
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,27)
- type: VID_TYPE_CAPTURE | VID_TYPE_SUBCAPTURE,
-+#endif
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- hardware: VID_HARDWARE_QCAM_USB,
- #endif
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.28.patch b/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.28.patch
deleted file mode 100644
index 438891f179a3..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.28.patch
+++ /dev/null
@@ -1,110 +0,0 @@
---- a/qc-driver.c 2009-01-11 17:54:22.000000000 +0100
-+++ b/qc-driver.c 2009-01-11 17:50:38.000000000 +0100
-@@ -645,7 +645,11 @@
- * - There is still commands to be sent in commands buffer or pid=0x850 and finalization packet is not yet sent.
- */
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+static void qc_i2c_handler(struct urb *urb)
-+#else
- static void qc_i2c_handler(struct urb *urb, struct pt_regs *ptregs)
-+#endif
- #else
- static void qc_i2c_handler(struct urb *urb)
- #endif
-@@ -1740,7 +1744,11 @@
- * - There are too many transfer errors
- */
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+static void qc_isoc_handler(struct urb *urb)
-+#else
- static void qc_isoc_handler(struct urb *urb, struct pt_regs *ptregs)
-+#endif
- #else
- static void qc_isoc_handler(struct urb *urb)
- #endif
-@@ -2255,7 +2263,11 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- struct video_device *dev = video_devdata(file);
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = (struct quickcam *)dev->priv;
-+#endif
- struct qc_frame_data *fd = &qc->frame_data;
- int mask;
-
-@@ -2307,7 +2319,11 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- struct video_device *dev = video_devdata(file);
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = dev->priv;
-+#endif
- int r;
-
- if (qcdebug&QC_DEBUGLOGIC || qcdebug&QC_DEBUGUSER) PDEBUG("qc_v4l_open(qc=%p)", qc);
-@@ -2375,7 +2391,11 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- struct video_device *dev = video_devdata(file);
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = (struct quickcam *)dev->priv;
-+#endif
- if (qcdebug&QC_DEBUGLOGIC || qcdebug&QC_DEBUGUSER) PDEBUG("qc_v4l_close(dev=%p,qc=%p)",dev,qc);
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- TEST_BUGR_MSG(qc==NULL, "qc==NULL");
-@@ -2423,7 +2443,11 @@
- struct video_device *dev = video_devdata(file);
- int noblock = file->f_flags & O_NONBLOCK;
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = (struct quickcam *)dev->priv;
-+#endif
- int frame_len;
- unsigned char *frame;
- long r = 0;
-@@ -2478,7 +2502,11 @@
- const void *start = (void *)vma->vm_start;
- unsigned long size = vma->vm_end - vma->vm_start;
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = (struct quickcam *)dev->priv;
-+#endif
- unsigned char *frame;
- int ret = 0, frame_size;
- #if !HAVE_VMA && LINUX_VERSION_CODE<KERNEL_VERSION(2,6,0)
-@@ -2510,7 +2538,11 @@
- struct video_device *dev = video_devdata(file);
- void *argp = (void *)arg;
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ struct quickcam *qc = (struct quickcam *) video_get_drvdata(dev);
-+#else
- struct quickcam *qc = (struct quickcam *)dev->priv;
-+#endif
- int i, retval = 0;
-
- if (qcdebug&QC_DEBUGLOGIC || qcdebug&QC_DEBUGUSER) PDEBUG("qc_v4l_ioctl(dev=%p,cmd=%u,arg=%p,qc=%p)",dev,cmd,argp,qc);
-@@ -3161,7 +3193,11 @@
-
- /* Register V4L video device */
- memcpy(&qc->vdev, &qc_v4l_template, sizeof(qc_v4l_template));
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,28)
-+ video_set_drvdata(&qc->vdev, qc);
-+#else
- qc->vdev.priv = qc;
-+#endif
- r = video_register_device(&qc->vdev, VFL_TYPE_GRABBER, video_nr);
- if (r<0) goto fail3;
- PRINTK(KERN_INFO, "Registered device: /dev/video%i", qc->vdev.minor);
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.30.patch b/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.30.patch
deleted file mode 100644
index cdb8c1ae6736..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-kcompat-2.6.30.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- qc-driver.c.old 2009-09-13 11:34:38.048300181 -0400
-+++ qc-driver.c 2009-09-13 11:38:10.329258334 -0400
-@@ -1000,7 +1000,9 @@
- PRINTK(KERN_WARNING,"Could not register procfs file entry");
- return -ENXIO;
- }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
- entry->owner = THIS_MODULE;
-+#endif
- entry->data = qc;
- entry->read_proc = qc_proc_read;
- entry->write_proc = qc_proc_write;
-@@ -1038,7 +1040,9 @@
- return -ENXIO;
- }
- }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
- qc_proc_entry->owner = THIS_MODULE;
-+#endif
- return 0;
- }
- /* }}} */
-@@ -2311,7 +2315,11 @@
- /* }}} */
- /* {{{ [fold] qc_v4l_open(struct video_device *dev, int flags) */
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
-+static int qc_v4l_open(struct file *file)
-+#else
- static int qc_v4l_open(struct inode *inode, struct file *file)
-+#endif
- #else
- static int qc_v4l_open(struct video_device *dev, int flags)
- #endif
-@@ -2383,7 +2391,11 @@
- /* }}} */
- /* {{{ [fold] qc_v4l_close(struct video_device *dev) */
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
-+static int qc_v4l_close(struct file *file)
-+#else
- static int qc_v4l_close(struct inode *inode, struct file *file)
-+#endif
- #else
- static void qc_v4l_close(struct video_device *dev)
- #endif
-@@ -2528,7 +2540,11 @@
- /* }}} */
- /* {{{ [fold] qc_v4l_ioctl(struct video_device *dev, unsigned int cmd, void *arg) */
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
-+static long qc_v4l_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
-+#else
- static int qc_v4l_ioctl(struct inode *inode, struct file *file, unsigned int cmd, unsigned long arg)
-+#endif
- #else
- static int qc_v4l_ioctl(struct video_device *dev, unsigned int cmd, void *argp)
- #endif
-@@ -3025,7 +3041,11 @@
-
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- static void qc_v4l_release(struct video_device *vfd) { }
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
-+static struct v4l2_file_operations qc_v4l_fops = {
-+#else
- static struct file_operations qc_v4l_fops = {
-+#endif
- owner: THIS_MODULE,
- open: qc_v4l_open,
- release: qc_v4l_close,
diff --git a/media-video/qc-usb/files/qc-usb-0.6.6-koutput.patch b/media-video/qc-usb/files/qc-usb-0.6.6-koutput.patch
deleted file mode 100644
index 1b13514c61f7..000000000000
--- a/media-video/qc-usb/files/qc-usb-0.6.6-koutput.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -ur qc-usb-0.6.6.orig/Makefile qc-usb-0.6.6/Makefile
---- qc-usb-0.6.6.orig/Makefile 2006-10-24 05:06:19.000000000 +0300
-+++ qc-usb-0.6.6/Makefile 2006-12-10 10:19:06.000000000 +0200
-@@ -44,11 +44,7 @@
- #RELEASE := $(shell awk -F \" '/[ ]*\#[ ]*define[ ]*UTS_RELEASE[ ]*/ { print $$2 }' $(LINUX_DIR)/include/linux/version.h|tail -n 1)
- # This seem to work better
- #LINUX_DIR := /usr/src/linux
--RELEASE := $(shell if test -r $(LINUX_DIR)/include/linux/version.h && fgrep -q UTS_RELEASE $(LINUX_DIR)/include/linux/version.h; then \
-- ((echo "\#include <linux/version.h>" ; echo "kernsrcver=UTS_RELEASE") | cpp -I $(LINUX_DIR)/include | grep "^kernsrcver=" | cut -d \" -f 2); \
-- elif test -r $(LINUX_DIR)/include/linux/utsrelease.h && fgrep -q UTS_RELEASE $(LINUX_DIR)/include/linux/utsrelease.h; then \
-- ((echo "\#include <linux/utsrelease.h>"; echo "kernsrcver=UTS_RELEASE") | cpp -I $(LINUX_DIR)/include | grep "^kernsrcver=" | cut -d \" -f 2); \
-- fi)
-+RELEASE := $(shell awk -F \" '/[ ]*\#[ ]*define[ ]*UTS_RELEASE[ ]*/ { print $$2 }' $(OUTPUT_DIR)/include/linux/version.h|tail -n 1)
- MODULE_DIR := /lib/modules/$(RELEASE)
- endif
- endif
-@@ -58,6 +54,10 @@
- LINUX_DIR := $(MODULE_DIR)/build
- endif
-
-+ifndef OUTPUT_DIR
-+OUTPUT_DIR := $(LINUX_DIR)
-+endif
-+
- HAVE_UTSRELEASE_H := $(shell if test -r $(LINUX_DIR)/include/linux/version.h && fgrep -q UTS_RELEASE $(LINUX_DIR)/include/linux/version.h; then \
- echo 0; \
- elif test -r $(LINUX_DIR)/include/linux/utsrelease.h && fgrep -q UTS_RELEASE $(LINUX_DIR)/include/linux/utsrelease.h; then \
-@@ -75,7 +75,7 @@
- DEPMOD := $(shell which depmod || which /sbin/depmod || echo "true You should now run depmod")
-
- # Get VERSION_CODE (from version.h in kernel source directory)
--VERSION_CODE := $(shell awk '/[ ]*\#[ ]*define[ ]*LINUX_VERSION_CODE[ ]*/ { print $$3 }' $(LINUX_DIR)/include/linux/version.h|tail -n 1)
-+VERSION_CODE := $(shell awk '/[ ]*\#[ ]*define[ ]*LINUX_VERSION_CODE[ ]*/ { print $$3 }' $(OUTPUT_DIR)/include/linux/version.h|tail -n 1)
-
- ifeq ($(shell if [ $(VERSION_CODE) -ge 132608 ]; then echo y; fi),y)
- MODULE_NAME := quickcam.ko # for 2.6.x
-@@ -91,6 +91,7 @@
- @echo "make all - Compile driver and utilities against current running kernel"
- @echo "make all USER_OPT=-DDEBUG - Compile with debugging code and messages"
- @echo "make all LINUX_DIR=/usr/src/linux - Compile against specified kernel source"
-+ @echo "make all OUTPUT_DIR=/var/tmp/kernel-output/2.6.19 - Specify binary output dir"
- @echo "make install - Copy driver and utilities into standard locations (needs root)"
- @echo "make install PREFIX=/usr - Copy utilities to /usr/bin instead of /usr/local/bin"
- @echo "make install MODULE_DIR=/lib/modules/2.4.0 - Copy module to /lib/modules/2.4.0/misc"
-@@ -130,7 +131,7 @@
- else
- # No, 2.4.x or older
-
--MODULE_INC := -I$(LINUX_DIR)/include -nostdinc -iwithprefix include
-+MODULE_INC := -I$(LINUX_DIR)/include -I$(OUTPUT_DIR)/include -nostdinc -iwithprefix include
- MODULE_DEF := -DMODULE -D__KERNEL__ -DNOKERNEL
- MODULE_OPT := -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
- MODULE_WARN := -Wall -Wstrict-prototypes -Wno-trigraphs