summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-09 18:46:26 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-09 18:46:26 +0000
commit0d796e9fbf18ca0990368652a10537284d5a6fa9 (patch)
treeb0eae740f56f8356494a21d171342232547c300c /media-video/parole
parentpunt python 2_6 (diff)
downloadgentoo-2-0d796e9fbf18ca0990368652a10537284d5a6fa9.tar.gz
gentoo-2-0d796e9fbf18ca0990368652a10537284d5a6fa9.tar.bz2
gentoo-2-0d796e9fbf18ca0990368652a10537284d5a6fa9.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/ChangeLog9
-rw-r--r--media-video/parole/parole-0.8.0.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/media-video/parole/ChangeLog b/media-video/parole/ChangeLog
index d46d291c7d88..602118bcea23 100644
--- a/media-video/parole/ChangeLog
+++ b/media-video/parole/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/parole
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.51 2014/07/09 11:47:24 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.52 2015/03/09 18:46:26 mgorny Exp $
+
+*parole-0.8.0 (09 Mar 2015)
+
+ 09 Mar 2015; Michał Górny <mgorny@gentoo.org> +parole-0.8.0.ebuild:
+ Version bump.
*parole-0.7.0 (09 Jul 2014)
diff --git a/media-video/parole/parole-0.8.0.ebuild b/media-video/parole/parole-0.8.0.ebuild
new file mode 100644
index 000000000000..a7dd56dffa65
--- /dev/null
+++ b/media-video/parole/parole-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.8.0.ebuild,v 1.1 2015/03/09 18:46:26 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="a simple media player based on the GStreamer framework for the Xfce4 desktop"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/parole/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="clutter debug libnotify taglib"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
+ >=dev-libs/glib-2.32:2=
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0=
+ sys-apps/dbus:0=
+ >=x11-libs/gtk+-3.2:3=
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.11:0=
+ >=xfce-base/libxfce4util-4.11:0=
+ >=xfce-base/xfconf-4.10:0=
+ clutter? (
+ >=media-libs/clutter-1.16.4:1.0=
+ >=media-libs/clutter-gtk-1.4.4:1.0=
+ )
+ libnotify? ( >=x11-libs/libnotify-0.7:0= )
+ taglib? ( >=media-libs/taglib-1.6:0= )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable clutter)
+ $(use_enable taglib)
+ $(use_enable libnotify notify-plugin)
+ $(xfconf_use_debug)
+ --with-gstreamer=1.0
+ )
+
+ DOCS=( AUTHORS ChangeLog README THANKS TODO )
+}