summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-14 08:59:14 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-14 08:59:14 +0000
commit980c5393ec1ef630b2af6a5311c231773654c9e9 (patch)
treebfa9b3995278196dc09fce4f3b13538c14223bc2 /media-video/ogle
parenttouchups and inherit #15675 (diff)
downloadgentoo-2-980c5393ec1ef630b2af6a5311c231773654c9e9.tar.gz
gentoo-2-980c5393ec1ef630b2af6a5311c231773654c9e9.tar.bz2
gentoo-2-980c5393ec1ef630b2af6a5311c231773654c9e9.zip
touchups and inherit #15675
Diffstat (limited to 'media-video/ogle')
-rw-r--r--media-video/ogle/ogle-0.8.4.ebuild35
-rw-r--r--media-video/ogle/ogle-0.8.5.ebuild40
2 files changed, 18 insertions, 57 deletions
diff --git a/media-video/ogle/ogle-0.8.4.ebuild b/media-video/ogle/ogle-0.8.4.ebuild
index 3f91c40537ad..43c3e806517a 100644
--- a/media-video/ogle/ogle-0.8.4.ebuild
+++ b/media-video/ogle/ogle-0.8.4.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.4.ebuild,v 1.6 2003/02/13 13:33:01 vapier Exp $
-
-IUSE="oss mmx alsa"
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.4.ebuild,v 1.7 2003/02/14 08:59:14 vapier Exp $
inherit libtool
-S=${WORKDIR}/${P}
-DESCRIPTION="Ogle is a full featured DVD player that supports DVD menus"
+DESCRIPTION="full featured DVD player that supports DVD menus"
SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+IUSE="oss mmx alsa"
+
DEPEND="media-libs/libdvdcss
media-libs/jpeg
media-libs/libdvdread
@@ -19,30 +21,13 @@ DEPEND="media-libs/libdvdcss
>=media-libs/a52dec-0.7.3
alsa? ( media-libs/alsa-lib )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
src_compile() {
-
# STOP! If you make any changes, make sure to unmerge all copies
# of ogle and ogle-gui from your system and merge ogle-gui using your
# new version of ogle... Changes in this package can break ogle-gui
# very very easily -- blocke
- local myconf
-
- use mmx \
- && myconf="--enable-mmx" \
- || myconf="--disable-mmx"
-
- use oss \
- && myconf="${myconf} --enable-oss" \
- || myconf="${myconf} --disable-oss"
-
- use alsa \
- && myconf="${myconf} --enable-alsa" \
- || myconf="${myconf} --disable-alsa"
+ local myconf="`use_enable mmx` `use_enable oss` `use_enable alsa`"
elibtoolize
@@ -51,14 +36,10 @@ src_compile() {
econf ${myconf} || die
emake CFLAGS="${CFLAGS}" || die
-
}
src_install() {
-
einstall || die
dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL NEWS README TODO
dodoc doc/liba52.txt
-
}
-
diff --git a/media-video/ogle/ogle-0.8.5.ebuild b/media-video/ogle/ogle-0.8.5.ebuild
index 19b12059e19e..0097c68e0801 100644
--- a/media-video/ogle/ogle-0.8.5.ebuild
+++ b/media-video/ogle/ogle-0.8.5.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.5.ebuild,v 1.7 2003/02/13 13:33:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.5.ebuild,v 1.8 2003/02/14 08:59:14 vapier Exp $
-IUSE="oss mmx alsa"
+inherit libtool
DESCRIPTION="Full featured DVD player that supports DVD menus."
HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
-LICENSE="GPL-2"
+SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
-inherit libtool
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+IUSE="oss mmx alsa"
DEPEND="media-libs/libdvdcss
media-libs/jpeg
@@ -19,35 +22,15 @@ DEPEND="media-libs/libdvdcss
>=media-libs/a52dec-0.7.3
alsa? ( media-libs/alsa-lib )"
-SLOT="0"
-KEYWORDS="x86 ppc"
-
-SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
-S=${WORKDIR}/${P}
-
src_compile() {
-
# STOP! If you make any changes, make sure to unmerge all copies
# of ogle and ogle-gui from your system and merge ogle-gui using your
# new version of ogle... Changes in this package can break ogle-gui
# very very easily -- blocke
- local myconf
-
- use mmx \
- && myconf="--enable-mmx" \
- || myconf="--disable-mmx"
+ local myconf="`use_enable mmx` `use_enable oss` `use_enable alsa`"
- use oss \
- && myconf="${myconf} --enable-oss" \
- || myconf="${myconf} --disable-oss"
-
- use alsa \
- && myconf="${myconf} --enable-alsa" \
- || myconf="${myconf} --disable-alsa"
-
- if [ "${ARCH}" = "ppc" ]
- then
+ if [ "${ARCH}" = "ppc" ] ; then
# if this user doesn't want altivec, don't compile it in
# fixes #14939
if [ `echo ${CFLAGS} | grep -e "-maltivec" | wc -l` = "0" ]
@@ -66,14 +49,11 @@ src_compile() {
CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml -I/usr/include/libxml2"
econf ${myconf} || die
- emake CFLAGS="${CFLAGS}" || die
-
+ emake CFLAGS="${CFLAGS}" || die
}
src_install() {
-
einstall || die
dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL NEWS README TODO
dodoc doc/liba52.txt
-
}