summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2010-09-05 17:43:18 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2010-09-05 17:43:18 +0000
commite97980581f3e071ddf3e689bcb2098c0944e5c2b (patch)
tree4f0531c51469dc82b66342b5c516c5eda7e456e8 /media-video/noad
parentx86 stable wrt bug #335479 (diff)
downloadgentoo-2-e97980581f3e071ddf3e689bcb2098c0944e5c2b.tar.gz
gentoo-2-e97980581f3e071ddf3e689bcb2098c0944e5c2b.tar.bz2
gentoo-2-e97980581f3e071ddf3e689bcb2098c0944e5c2b.zip
fix for new svdrp port 6419, used in >=vdr-1.7.15
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog8
-rw-r--r--media-video/noad/files/0.7.1/confd_vdraddon.noad5
-rw-r--r--media-video/noad/noad-0.7.2-r1.ebuild84
3 files changed, 94 insertions, 3 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index 80566f534670..7c91d540b186 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/noad
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.44 2010/06/16 14:19:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.45 2010/09/05 17:43:18 hd_brummy Exp $
+
+*noad-0.7.2-r1 (05 Sep 2010)
+
+ 05 Sep 2010; Joerg Bornkessel <hd_brummy@gentoo.org>
+ files/0.7.1/confd_vdraddon.noad, +noad-0.7.2-r1.ebuild:
+ fix for new svdrp port 6419, used in >=vdr-1.7.15
16 Jun 2010; Alexis Ballier <aballier@gentoo.org>
+files/patches-0.7.x/noad-0.7.2-cflags.patch, noad-0.7.2.ebuild:
diff --git a/media-video/noad/files/0.7.1/confd_vdraddon.noad b/media-video/noad/files/0.7.1/confd_vdraddon.noad
index 59a2e1a8e42c..eae61b501b20 100644
--- a/media-video/noad/files/0.7.1/confd_vdraddon.noad
+++ b/media-video/noad/files/0.7.1/confd_vdraddon.noad
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/files/0.7.1/confd_vdraddon.noad,v 1.1 2010/03/21 16:42:27 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/files/0.7.1/confd_vdraddon.noad,v 1.2 2010/09/05 17:43:18 hd_brummy Exp $
#########
##
@@ -44,7 +44,8 @@ NOAD_JUMP="yes"
#
NOAD_OVERLAP="yes"
-## send an OSD-Message to localhost:2001 for start and end
+## send an OSD-Message to localhost:2001 ( >=vdr-1.7.15 localhost:6419 )
+# for start and end
# available Parameter
# yes | no
#
diff --git a/media-video/noad/noad-0.7.2-r1.ebuild b/media-video/noad/noad-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..164978365735
--- /dev/null
+++ b/media-video/noad/noad-0.7.2-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.7.2-r1.ebuild,v 1.1 2010/09/05 17:43:18 hd_brummy Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Mark commercial Breaks in VDR records"
+HOMEPAGE="http://noad.heliohost.org/"
+SRC_URI="http://noad.heliohost.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg imagemagick"
+
+DEPEND="media-libs/libmpeg2
+ ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
+ imagemagick? ( >=media-gfx/imagemagick-6.2.4.2-r1 )"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/patches-0.7.x/"${P}"-hangcheck.diff
+ epatch "${FILESDIR}"/patches-0.7.x/"${P}"-cflags.patch
+ eautoreconf
+ # UINT64_C is needed by ffmpeg headers
+ append-flags -D__STDC_CONSTANT_MACROS
+
+ if has_version ">=media-video/vdr-1.5.17"; then
+ sed -e "s:2001:6419:" -i svdrpc.cpp
+ fi
+}
+
+src_configure() {
+
+ local=myconf
+ use ffmpeg && myconf="--with-ffmpeg --with-ffmpeginclude=/usr/include"
+
+ econf \
+ ${myconf} \
+ $(use_with imagemagick magick) \
+ --with-mpeginclude=/usr/include/mpeg2dec
+# --with-tools # fails on showindex, marcpics compile
+}
+
+src_install() {
+
+ dobin noad
+# fix me later!
+# dobin noad showindex
+# use imagemagick && dobin markpics
+
+ dodoc README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadifnew stat2html
+
+ CONF_SOURCE="${FILESDIR}/0.7.1"
+ newconfd "${CONF_SOURCE}"/confd_vdraddon.noad vdraddon.noad
+
+ insinto /usr/share/vdr/record
+ doins "${CONF_SOURCE}"/record-50-noad.sh
+
+ insinto /usr/share/vdr/shutdown
+ doins "${FILESDIR}"/pre-shutdown-15-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins "${CONF_SOURCE}"/reccmds.noad.conf
+
+ exeinto /usr/share/vdr/bin
+ doexe "${CONF_SOURCE}"/noad-reccmd
+}
+
+pkg_postinst() {
+
+ elog
+ elog "Congratulations, you have just installed noad!,"
+ elog "To integrate noad in VDR you should do this:"
+ elog
+ elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ elog
+ elog "Note: You can use here all pararmeters for noad,"
+ elog "please look in the documentation of noad."
+}