summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-03-21 23:44:25 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-03-21 23:44:25 +0000
commit80176354972b73b148d597429e8f93d2164ce5e0 (patch)
treec585f2c474cecd997581d39e39f8ddbfe189d870 /media-video/mtxdrivers-pro
parentfix gtk2.4 build issues (Manifest recommit) (diff)
downloadgentoo-2-80176354972b73b148d597429e8f93d2164ce5e0.tar.gz
gentoo-2-80176354972b73b148d597429e8f93d2164ce5e0.tar.bz2
gentoo-2-80176354972b73b148d597429e8f93d2164ce5e0.zip
Changing absolute symlinks to relative to close #44969.
Diffstat (limited to 'media-video/mtxdrivers-pro')
-rw-r--r--media-video/mtxdrivers-pro/ChangeLog8
-rw-r--r--media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta-r11
-rw-r--r--media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta-r1.ebuild62
3 files changed, 70 insertions, 1 deletions
diff --git a/media-video/mtxdrivers-pro/ChangeLog b/media-video/mtxdrivers-pro/ChangeLog
index c0a83b281539..d06ab2ed73b3 100644
--- a/media-video/mtxdrivers-pro/ChangeLog
+++ b/media-video/mtxdrivers-pro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/mtxdrivers-pro
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/ChangeLog,v 1.8 2004/03/12 19:45:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/ChangeLog,v 1.9 2004/03/21 23:44:25 spyderous Exp $
+
+*mtxdrivers-pro-1.1.0_beta-r1 (21 Mar 2004)
+
+ 21 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ mtxdrivers-pro-1.1.0_beta-r1.ebuild:
+ Changing absolute symlinks to relative to close #44969.
12 Mar 2004; Seemant Kulleen <seemant@gentoo.org>
mtxdrivers-pro-1.0_beta4.ebuild:
diff --git a/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta-r1 b/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta-r1
new file mode 100644
index 000000000000..3ec4bba8c835
--- /dev/null
+++ b/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta-r1
@@ -0,0 +1 @@
+MD5 f6a0889f98df944b6d0e6b1d68dc3de5 mtxdrivers-rh9.0-v1.1.0-pro-beta.tar.gz 2658433
diff --git a/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta-r1.ebuild b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta-r1.ebuild
new file mode 100644
index 000000000000..d06268540524
--- /dev/null
+++ b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta-r1.ebuild,v 1.1 2004/03/21 23:44:25 spyderous Exp $
+
+inherit matrox
+
+# GL lib version
+GL_V="1.3.0"
+
+# Stupid naming scheme requires this, probably only works for betas
+MY_PV="${PV/_/-pro-}"
+MY_PN="${PN/-pro}"
+MY_P="${MY_PN}-rh9.0-v${MY_PV}"
+S="${WORKDIR}/${MY_PN}"
+DESCRIPTION="Drivers for the Matrox Parhelia and Millenium P650/P750 cards with OpenGL support."
+SRC_URI="${MY_P}.tar.gz"
+
+KEYWORDS="~x86"
+
+RDEPEND="x11-base/opengl-update
+ !media-video/mtxdrivers"
+
+pkg_nofetch() {
+ einfo "Matrox requires you e-mail them for the 'pro' version of their drivers"
+ einfo "(i.e., the ones with OpenGL support). If you do not need OpenGL, please"
+ einfo "emerge mtxdrivers. Otherwise, e-mail cad-support@matrox.com and request"
+ einfo "the Matrox Parhelia drivers with OpenGL support. Please remember to"
+ einfo "download the RH9.0 driver once you are given the site address."
+}
+
+src_install() {
+ # Install 2D driver and DRM kernel module
+ matrox_base_src_install
+
+ dodoc README*
+
+ # Install OpenGL driver, libs, etc.
+ local GENTOO_GL_ROOT="/usr/lib/opengl"
+ local GENTOO_MTX_ROOT="${GENTOO_GL_ROOT}/mtx"
+
+ dodir ${GENTOO_MTX_ROOT}/extensions; exeinto ${GENTOO_MTX_ROOT}/extensions
+ doexe xfree86/${GENTOO_X_VERSION}/libglx.a
+
+ dodir ${GENTOO_MTX_ROOT}/include; insinto ${GENTOO_MTX_ROOT}/include
+ doins include/GL/gl.h include/GL/glx.h include/GL/glext.h
+
+ dodir ${GENTOO_MTX_ROOT}/lib; exeinto ${GENTOO_MTX_ROOT}/lib
+ doexe lib/libGL.so.${GL_V}
+ dosym ../../xfree/lib/libGL.so.${GL_V} ${GENTOO_MTX_ROOT}/lib/libGL.so.1
+ dosym ../../xfree/lib/libGL.so.${GL_V} ${GENTOO_MTX_ROOT}/lib/libGL.so
+
+ # Same as XFree86
+ dosym ../../xfree/lib/libGL.la ${GENTOO_MTX_ROOT}/lib/libGL.la
+}
+
+pkg_postinst() {
+ # modules-update, maybe some info on busmastering
+ matrox_base_pkg_postinst
+
+ # Don't run opengl-update for them. Tell them how, instead. (spyderous)
+ einfo "To switch to Matrox OpenGL, run \"opengl-update mtx\""
+}