summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-22 15:24:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-22 15:24:11 +0000
commite4e4c39e899428857741849a8d23aa1ef0b0b62d (patch)
tree46251ab1cd74b9df01ce05865b3b45a21696d411 /media-video/mplayer
parentremoving from metadata (diff)
downloadgentoo-2-e4e4c39e899428857741849a8d23aa1ef0b0b62d.tar.gz
gentoo-2-e4e4c39e899428857741849a8d23aa1ef0b0b62d.tar.bz2
gentoo-2-e4e4c39e899428857741849a8d23aa1ef0b0b62d.zip
add upstream build fix against ffmpeg git master
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/files/mplayer-1.1-codecid.patch19
-rw-r--r--media-video/mplayer/mplayer-1.1-r1.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 82681339813c..df999be05b6e 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.855 2012/08/01 10:43:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.856 2012/08/22 15:24:11 aballier Exp $
+
+ 22 Aug 2012; Alexis Ballier <aballier@gentoo.org> mplayer-1.1-r1.ebuild,
+ +files/mplayer-1.1-codecid.patch:
+ add upstream build fix against ffmpeg git master
01 Aug 2012; Fabian Groffen <grobian@gentoo.org> mplayer-1.1-r1.ebuild:
aqua is also sufficient for opengl and osdmenu
diff --git a/media-video/mplayer/files/mplayer-1.1-codecid.patch b/media-video/mplayer/files/mplayer-1.1-codecid.patch
new file mode 100644
index 000000000000..38a58aa0f47b
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-1.1-codecid.patch
@@ -0,0 +1,19 @@
+r35075 | iive | 2012-08-11 12:42:43 -0400 (Sat, 11 Aug 2012) | 4 lines
+
+Quick Build Fix. FFmpeg CodecID is redefined as AVCodecID.
+It needs the FFmpeg includes in all places that use it.
+
+
+Index: libmpdemux/mp_taglists.h
+===================================================================
+--- libmpdemux/mp_taglists.h (revision 35074)
++++ libmpdemux/mp_taglists.h (revision 35075)
+@@ -20,6 +20,8 @@
+ #define MPLAYER_MP_TAGLISTS_H
+
+ #include <stdint.h>
++#include "libavutil/common.h"
++#include "libavformat/avformat.h"
+
+ enum CodecID mp_tag2codec_id(uint32_t tag, int audio);
+ uint32_t mp_codec_id2tag(enum CodecID codec_id, uint32_t old_tag, int audio);
diff --git a/media-video/mplayer/mplayer-1.1-r1.ebuild b/media-video/mplayer/mplayer-1.1-r1.ebuild
index 52116ec47592..1f10ac451b0d 100644
--- a/media-video/mplayer/mplayer-1.1-r1.ebuild
+++ b/media-video/mplayer/mplayer-1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.1-r1.ebuild,v 1.4 2012/08/01 10:43:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.1-r1.ebuild,v 1.5 2012/08/22 15:24:11 aballier Exp $
EAPI=4
@@ -194,6 +194,7 @@ REQUIRED_USE="bindist? ( !faac !win32codecs )
PATCHES=(
"${FILESDIR}/${PN}-1.0_rc4-pkg-config.patch"
"${FILESDIR}/${P}-ffmpeg.patch"
+ "${FILESDIR}/${P}-codecid.patch"
)
pkg_setup() {