summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-28 01:46:17 +0000
committerChris White <chriswhite@gentoo.org>2005-01-28 01:46:17 +0000
commit1547f828184ffc9d6c28f4f776fa1feb6def2fdc (patch)
tree76b8d3f61c81dbc54e70e72d4fccf979fa3aeb5b /media-video/mpgtx
parentdrop eutils eclass depend (diff)
downloadgentoo-2-1547f828184ffc9d6c28f4f776fa1feb6def2fdc.tar.gz
gentoo-2-1547f828184ffc9d6c28f4f776fa1feb6def2fdc.tar.bz2
gentoo-2-1547f828184ffc9d6c28f4f776fa1feb6def2fdc.zip
Bumped to 1.3.1. Fixes bug #79160. Thanks to Martin Deirs for the report.
Diffstat (limited to 'media-video/mpgtx')
-rw-r--r--media-video/mpgtx/ChangeLog9
-rw-r--r--media-video/mpgtx/Manifest5
-rw-r--r--media-video/mpgtx/files/digest-mpgtx-1.3.11
-rw-r--r--media-video/mpgtx/mpgtx-1.3.1.ebuild46
-rw-r--r--media-video/mpgtx/mpgtx-1.3.ebuild4
5 files changed, 60 insertions, 5 deletions
diff --git a/media-video/mpgtx/ChangeLog b/media-video/mpgtx/ChangeLog
index fe195cc8966f..562c76665b3a 100644
--- a/media-video/mpgtx/ChangeLog
+++ b/media-video/mpgtx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/mpgtx
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/ChangeLog,v 1.5 2004/10/18 21:28:23 kugelfang Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/ChangeLog,v 1.6 2005/01/28 01:46:17 chriswhite Exp $
+
+*mpgtx-1.3.1 (28 Jan 2005)
+
+ 28 Jan 2005; Chris White <chriswhite@gentoo.org> +mpgtx-1.3.1.ebuild:
+ Bumped to 1.3.1. Fixes bug #79160. Thanks to Martin Deirs for the report.
18 Oct 2004; Danny van Dyk <kugelfang@gentoo.org> mpgtx-1.3.ebuild:
Marked ~amd64.
diff --git a/media-video/mpgtx/Manifest b/media-video/mpgtx/Manifest
index 627f8e01f829..ae0e03139497 100644
--- a/media-video/mpgtx/Manifest
+++ b/media-video/mpgtx/Manifest
@@ -1,5 +1,8 @@
MD5 7f9a031d463f9dcaa51eda32de19c631 ChangeLog 725
-MD5 3b8f6d4db5c438860a7e42c20075c582 mpgtx-1.3.ebuild 1467
MD5 31018765c8c65a239dba78a98c405543 metadata.xml 224
+MD5 3b8f6d4db5c438860a7e42c20075c582 mpgtx-1.3.ebuild 1467
+MD5 61ab1aafde08812b82657c215bb4812f mpgtx-1.3.1.ebuild 1394
+MD5 876395e802febea314a66342c3576818 .mpgtx-1.3.1.ebuild.swp 12288
MD5 2f7766f539f18c11a67ea4d0ceaaadda files/digest-mpgtx-1.3 57
MD5 a3dbfa95d33bc0878275c94e9e6e8fe9 files/mpgtx-1.3-gcc34.patch 288
+MD5 e7a438b14d3a5d4e41f591b09d90b6cf files/digest-mpgtx-1.3.1 62
diff --git a/media-video/mpgtx/files/digest-mpgtx-1.3.1 b/media-video/mpgtx/files/digest-mpgtx-1.3.1
new file mode 100644
index 000000000000..c12562455ef1
--- /dev/null
+++ b/media-video/mpgtx/files/digest-mpgtx-1.3.1
@@ -0,0 +1 @@
+MD5 d628060aa04ad3b40a175bf35f5167cf mpgtx-1.3.1.tar.gz 89170
diff --git a/media-video/mpgtx/mpgtx-1.3.1.ebuild b/media-video/mpgtx/mpgtx-1.3.1.ebuild
new file mode 100644
index 000000000000..1a95922f6232
--- /dev/null
+++ b/media-video/mpgtx/mpgtx-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.1.ebuild,v 1.1 2005/01/28 01:46:17 chriswhite Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="mpgtx a command line MPEG audio/video/system file toolbox"
+SRC_URI="mirror://sourceforge/mpgtx/${P}.tar.gz"
+HOMEPAGE="http://mpgtx.sourceforge.net/"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="sys-libs/glibc"
+
+src_compile() {
+ ./configure --parachute --prefix=/usr
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]; then
+ sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe mpgtx
+
+ dosym /usr/bin/mpgtx /usr/bin/mpgjoin
+ dosym /usr/bin/mpgtx /usr/bin/mpgsplit
+ dosym /usr/bin/mpgtx /usr/bin/mpgcat
+ dosym /usr/bin/mpgtx /usr/bin/mpginfo
+ dosym /usr/bin/mpgtx /usr/bin/mpgdemux
+ dosym /usr/bin/mpgtx /usr/bin/tagmp3
+
+ doman man/mpgtx.1 man/tagmp3.1
+
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgcat.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgjoin.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpginfo.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgsplit.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgdemux.1
+
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/mpgtx/mpgtx-1.3.ebuild b/media-video/mpgtx/mpgtx-1.3.ebuild
index d4465a237cf5..e7814975263d 100644
--- a/media-video/mpgtx/mpgtx-1.3.ebuild
+++ b/media-video/mpgtx/mpgtx-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.10 2004/10/18 21:28:23 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.11 2005/01/28 01:46:17 chriswhite Exp $
inherit eutils gcc