summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2011-01-21 17:51:38 +0000
committerDror Levin <spatz@gentoo.org>2011-01-21 17:51:38 +0000
commit0a17753bd2d2fbd72283a5034ac55a80249f5047 (patch)
tree7049244c96273bb74220bf599bba2e7a75d194d8 /media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild
parentFix libxfcegui4 block wrt #351945 by Zac Medico. (diff)
downloadgentoo-2-0a17753bd2d2fbd72283a5034ac55a80249f5047.tar.gz
gentoo-2-0a17753bd2d2fbd72283a5034ac55a80249f5047.tar.bz2
gentoo-2-0a17753bd2d2fbd72283a5034ac55a80249f5047.zip
Add pch USE flag to avoid breakage on hardened (bug 352185). Bump to EAPI 3. Drop old.
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild')
-rw-r--r--media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild b/media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild
deleted file mode 100644
index cd20b10ede1b..000000000000
--- a/media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mkvtoolnix/mkvtoolnix-4.2.0.ebuild,v 1.1 2010/07/29 22:33:18 beandog Exp $
-
-EAPI="1"
-inherit eutils wxwidgets flag-o-matic qt4 autotools
-
-DESCRIPTION="Tools to create, alter, and inspect Matroska files"
-HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
-SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="bzip2 debug doc flac lzo qt4 wxwidgets"
-
-DEPEND=">=dev-libs/libebml-1.0.0
- >=media-libs/libmatroska-1.0.0
- media-libs/libogg
- media-libs/libvorbis
- dev-libs/expat
- sys-libs/zlib
- dev-libs/boost
- wxwidgets? ( x11-libs/wxGTK:2.8 )
- flac? ( media-libs/flac )
- bzip2? ( app-arch/bzip2 )
- lzo? ( dev-libs/lzo )
- qt4? ( x11-libs/qt-gui:4 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- WX_GTK_VER="2.8"
- if use wxwidgets; then
- need-wxwidgets unicode
- fi
-}
-
-src_prepare() {
- eautoreconf
-}
-
-src_compile() {
- use wxwidgets && myconf="--with-wx-config=${WX_CONFIG}"
- econf \
- $(use_enable lzo) \
- $(use_enable bzip2 bz2) \
- $(use_enable wxwidgets) \
- $(use_enable debug) \
- $(use_with flac) \
- $(use_enable qt4 qt) \
- ${myconf} \
- --with-boost-regex=boost_regex \
- --with-boost-filesystem=boost_filesystem \
- --with-boost-system=boost_system
-
- # Don't run strip while installing stuff, leave to portage the job.
- emake STRIP="true" || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" STRIP="true" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
- doman doc/man/*.1 || die "doman failed"
-
- if use doc; then
- dohtml doc/guide/en/mkvmerge-gui.html || die "dohtml failed"
- docinto html/images
- dohtml doc/guide/en/images/* || die "dohtml failed"
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}
-
-pkg_postinst() {
- use qt4 && elog "Qt GUI is unsupported by upstream, and may be removed
- soon."
-}