summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-02-10 21:01:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-02-10 21:01:21 +0000
commit40f9948296fe2b2cac9301afe008516d20bd67d9 (patch)
treee3b38186cfd560f84d4c07838898aa3aaf0dfd94 /media-video/minitube
parentinitial import wrt #235537 (diff)
downloadgentoo-2-40f9948296fe2b2cac9301afe008516d20bd67d9.tar.gz
gentoo-2-40f9948296fe2b2cac9301afe008516d20bd67d9.tar.bz2
gentoo-2-40f9948296fe2b2cac9301afe008516d20bd67d9.zip
Version bump. Disable check_for_updates popup on startup. bug #455976
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-video/minitube')
-rw-r--r--media-video/minitube/ChangeLog10
-rw-r--r--media-video/minitube/files/minitube-2.0-disable-updates.patch16
-rw-r--r--media-video/minitube/minitube-2.0.ebuild60
3 files changed, 84 insertions, 2 deletions
diff --git a/media-video/minitube/ChangeLog b/media-video/minitube/ChangeLog
index abe04e1f4da6..5a6c206af9b3 100644
--- a/media-video/minitube/ChangeLog
+++ b/media-video/minitube/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/minitube
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.81 2012/12/22 10:24:55 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.82 2013/02/10 21:01:21 hwoarang Exp $
+
+*minitube-2.0 (10 Feb 2013)
+
+ 10 Feb 2013; Markos Chandras <hwoarang@gentoo.org>
+ +files/minitube-2.0-disable-updates.patch, +minitube-2.0.ebuild:
+ Version bump. Disable check_for_updates popup on startup. bug #455976
22 Dec 2012; Markos Chandras <hwoarang@gentoo.org>
-files/minitube-1.8-gcc4.7.patch, -minitube-1.8.ebuild:
diff --git a/media-video/minitube/files/minitube-2.0-disable-updates.patch b/media-video/minitube/files/minitube-2.0-disable-updates.patch
new file mode 100644
index 000000000000..0117fd95d0ff
--- /dev/null
+++ b/media-video/minitube/files/minitube-2.0-disable-updates.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=455976
+
+Index: minitube/src/mainwindow.cpp
+===================================================================
+--- minitube.orig/src/mainwindow.cpp
++++ minitube/src/mainwindow.cpp
+@@ -145,9 +145,6 @@ MainWindow::MainWindow() :
+ mouseTimer->setInterval(5000);
+ mouseTimer->setSingleShot(true);
+ connect(mouseTimer, SIGNAL(timeout()), SLOT(hideMouse()));
+-
+- QTimer::singleShot(0, this, SLOT(checkForUpdate()));
+-
+ }
+
+ MainWindow::~MainWindow() {
diff --git a/media-video/minitube/minitube-2.0.ebuild b/media-video/minitube/minitube-2.0.ebuild
new file mode 100644
index 000000000000..7aa25902f7a3
--- /dev/null
+++ b/media-video/minitube/minitube-2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-2.0.ebuild,v 1.1 2013/02/10 21:01:21 hwoarang Exp $
+
+EAPI=5
+PLOCALES="ar ca ca_ES da de_DE el en es es_AR es_ES fi fi_FI fr gl he_IL hr hu
+ia id it jv ka_GE nb nl nn pl pl_PL pt pt_BR ro ru sk sl sq sr sv_SE tr
+uk_UA zh_CN"
+
+inherit l10n qt4-r2
+
+DESCRIPTION="Qt4 YouTube Client"
+HOMEPAGE="http://flavio.tordini.org/minitube"
+SRC_URI="http://flavio.tordini.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gstreamer kde"
+
+DEPEND=">=x11-libs/qt-gui-4.6:4[accessibility,gtkstyle]
+ >=x11-libs/qt-dbus-4.6:4
+ kde? ( || ( media-libs/phonon[gstreamer?] >=x11-libs/qt-phonon-4.6:4 ) )
+ !kde? ( || ( >=x11-libs/qt-phonon-4.6:4 media-libs/phonon[gstreamer?] ) )
+ gstreamer? (
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS CHANGES TODO"
+
+#455976
+PATCHES=( "${FILESDIR}"/${P}-disable-updates.patch )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # Remove unneeded translations
+ local trans=
+ for x in $(l10n_get_locales); do
+ trans+="${x}.ts "
+ done
+ if [[ -n ${trans} ]]; then
+ sed -i -e "/^TRANSLATIONS/s/+=.*/+=${trans}/" locale/locale.pri || die
+ fi
+ # gcc-4.7. Bug #422977. Will probably be fixed
+ # once ubuntu moves to gcc-4.7
+ epatch "${FILESDIR}"/${PN}-1.9-gcc47.patch
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon images/app.png minitube.png
+}