summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2011-11-15 10:35:47 +0000
committerLuca Barbato <lu_zero@gentoo.org>2011-11-15 10:35:47 +0000
commit5da7a675d225efbdcac7e4fc348ceaf8a11cb4cc (patch)
tree6f92dfafc8e75fbf471a980d81500c87224e41c0 /media-video/kino
parentAdding selinux-tftp as newer version for selinux-tftpd, naming now ok with up... (diff)
downloadgentoo-2-5da7a675d225efbdcac7e4fc348ceaf8a11cb4cc.tar.gz
gentoo-2-5da7a675d225efbdcac7e4fc348ceaf8a11cb4cc.tar.bz2
gentoo-2-5da7a675d225efbdcac7e4fc348ceaf8a11cb4cc.zip
Update libav support, thanks to Charlie Gehlin <charlie@gehlin.com> for the patch and the report in bug #390067
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'media-video/kino')
-rw-r--r--media-video/kino/ChangeLog7
-rw-r--r--media-video/kino/files/kino-1.3.4-libav-0.7.patch60
-rw-r--r--media-video/kino/kino-1.3.4.ebuild3
3 files changed, 68 insertions, 2 deletions
diff --git a/media-video/kino/ChangeLog b/media-video/kino/ChangeLog
index 0f8cc739e35f..381e8668d48b 100644
--- a/media-video/kino/ChangeLog
+++ b/media-video/kino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/kino
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.128 2011/10/16 19:24:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.129 2011/11/15 10:35:46 lu_zero Exp $
+
+ 15 Nov 2011; Luca Barbato <lu_zero@gentoo.org> kino-1.3.4.ebuild,
+ +files/kino-1.3.4-libav-0.7.patch:
+ Update libav support, thanks to Charlie Gehlin <charlie@gehlin.com> for the
+ patch and the report in bug #390067
16 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -kino-1.3.3.ebuild,
-files/kino-1.3.3-avutil.patch:
diff --git a/media-video/kino/files/kino-1.3.4-libav-0.7.patch b/media-video/kino/files/kino-1.3.4-libav-0.7.patch
new file mode 100644
index 000000000000..65c5bc38276d
--- /dev/null
+++ b/media-video/kino/files/kino-1.3.4-libav-0.7.patch
@@ -0,0 +1,60 @@
+--- kino-1.3.4.orig/src/frame.cc 2011-07-17 14:54:59.089481638 +0200
++++ kino-1.3.4/src/frame.cc 2011-07-17 15:09:23.199481714 +0200
+@@ -1063,7 +1063,12 @@
+ AVPicture dest;
+ int got_picture;
+
+- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
++ AVPacket pkt;
++ av_init_packet(&pkt);
++ pkt.data = data;
++ pkt.size = GetFrameSize();
++
++ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
+ if ( got_picture )
+ {
+ avpicture_fill( &dest, static_cast<uint8_t*>( rgb ), PIX_FMT_RGB24, GetWidth(), GetHeight() );
+@@ -1123,7 +1128,12 @@
+ AVPicture output;
+ int got_picture;
+
+- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
++ AVPacket pkt;
++ av_init_packet(&pkt);
++ pkt.data = data;
++ pkt.size = GetFrameSize();
++
++ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
+ if ( got_picture )
+ {
+ avpicture_fill( &output, static_cast<uint8_t*>( yuv ), PIX_FMT_YUV422, GetWidth(), GetHeight() );
+@@ -1156,7 +1166,12 @@
+ AVFrame *frame = avcodec_alloc_frame();
+ int got_picture;
+
+- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
++ AVPacket pkt;
++ av_init_packet(&pkt);
++ pkt.data = data;
++ pkt.size = GetFrameSize();
++
++ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
+
+ int width = GetWidth(), height = GetHeight();
+
+@@ -1319,12 +1334,12 @@
+ #if defined(HAVE_LIBAVCODEC)
+ if ( avformatEncoder == NULL )
+ {
+- avformatEncoder = av_alloc_format_context();
++ avformatEncoder = avformat_alloc_context();
+ if ( avformatEncoder )
+ {
+- avformatEncoder->oformat = guess_format( "dv", NULL, NULL );
++ avformatEncoder->oformat = av_guess_format( "dv", NULL, NULL );
+ AVStream* vst = av_new_stream( avformatEncoder, 0 );
+- vst->codec->codec_type = CODEC_TYPE_VIDEO;
++ vst->codec->codec_type = AVMEDIA_TYPE_VIDEO;
+ vst->codec->codec_id = CODEC_ID_DVVIDEO;
+ vst->codec->bit_rate = 25000000;
+ vst->start_time = 0;
diff --git a/media-video/kino/kino-1.3.4.ebuild b/media-video/kino/kino-1.3.4.ebuild
index 40133b122c0f..b0179a8fa214 100644
--- a/media-video/kino/kino-1.3.4.ebuild
+++ b/media-video/kino/kino-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-1.3.4.ebuild,v 1.5 2011/10/16 19:22:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-1.3.4.ebuild,v 1.6 2011/11/15 10:35:46 lu_zero Exp $
EAPI="4"
@@ -84,6 +84,7 @@ src/page_bttv.cc' po/POTFILES.in || die "sed failed"
sed -i -e 's:^#include <quicktime.h>:#include <lqt/quicktime.h>:' \
src/filehandler.h || die "sed failed"
epatch "${FILESDIR}/${P}-v4l1.patch"
+ epatch "${FILESDIR}/${P}-libav-0.7.patch"
}
src_configure() {