summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-10-18 15:16:12 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-10-18 15:16:12 +0000
commit26c477367f0581de1452df93009ea4c1a485cba5 (patch)
treef144943aab5df9630b5532e5e5ddb522077a6ecc /media-video/kdenlive
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-26c477367f0581de1452df93009ea4c1a485cba5.tar.gz
gentoo-2-26c477367f0581de1452df93009ea4c1a485cba5.tar.bz2
gentoo-2-26c477367f0581de1452df93009ea4c1a485cba5.zip
Added gcc-3.4 patch
Diffstat (limited to 'media-video/kdenlive')
-rw-r--r--media-video/kdenlive/ChangeLog5
-rw-r--r--media-video/kdenlive/Manifest5
-rw-r--r--media-video/kdenlive/files/kdenlive-0.2.4-gcc34.patch82
-rw-r--r--media-video/kdenlive/kdenlive-0.2.4.ebuild12
4 files changed, 99 insertions, 5 deletions
diff --git a/media-video/kdenlive/ChangeLog b/media-video/kdenlive/ChangeLog
index b526f28e7d1f..33d7c923d03a 100644
--- a/media-video/kdenlive/ChangeLog
+++ b/media-video/kdenlive/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/kdenlive
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/ChangeLog,v 1.5 2004/06/29 12:10:27 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/ChangeLog,v 1.6 2004/10/18 15:16:12 zypher Exp $
+
+ 18 Oct 2004; Marc Hildebrand <zypher@gentoo.org> kdenlive-0.2.4.ebuild:
+ Added gcc-3.4 patch. Thanks to Mathijs Mohlmann for the patch.
29 Jun 2004; Carsten Lohrke <carlo@gentoo.org> kdenlive-0.2.4.ebuild:
QA: IUSE, need-kde after R/DEPEND
diff --git a/media-video/kdenlive/Manifest b/media-video/kdenlive/Manifest
index 645c3ea81434..569b3fe5a996 100644
--- a/media-video/kdenlive/Manifest
+++ b/media-video/kdenlive/Manifest
@@ -1,4 +1,5 @@
-MD5 80918426da071ccb9ff9cc59908f6fe5 ChangeLog 642
+MD5 b616349b59fed6652131843090111800 ChangeLog 782
MD5 b930e21bf22fd73f984ae65f871fdc2d metadata.xml 253
-MD5 352cc22f24971918700d7ea107a3ba57 kdenlive-0.2.4.ebuild 579
+MD5 ce231220c4c93e9b98b69d6e11f0871e kdenlive-0.2.4.ebuild 721
+MD5 9b7f530fe5c63b0114d2445b9d352e43 files/kdenlive-0.2.4-gcc34.patch 3723
MD5 e0e37c5c67335b510278e92e08bb01d8 files/digest-kdenlive-0.2.4 67
diff --git a/media-video/kdenlive/files/kdenlive-0.2.4-gcc34.patch b/media-video/kdenlive/files/kdenlive-0.2.4-gcc34.patch
new file mode 100644
index 000000000000..8d6d51617a85
--- /dev/null
+++ b/media-video/kdenlive/files/kdenlive-0.2.4-gcc34.patch
@@ -0,0 +1,82 @@
+diff -ru kdenlive-0.2.4/kdenlive/docclipbaselist.h kdenlive-0.2.4.sav/kdenlive/docclipbaselist.h
+--- kdenlive-0.2.4/kdenlive/docclipbaselist.h 2003-12-17 01:14:12.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/docclipbaselist.h 2004-10-13 14:45:51.665341837 +0200
+@@ -49,7 +49,7 @@
+ /** The "master clip" of this list. The master clip is special only in that it is mentioned
+ seperately to every other clip in the clip list; it also appears in the clip list. It is
+ singled out so that operations that require a master clip can make use of it. */
+- DocClipBase * m_masterClip;;
++ DocClipBase * m_masterClip;
+ };
+
+ #endif
+diff -ru kdenlive-0.2.4/kdenlive/docclipreflist.h kdenlive-0.2.4.sav/kdenlive/docclipreflist.h
+--- kdenlive-0.2.4/kdenlive/docclipreflist.h 2003-12-17 01:14:58.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/docclipreflist.h 2004-10-13 14:45:17.239736652 +0200
+@@ -49,7 +49,7 @@
+ /** The "master clip" of this list. The master clip is special only in that it is mentioned
+ seperately to every other clip in the clip list; it also appears in the clip list. It is
+ singled out so that operations that require a master clip can make use of it. */
+- DocClipRef * m_masterClip;;
++ DocClipRef * m_masterClip;
+ };
+
+ #endif
+diff -ru kdenlive-0.2.4/kdenlive/doctrackbase.h kdenlive-0.2.4.sav/kdenlive/doctrackbase.h
+--- kdenlive-0.2.4/kdenlive/doctrackbase.h 2003-12-17 01:14:12.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/doctrackbase.h 2004-10-13 14:45:30.860602135 +0200
+@@ -67,7 +67,7 @@
+ /** Adds all of the clips in the pointerlist into this track. */
+ void addClips(DocClipRefList list, bool selected);
+ /** returns true if all of the clips within the cliplist can be added, returns false otherwise. */
+- bool canAddClips(DocClipRefList clipList);;
++ bool canAddClips(DocClipRefList clipList);
+ /** Returns true if the clip given exists in this track, otherwise returns
+ false. */
+ bool clipExists(DocClipRef *clip);
+diff -ru kdenlive-0.2.4/kdenlive/kaddmarkercommand.cpp kdenlive-0.2.4.sav/kdenlive/kaddmarkercommand.cpp
+--- kdenlive-0.2.4/kdenlive/kaddmarkercommand.cpp 2003-12-17 01:15:02.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/kaddmarkercommand.cpp 2004-10-13 14:50:33.841122249 +0200
+@@ -108,4 +108,4 @@
+ }
+ }
+
+-};
++}
+diff -ru kdenlive-0.2.4/kdenlive/kaddmarkercommand.h kdenlive-0.2.4.sav/kdenlive/kaddmarkercommand.h
+--- kdenlive-0.2.4/kdenlive/kaddmarkercommand.h 2003-12-17 01:15:02.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/kaddmarkercommand.h 2004-10-13 14:47:35.352093152 +0200
+@@ -64,6 +64,6 @@
+ void deleteMarker();
+ };
+
+-};
++}
+
+ #endif
+diff -ru kdenlive-0.2.4/kdenlive/kdenlivedoc.cpp kdenlive-0.2.4.sav/kdenlive/kdenlivedoc.cpp
+--- kdenlive-0.2.4/kdenlive/kdenlivedoc.cpp 2003-12-20 19:33:48.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/kdenlivedoc.cpp 2004-10-13 14:48:05.338394017 +0200
+@@ -290,7 +290,7 @@
+ }
+
+ return pResult;
+-};
++}
+
+ void KdenliveDoc::activeSceneListGeneration(bool active)
+ {
+diff -ru kdenlive-0.2.4/kdenlive/krender.h kdenlive-0.2.4.sav/kdenlive/krender.h
+--- kdenlive-0.2.4/kdenlive/krender.h 2003-12-17 01:14:33.000000000 +0100
++++ kdenlive-0.2.4.sav/kdenlive/krender.h 2004-10-13 14:43:46.950885761 +0200
+@@ -117,7 +117,7 @@
+ void setSceneList(QDomDocument list);
+ /** Wraps the VEML command of the same name - sends a <ping> command to the server, which
+ should reply with a <pong> - let's us determine the round-trip latency of the connection. */
+- void ping(QString &ID);;
++ void ping(QString &ID);
+ /** Wraps the VEML command of the same name. Tells the renderer to
+ play the current scene at the speed specified, relative to normal
+ playback. e.g. 1.0 is normal speed, 0.0 is paused, -1.0 means play
+
+
diff --git a/media-video/kdenlive/kdenlive-0.2.4.ebuild b/media-video/kdenlive/kdenlive-0.2.4.ebuild
index 19c19e456744..4c9b3d3de7da 100644
--- a/media-video/kdenlive/kdenlive-0.2.4.ebuild
+++ b/media-video/kdenlive/kdenlive-0.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/kdenlive-0.2.4.ebuild,v 1.6 2004/06/29 12:10:27 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/kdenlive-0.2.4.ebuild,v 1.7 2004/10/18 15:16:12 zypher Exp $
-inherit kde
+inherit gcc kde
DESCRIPTION="Kdenlive! (pronounced Kay-den-live) is a Non Linear Video Editing Suite for KDE."
HOMEPAGE="http://www.uchian.pwp.blueyonder.co.uk/kdenlive.html"
@@ -16,3 +16,11 @@ IUSE=""
DEPEND=">=media-video/piave-0.2.4
>=kde-base/kdesdk-3.2"
need-kde 3
+
+src_unpack() {
+ unpack ${A}
+ if [ "`gcc-minor-version`" -eq "4" ]
+ then
+ epatch ${FILESDIR}/kdenlive-0.2.4-gcc34.patch
+ fi
+}