summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-27 09:37:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-27 09:37:25 +0000
commit7c1413c4c6a51ba861624bf141d01a44173abd58 (patch)
tree4bebe87a91a96157f5d172487d1be56de647eb07 /media-video/istanbul
parentHave paraview block vtk until a better solution is found (#279264). (diff)
downloadgentoo-2-7c1413c4c6a51ba861624bf141d01a44173abd58.tar.gz
gentoo-2-7c1413c4c6a51ba861624bf141d01a44173abd58.tar.bz2
gentoo-2-7c1413c4c6a51ba861624bf141d01a44173abd58.zip
Fix aclocal failure, bug #218917. Move to EAPI=2, move to split python bindings, bug #108479. Add missing pkgconfig to DEPEND. Use new python eclass functions in postinst.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/istanbul')
-rw-r--r--media-video/istanbul/istanbul-0.2.0-r1.ebuild62
-rw-r--r--media-video/istanbul/istanbul-0.2.0.ebuild36
-rw-r--r--media-video/istanbul/istanbul-0.2.2.ebuild59
3 files changed, 31 insertions, 126 deletions
diff --git a/media-video/istanbul/istanbul-0.2.0-r1.ebuild b/media-video/istanbul/istanbul-0.2.0-r1.ebuild
deleted file mode 100644
index 5165ae621831..000000000000
--- a/media-video/istanbul/istanbul-0.2.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.0-r1.ebuild,v 1.8 2008/05/29 17:30:45 hawking Exp $
-
-inherit eutils gnome2 python autotools
-
-KEYWORDS="~x86 ~amd64"
-
-HOMEPAGE="http://live.gnome.org/Istanbul"
-LICENSE="GPL-2"
-SLOT=0
-DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
-IUSE=""
-
-RDEPEND=">=media-libs/gst-plugins-base-0.10.8
- dev-lang/python
- >=dev-python/pygtk-2.6
- >=dev-python/gnome-python-extras-2.11.3
- >=gnome-base/gconf-2.0
- >=dev-python/gst-python-0.10.0
- =media-plugins/gst-plugins-ogg-0.10*
- =media-plugins/gst-plugins-theora-0.10*
- >=media-libs/libtheora-1.0_alpha6
- =media-plugins/gst-plugins-gconf-0.10*"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35.0"
-
-SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
-
-src_unpack() {
- gnome2_src_unpack
-
- # disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s /bin/true "${S}"/py-compile
- echo "py_compile = /bin/true" > common/python.mk
-
- intltoolize --force --copy || die
- AT_M4DIR="common" eautoreconf
-}
-
-src_compile() {
- mkdir -p "${T}/home"
- export HOME="${T}/home"
- export GST_REGISTRY=${T}/home/registry.cache.xml
- addpredict /root/.gconfd
- addpredict /root/.gconf
- addpredict /root/.gnome2
- econf
- emake
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/istanbul
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}
diff --git a/media-video/istanbul/istanbul-0.2.0.ebuild b/media-video/istanbul/istanbul-0.2.0.ebuild
deleted file mode 100644
index 064f1c87cb3d..000000000000
--- a/media-video/istanbul/istanbul-0.2.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.0.ebuild,v 1.3 2007/01/22 02:20:49 compnerd Exp $
-
-inherit eutils gnome2
-
-KEYWORDS="~x86 ~amd64"
-
-HOMEPAGE="http://live.gnome.org/Istanbul"
-LICENSE="GPL-2"
-SLOT=0
-DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
-IUSE=""
-
-RDEPEND=">=media-libs/gst-plugins-base-0.10.8
- dev-lang/python
- >=dev-python/pygtk-2.6
- >=dev-python/gnome-python-extras-2.11.3
- >=gnome-base/gconf-2.0
- >=dev-python/gst-python-0.10.0
- media-plugins/gst-plugins-ogg
- media-plugins/gst-plugins-theora
- >=media-libs/libtheora-1.0_alpha6"
-
-DEPEND="${RDEPEND}"
-SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
-
-src_compile() {
- mkdir -p "${T}/home"
- export HOME="${T}/home"
- export GST_REGISTRY=${T}/home/registry.cache.xml
- addpredict /root/.gconfd
- addpredict /root/.gconf
- econf
- emake
-}
diff --git a/media-video/istanbul/istanbul-0.2.2.ebuild b/media-video/istanbul/istanbul-0.2.2.ebuild
index 2f93737bcd9c..dace10f57583 100644
--- a/media-video/istanbul/istanbul-0.2.2.ebuild
+++ b/media-video/istanbul/istanbul-0.2.2.ebuild
@@ -1,69 +1,72 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.ebuild,v 1.4 2008/05/29 17:30:45 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.ebuild,v 1.5 2009/07/27 09:37:25 eva Exp $
-inherit eutils gnome2 python autotools
+EAPI="2"
+GCONF_DEBUG="no"
-KEYWORDS="~x86 ~amd64"
+inherit eutils gnome2 python autotools
HOMEPAGE="http://live.gnome.org/Istanbul"
+DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT=0
-DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=media-libs/gst-plugins-base-0.10.8
dev-lang/python
>=dev-python/pygtk-2.6
- >=dev-python/gnome-python-extras-2.11.3
>=gnome-base/gconf-2.0
>=dev-python/gst-python-0.10.0
=media-plugins/gst-plugins-ogg-0.10*
=media-plugins/gst-plugins-theora-0.10*
- >=media-libs/libtheora-1.0_alpha6
+ >=media-libs/libtheora-1.0_alpha6[encode]
=media-plugins/gst-plugins-gconf-0.10*
- dev-python/python-xlib"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35.0"
+ dev-python/python-xlib
-SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
-
-pkg_setup() {
- if ! built_with_use media-libs/libtheora encode; then
- eerror "You need to rebuild media-libs/libtheora with USE flag encode."
- die "media-libs/libtheora needs USE flag encode."
- fi
-}
+ >=dev-python/egg-python-2.11.3
+ >=dev-python/gnome-vfs-python-2
+ >=dev-python/gconf-python-2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ dev-util/pkgconfig"
-src_unpack() {
- gnome2_src_unpack
+src_prepare() {
+ gnome2_src_prepare
# disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s /bin/true "${S}"/py-compile
- echo "py_compile = /bin/true" > common/python.mk
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+ echo "py_compile = $(type -P true)" > common/python.mk
+
+ # fix autoreconf failure, bug #230325
+ epatch "${FILESDIR}/${P}-macro-typo.patch"
- intltoolize --force --copy || die
- AT_M4DIR="common" eautoreconf
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
}
-src_compile() {
+src_configure() {
mkdir -p "${T}/home"
export HOME="${T}/home"
export GST_REGISTRY=${T}/home/registry.cache.xml
addpredict /root/.gconfd
addpredict /root/.gconf
addpredict /root/.gnome2
- econf
- emake
+
+ gnome2_src_configure
}
pkg_postinst() {
gnome2_pkg_postinst
python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/istanbul
+ python_mod_optimize $(python_get_sitedir)/istanbul
}
pkg_postrm() {
+ gnome2_pkg_postrm
python_mod_cleanup
}