summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-03-25 00:25:19 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-03-25 00:25:19 +0000
commitae942e2dd4ef7fb06f54b653456e3cef725b6669 (patch)
treef2ce902af98a0469faf9930fdb489caaaf5ed2a3 /media-video/flumotion
parentAdded spanish translations for gnustep-* (diff)
downloadgentoo-2-ae942e2dd4ef7fb06f54b653456e3cef725b6669.tar.gz
gentoo-2-ae942e2dd4ef7fb06f54b653456e3cef725b6669.tar.bz2
gentoo-2-ae942e2dd4ef7fb06f54b653456e3cef725b6669.zip
Initial Commit - Flumotion Streaming Server (Fixes #85791)
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog10
-rw-r--r--media-video/flumotion/Manifest4
-rw-r--r--media-video/flumotion/files/digest-flumotion-0.1.61
-rwxr-xr-xmedia-video/flumotion/files/flumotion-init28
-rw-r--r--media-video/flumotion/flumotion-0.1.6.ebuild91
-rw-r--r--media-video/flumotion/metadata.xml5
6 files changed, 139 insertions, 0 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
new file mode 100644
index 000000000000..485c05c292b7
--- /dev/null
+++ b/media-video/flumotion/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-video/flumotion
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.1 2005/03/25 00:25:19 zaheerm Exp $
+
+*flumotion-0.1.6 (25 Mar 2005)
+
+ 25 Mar 2005; <zaheerm@gentoo.org> +files/flumotion-init,
+ +flumotion-0.1.6.ebuild:
+ Initial Commit - Flumotion Streaming Server (Fixes #85791)
+
diff --git a/media-video/flumotion/Manifest b/media-video/flumotion/Manifest
new file mode 100644
index 000000000000..6c7cbae9a29f
--- /dev/null
+++ b/media-video/flumotion/Manifest
@@ -0,0 +1,4 @@
+MD5 ff802654be3e1581fa5775dfdbac6db2 flumotion-0.1.6.ebuild 2245
+MD5 6050196ef420c3e4025029ebee5a813f metadata.xml 162
+MD5 8e6e2463c4524b7786f678ca197fd7af files/flumotion-init 1021
+MD5 f421d5bbf35e1bda4cde73c86517fbd3 files/digest-flumotion-0.1.6 68
diff --git a/media-video/flumotion/files/digest-flumotion-0.1.6 b/media-video/flumotion/files/digest-flumotion-0.1.6
new file mode 100644
index 000000000000..20bf22bf741a
--- /dev/null
+++ b/media-video/flumotion/files/digest-flumotion-0.1.6
@@ -0,0 +1 @@
+MD5 eaaa93f8d2696164849c19d0c466fab9 flumotion-0.1.6.tar.bz2 574448
diff --git a/media-video/flumotion/files/flumotion-init b/media-video/flumotion/files/flumotion-init
new file mode 100755
index 000000000000..7f144e7e4ccd
--- /dev/null
+++ b/media-video/flumotion/files/flumotion-init
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+
+flumotion_manager=/usr/bin/flumotion-manager
+flumotion_worker=/usr/bin/flumotion-worker
+flumotion_manager_pidfile=/var/run/flumotion/manager.default.pid
+flumotion_worker_pidfile=/var/run/flumotion/worker.localhost.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Flumotion Manager"
+ HOME=/usr/share/flumotion start-stop-daemon --start --chuid flumotion:flumotion --pidfile ${flumotion_manager_pidfile} --exec ${flumotion_manager} -- -D /etc/flumotion/managers/default/planet.xml
+ eend $?
+ ebegin "Starting Flumotion Worker"
+ HOME=/usr/share/flumotion start-stop-daemon --start --chuid flumotion:flumotion --pidfile ${flumotion_worker_pidfile} --exec ${flumotion_worker} -- -D /etc/flumotion/workers/default.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Flumotion Worker"
+ start-stop-daemon --stop --pidfile ${flumotion_worker_pidfile}
+ eend $?
+ ebegin "Stopping Flumotion Manager"
+ start-stop-daemon --stop --pidfile ${flumotion_manager_pidfile}
+ eend $?
+}
diff --git a/media-video/flumotion/flumotion-0.1.6.ebuild b/media-video/flumotion/flumotion-0.1.6.ebuild
new file mode 100644
index 000000000000..bc71f5c69a0a
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.1.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.1.6.ebuild,v 1.1 2005/03/25 00:25:19 zaheerm Exp $
+
+inherit eutils
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.fluendo.com"
+SRC_URI="http://www.flumotion.net/src/flumotion/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="v4l speex jpeg dv"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ >=gnome-base/libglade-2
+ >=media-libs/gstreamer-0.8.9-r2
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-gnomevfs-0.8.8
+ v4l? ( >=media-plugins/gst-plugins-v4l-0.8.8 )
+ >=media-plugins/gst-plugins-ogg-0.8.8
+ >=media-plugins/gst-plugins-theora-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8
+ >=media-plugins/gst-plugins-libpng-0.8.8
+ speex? ( >=media-plugins/gst-plugins-speex-0.8.8 )
+ dv? ( >=media-plugins/gst-plugins-dv-0.8.8
+ >=media-plugins/gst-plugins-raw1394-0.8.8 )
+ >=dev-python/pygtk-2.4.0
+ >=dev-python/gst-python-0.8.1
+ >=dev-python/twisted-1.3.0
+ dev-python/imaging
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ LICENCE.Flumotion LICENCE.GPL \
+ NEWS README TODO"
+
+src_compile() {
+ econf --localstatedir=/var || die
+
+ emake || die
+
+}
+
+src_install() {
+ einstall
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ insinto /etc/flumotion/managers/default/flows
+ cd ${S}/conf
+ doins managers/default/flows/ogg-test-theora.xml
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+
+ insinto /etc/flumotion
+ doins default.pem
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/flumotion-init flumotion
+
+ keepdir /var/run/flumotion
+ keepdir /var/log/flumotion
+}
+
+# borrowed from jboss ebuild
+without_error() {
+ $@ &>/dev/null || true
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 /bin/false /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion ${dir}
+ chmod -R 755 ${dir}
+ done
+}
diff --git a/media-video/flumotion/metadata.xml b/media-video/flumotion/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/media-video/flumotion/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>