summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-26 15:20:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-26 15:20:48 +0000
commitc286751011f4c7bf902de6cd8f981fd96b1061fc (patch)
treee92974d6b074ae37139f6fd1b221d45081ea460d /media-video/ffmpegthumbnailer
parentNew addition, mainly written by rei4dan (diff)
downloadgentoo-2-c286751011f4c7bf902de6cd8f981fd96b1061fc.tar.gz
gentoo-2-c286751011f4c7bf902de6cd8f981fd96b1061fc.tar.bz2
gentoo-2-c286751011f4c7bf902de6cd8f981fd96b1061fc.zip
Fix building with sys-devel/gcc >= 4.6 wrt #357305 by Ryan Hill.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog6
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild4
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-gcc46.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index b7d3d985505c..d2e8ad1ba7fc 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.113 2011/01/22 18:05:18 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.114 2011/03/26 15:20:48 ssuominen Exp $
+
+ 26 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ ffmpegthumbnailer-2.0.6.ebuild, +files/ffmpegthumbnailer-2.0.6-gcc46.patch:
+ Fix building with sys-devel/gcc >= 4.6 wrt #357305 by Ryan Hill.
22 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
ffmpegthumbnailer-2.0.4.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
index 641fae116a49..fe8de338fcaf 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.2 2011/01/09 14:05:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.3 2011/03/26 15:20:48 ssuominen Exp $
EAPI=2
inherit autotools eutils
@@ -23,7 +23,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{asneeded,flags}.patch
+ epatch "${FILESDIR}"/${P}-{asneeded,flags,gcc46}.patch
eautoreconf
}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-gcc46.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-gcc46.patch
new file mode 100644
index 000000000000..71f0fd9acd63
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-gcc46.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/357305
+http://code.google.com/p/ffmpegthumbnailer/issues/detail?id=83&can=1
+
+--- a/libffmpegthumbnailer/filmstripfilter.cpp
++++ b/libffmpegthumbnailer/filmstripfilter.cpp
+@@ -14,6 +14,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++#include <cstddef>
+ #include "filmstripfilter.h"
+ #include "filmstrip.h"
+