summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-26 16:07:56 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-26 16:07:56 +0000
commit9b8746be85d6b5452be59032c4f140f05c48a305 (patch)
tree0284aaf17920cf59ab60325cb78af4f594ffad43 /media-video/ffmpegthumbnailer
parentapp-admin/setools: new upstream bugfix release. (diff)
downloadgentoo-2-9b8746be85d6b5452be59032c4f140f05c48a305.tar.gz
gentoo-2-9b8746be85d6b5452be59032c4f140f05c48a305.tar.bz2
gentoo-2-9b8746be85d6b5452be59032c4f140f05c48a305.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.2.1.ebuild37
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.2.1-asneeded.patch8
3 files changed, 53 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 07a82fcc3306..bc58b5a01f02 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.30 2008/02/16 14:25:25 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.31 2008/02/26 16:07:55 drac Exp $
+
+*ffmpegthumbnailer-1.2.1 (26 Feb 2008)
+
+ 26 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ +files/ffmpegthumbnailer-1.2.1-asneeded.patch,
+ +ffmpegthumbnailer-1.2.1.ebuild:
+ Version bump.
*ffmpegthumbnailer-1.1.5 (16 Feb 2008)
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.2.1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.2.1.ebuild
new file mode 100644
index 000000000000..869baeff3510
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.2.1.ebuild,v 1.1 2008/02/26 16:07:55 drac Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ media-libs/jpeg
+ >=media-video/ffmpeg-0.4.9_p20070330"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautomake
+}
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.2.1-asneeded.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.2.1-asneeded.patch
new file mode 100644
index 000000000000..8e80fc3b4c6e
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.2.1-asneeded.patch
@@ -0,0 +1,8 @@
+diff -ur ffmpegthumbnailer-1.2.1.orig/src/libffmpegthumbnailer/Makefile.am ffmpegthumbnailer-1.2.1/src/libffmpegthumbnailer/Makefile.am
+--- ffmpegthumbnailer-1.2.1.orig/src/libffmpegthumbnailer/Makefile.am 2008-02-26 13:40:33.000000000 +0200
++++ ffmpegthumbnailer-1.2.1/src/libffmpegthumbnailer/Makefile.am 2008-02-26 18:01:22.000000000 +0200
+@@ -11,3 +11,4 @@
+
+ libffmpegthumbnailer_includedir = $(includedir)/libffmpegthumbnailer
+ libffmpegthumbnailer_la_LDFLAGS = -version-info 2:0:0
++libffmpegthumbnailer_la_LIBADD = $(FFMPEG_LIBS) $(PNG_LIBS) -ljpeg