summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-05 20:13:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-05 20:13:42 +0000
commit921307133b7e0c0e9df240ac95d393efdeda916c (patch)
treeae9bca7d1f56b78a35d3dc1f774ba09e0cae3c56 /media-video/ffmpegthumbnailer
parentFixup distutils-r1 conversion. (diff)
downloadgentoo-2-921307133b7e0c0e9df240ac95d393efdeda916c.tar.gz
gentoo-2-921307133b7e0c0e9df240ac95d393efdeda916c.tar.bz2
gentoo-2-921307133b7e0c0e9df240ac95d393efdeda916c.zip
old
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog7
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7-r1.ebuild42
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.7-r238-r241.patch80
3 files changed, 6 insertions, 123 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 934130f6f992..f1e933621b4e 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.149 2013/04/05 18:14:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.150 2013/04/05 20:13:41 ssuominen Exp $
+
+ 05 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -ffmpegthumbnailer-2.0.7-r1.ebuild,
+ -files/ffmpegthumbnailer-2.0.7-r238-r241.patch:
+ old
05 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
ffmpegthumbnailer-2.0.8.ebuild, +files/ffmpegthumbnailer-2.0.8-memcpy.patch:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7-r1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7-r1.ebuild
deleted file mode 100644
index 7f7cddcfddf5..000000000000
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7-r1.ebuild,v 1.8 2012/08/05 18:09:47 armin76 Exp $
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
-HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="gtk jpeg png"
-
-COMMON_DEPEND=">=virtual/ffmpeg-0.10.2
- png? ( >=media-libs/libpng-1.2:0 )
- jpeg? ( virtual/jpeg )"
-RDEPEND="${COMMON_DEPEND}
- gtk? ( >=dev-libs/glib-2.14 )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog README"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-r238-r241.patch
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable png) \
- $(use_enable jpeg) \
- $(use_enable gtk gio)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -exec rm -f {} +
-}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.7-r238-r241.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.7-r238-r241.patch
deleted file mode 100644
index 0f9b21099f96..000000000000
--- a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.7-r238-r241.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-This is `svn diff -r238:241 http://ffmpegthumbnailer.googlecode.com/svn/trunk` but without unnecessary configure.ac
-indentation cleanup.
-
---- libffmpegthumbnailer/moviedecoder.cpp
-+++ libffmpegthumbnailer/moviedecoder.cpp
-@@ -58,19 +58,26 @@
- void MovieDecoder::initialize(const string& filename)
- {
- av_register_all();
-- avcodec_init();
- avcodec_register_all();
-
- string inputFile = filename == "-" ? "pipe:" : filename;
- m_AllowSeek = (filename != "-") && (filename.find("rtsp://") != 0);
--
-+
-+#if LIBAVCODEC_VERSION_MAJOR < 53
- if ((!m_FormatContextWasGiven) && av_open_input_file(&m_pFormatContext, inputFile.c_str(), NULL, 0, NULL) != 0)
-+#else
-+ if ((!m_FormatContextWasGiven) && avformat_open_input(&m_pFormatContext, inputFile.c_str(), NULL, NULL) != 0)
-+#endif
- {
- destroy();
- throw logic_error(string("Could not open input file: ") + filename);
- }
-
-+#if LIBAVCODEC_VERSION_MAJOR < 53
- if (av_find_stream_info(m_pFormatContext) < 0)
-+#else
-+ if (avformat_find_stream_info(m_pFormatContext, NULL) < 0)
-+#endif
- {
- destroy();
- throw logic_error(string("Could not find stream information"));
-@@ -90,8 +97,12 @@
-
- if ((!m_FormatContextWasGiven) && m_pFormatContext)
- {
-+#if LIBAVCODEC_VERSION_MAJOR < 53
- av_close_input_file(m_pFormatContext);
- m_pFormatContext = NULL;
-+#else
-+ avformat_close_input(&m_pFormatContext);
-+#endif
- }
-
- if (m_pPacket)
-@@ -159,7 +170,11 @@
-
- m_pVideoCodecContext->workaround_bugs = 1;
-
-+#if LIBAVCODEC_VERSION_MAJOR < 53
- if (avcodec_open(m_pVideoCodecContext, m_pVideoCodec) < 0)
-+#else
-+ if (avcodec_open2(m_pVideoCodecContext, m_pVideoCodec, NULL) < 0)
-+#endif
- {
- throw logic_error("Could not open video codec");
- }
---- main.cpp
-+++ main.cpp
-@@ -243,10 +243,18 @@
- freeFunc(pPath);
- }
- }
-+ else
-+ {
-+ cerr << "Not a native file, thumbnailing will likely fail" << endl;
-+ }
-
- unrefFunc(pFile);
- }
- }
-+ else
-+ {
-+ cerr << "Failed to load gio libraries" << endl;
-+ }
-
- if (gioLib) dlclose(gioLib);
- if (gobjectLib) dlclose(gobjectLib);