summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-02 13:07:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-02 13:07:26 +0000
commitf7b3823579f2553bf8fbd3b6d2cb5be430856be0 (patch)
treea01bce955036f1abc5b4e3e39170d5f32e0630f9 /media-video/ffmpeg
parentUse system media-sound/cdparanoia instead of internal copy wrt #206939 by Die... (diff)
downloadgentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.tar.gz
gentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.tar.bz2
gentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.zip
add flite useflag
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 10 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 8c3f693e9631..624ab80bd1d7 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.572 2012/07/23 22:44:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.573 2012/08/02 13:07:26 aballier Exp $
+
+ 02 Aug 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add flite useflag
23 Jul 2012; Anthony G. Basile <blueness@gentoo.org> ffmpeg-0.11.1.ebuild,
ffmpeg-9999.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 37a3087e11fb..91038b9183e7 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.100 2012/07/23 22:44:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.101 2012/08/02 13:07:26 aballier Exp $
EAPI="4"
@@ -30,7 +30,7 @@ if [ "${PV#9999}" = "${PV}" ] ; then
fi
IUSE="
aac aacplus alsa amr avresample bindist bluray +bzip2 cdio celt
- cpudetection debug doc +encode faac fontconfig frei0r gnutls gsm
+ cpudetection debug doc +encode faac flite fontconfig frei0r gnutls gsm
+hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libcaca libv4l
modplug mp3 network openal openssl opus oss pic pulseaudio rtmp schroedinger
sdl speex static-libs test theora threads truetype v4l vaapi vdpau vorbis
@@ -68,6 +68,7 @@ RDEPEND="
x264? ( >=media-libs/x264-0.0.20111017 )
xvid? ( >=media-libs/xvid-1.1.0 )
)
+ flite? ( app-accessibility/flite )
fontconfig? ( media-libs/fontconfig )
frei0r? ( media-plugins/frei0r-plugins )
gnutls? ( >=net-libs/gnutls-2.12.16 )
@@ -185,6 +186,7 @@ src_configure() {
use ${i} && myconf="${myconf} --enable-${i}"
done
use truetype && myconf="${myconf} --enable-libfreetype"
+ use flite && myconf="${myconf} --enable-libflite"
# Threads; we only support pthread for now but ffmpeg supports more
use threads && myconf="${myconf} --enable-pthreads"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 93210884fe9e..f7798e569231 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -21,6 +21,7 @@
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
<flag name="faac">Use external faac library for AAC encoding</flag>
+ <flag name="flite">Adds a text-to-speech filter based on <pkg>app-accessibility/flite</pkg>.</flag>
<flag name="frei0r">Enable frei0r wrapping in libavfilter</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="iec61883"> Support for FireWire DV/HDV input device using <pkg>media-libs/libiec61883</pkg>.</flag>