summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-10-11 19:54:18 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-10-11 19:54:18 +0000
commitd9fad8d3f7cbf31219e5496b75503630bd93b550 (patch)
tree665365a77727e79f3bdd6fcab5abe9e88b9f82ac /media-video/em8300-modules
parentapp-editors/katoob: update gtksourceview deps (see bug #195366) (diff)
downloadgentoo-2-d9fad8d3f7cbf31219e5496b75503630bd93b550.tar.gz
gentoo-2-d9fad8d3f7cbf31219e5496b75503630bd93b550.tar.bz2
gentoo-2-d9fad8d3f7cbf31219e5496b75503630bd93b550.zip
Added patch to make it work with kernel 2.6.23, thanks to Helmut Auer <helmut@helmutauer.de>
(Portage version: 2.1.3.12)
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog8
-rw-r--r--media-video/em8300-modules/em8300-modules-0.16.2.ebuild3
-rw-r--r--media-video/em8300-modules/files/em8300-modules-0.16.2-kernel-2.6.23.patch10
3 files changed, 19 insertions, 2 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index e690b886665a..643eaa94238b 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-modules
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.42 2007/07/10 13:40:17 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.43 2007/10/11 19:54:18 zzam Exp $
+
+ 11 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/em8300-modules-0.16.2-kernel-2.6.23.patch,
+ em8300-modules-0.16.2.ebuild:
+ Added patch to make it work with kernel 2.6.23, thanks to Helmut Auer
+ <helmut@helmutauer.de>
10 Jul 2007; Matthias Schwarzott <zzam@gentoo.org>
+files/em8300-modules-0.16.2-pci-module-init.patch,
diff --git a/media-video/em8300-modules/em8300-modules-0.16.2.ebuild b/media-video/em8300-modules/em8300-modules-0.16.2.ebuild
index 1434243b8042..9dc543560921 100644
--- a/media-video/em8300-modules/em8300-modules-0.16.2.ebuild
+++ b/media-video/em8300-modules/em8300-modules-0.16.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.16.2.ebuild,v 1.2 2007/07/10 13:40:17 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.16.2.ebuild,v 1.3 2007/10/11 19:54:18 zzam Exp $
inherit eutils linux-mod
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${A}
cd "${S}/.."
epatch "${FILESDIR}/${P}-pci-module-init.patch"
+ epatch "${FILESDIR}/${P}-kernel-2.6.23.patch"
}
src_compile() {
diff --git a/media-video/em8300-modules/files/em8300-modules-0.16.2-kernel-2.6.23.patch b/media-video/em8300-modules/files/em8300-modules-0.16.2-kernel-2.6.23.patch
new file mode 100644
index 000000000000..f01b28b3a2cb
--- /dev/null
+++ b/media-video/em8300-modules/files/em8300-modules-0.16.2-kernel-2.6.23.patch
@@ -0,0 +1,10 @@
+--- a/modules/em8300_ioctl.c 2007-10-11 10:46:18.678481128 +0200
++++ b/modules/em8300_ioctl.c 2007-10-11 10:46:03.847449878 +0200
+@@ -15,6 +15,7 @@
+ #include <linux/string.h>
+ #include <linux/pci.h>
+ #include <asm/io.h>
++#include <asm/ioctl.h>
+ #include <asm/uaccess.h>
+ #include <linux/wait.h>
+