summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-03-04 03:56:58 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-03-04 03:56:58 +0000
commit0f470fd4ac155420d0d4cddce5eefc841113a456 (patch)
tree2a2a879adff160e07267e0f9c41519d327fc0573 /media-video/em8300-modules
parentBump network to 2.3.0.11 (diff)
downloadgentoo-2-0f470fd4ac155420d0d4cddce5eefc841113a456.tar.gz
gentoo-2-0f470fd4ac155420d0d4cddce5eefc841113a456.tar.bz2
gentoo-2-0f470fd4ac155420d0d4cddce5eefc841113a456.zip
snapshot for testing, pmasked, bug #350211
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog10
-rw-r--r--media-video/em8300-modules/em8300-modules-0.18.0_p20120124.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index f33cff0dd9f2..2d7a247fe533 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-modules
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.56 2010/10/20 13:31:46 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.57 2012/03/04 03:56:58 hd_brummy Exp $
+
+*em8300-modules-0.18.0_p20120124 (04 Mar 2012)
+
+ 04 Mar 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +em8300-modules-0.18.0_p20120124.ebuild:
+ snapshot for testing, pmasked, bug #350211
20 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
em8300-modules-0.18.0.ebuild, +files/em8300-modules-0.18.0-2.6.35.patch:
diff --git a/media-video/em8300-modules/em8300-modules-0.18.0_p20120124.ebuild b/media-video/em8300-modules/em8300-modules-0.18.0_p20120124.ebuild
new file mode 100644
index 000000000000..2ddca84df6b5
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.18.0_p20120124.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.18.0_p20120124.ebuild,v 1.1 2012/03/04 03:56:58 hd_brummy Exp $
+
+EAPI=2
+inherit eutils linux-mod
+
+MY_P=${P/-modules}
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="http://vdr.websitec.de/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/linux-sources"
+
+CONFIG_CHECK="I2C"
+MODULE_NAMES="em8300(video:) bt865(video:) adv717x(video:)"
+
+S=${WORKDIR}/${MY_P}/modules
+
+src_compile() {
+ set_arch_to_kernel
+ emake KERNEL_LOCATION="${KERNEL_DIR}" || die
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README-modoptions README-modules.conf
+
+ newsbin devices.sh em8300-devices.sh
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/modules.em8300 em8300.conf
+
+ insinto /etc/udev/rules.d
+ newins em8300-udev.rules 15-em8300.rules
+}
+
+pkg_preinst() {
+ linux-mod_pkg_preinst
+
+ local old1="${ROOT}/etc/modprobe.d/em8300"
+ local old2="${ROOT}/etc/modules.d/em8300"
+ local new="${ROOT}/etc/modprobe.d/em8300.conf"
+
+ if [[ ! -a ${new} ]]; then
+ if [[ -a ${old1} ]]; then
+ elog "Renaming em8300-modprobe configuration to em8300.conf"
+ mv "${old1}" "${new}"
+ elif [[ -a ${old2} ]]; then
+ elog "Moving old em8300 configuration in /etc/modules.d to new"
+ elog "location in /etc/modprobe.d"
+ mv "${old2}" "${new}"
+ fi
+ fi
+}