summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-07-19 06:32:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-07-19 06:32:21 +0000
commita14d3c6ef184c8f39e71681281bc3472a5def0d5 (patch)
treecf76ed02797109a7a73bb884cd25374fb71a8b6d /media-video/devede
parentUpdate live ebuild for proper multi-slot building. (diff)
downloadgentoo-2-a14d3c6ef184c8f39e71681281bc3472a5def0d5.tar.gz
gentoo-2-a14d3c6ef184c8f39e71681281bc3472a5def0d5.tar.bz2
gentoo-2-a14d3c6ef184c8f39e71681281bc3472a5def0d5.zip
Bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-video/devede')
-rw-r--r--media-video/devede/ChangeLog8
-rw-r--r--media-video/devede/devede-3.22.0.ebuild56
2 files changed, 62 insertions, 2 deletions
diff --git a/media-video/devede/ChangeLog b/media-video/devede/ChangeLog
index 07ad39e3c771..c8bf33280b25 100644
--- a/media-video/devede/ChangeLog
+++ b/media-video/devede/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/devede
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.41 2012/06/08 11:58:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.42 2012/07/19 06:32:21 patrick Exp $
+
+*devede-3.22.0 (19 Jul 2012)
+
+ 19 Jul 2012; Patrick Lauer <patrick@gentoo.org> +devede-3.22.0.ebuild:
+ Bump
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> devede-3.21.0.ebuild:
x86 stable wrt bug #419139
@@ -182,4 +187,3 @@
17 Jun 2007; Samuli Suominen <drac@gentoo.org> +devede-2.13.ebuild:
Initial commit for bug 139986.
-
diff --git a/media-video/devede/devede-3.22.0.ebuild b/media-video/devede/devede-3.22.0.ebuild
new file mode 100644
index 000000000000..435b846e6ac0
--- /dev/null
+++ b/media-video/devede/devede-3.22.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.22.0.ebuild,v 1.1 2012/07/19 06:32:21 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players."
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# from upstream ChangeLog in 3.21.0: Now uses FFMpeg as the default backend
+IUSE="+ffmpeg"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ >=dev-python/pygtk-2.16
+ media-video/dvdauthor
+ media-video/mplayer
+ media-video/vcdimager
+ virtual/cdrtools
+ ffmpeg? ( virtual/ffmpeg[mp3] )"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ./install.sh DESTDIR="${D}" libdir="/usr/$(get_libdir)" \
+ pkgdocdir=/usr/share/doc/${PF} prefix=/usr || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}