summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-24 04:39:52 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-24 04:39:52 +0000
commitaf5f2efd81afbbeb107997aefb4a5ab93047d4b8 (patch)
tree83e66582fcd40c868ea52ca6a893ec86113ac57c /media-video/clive
parentRemove old. (diff)
downloadgentoo-2-af5f2efd81afbbeb107997aefb4a5ab93047d4b8.tar.gz
gentoo-2-af5f2efd81afbbeb107997aefb4a5ab93047d4b8.tar.bz2
gentoo-2-af5f2efd81afbbeb107997aefb4a5ab93047d4b8.zip
Version bump.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.28.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 59e27dd9a388..5540485e1194 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.70 2011/08/17 06:33:10 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.71 2011/10/24 04:39:52 radhermit Exp $
+
+*clive-2.2.28 (24 Oct 2011)
+
+ 24 Oct 2011; Tim Harder <radhermit@gentoo.org> +clive-2.2.28.ebuild:
+ Version bump.
*clive-2.2.26 (17 Aug 2011)
diff --git a/media-video/clive/clive-2.2.28.ebuild b/media-video/clive/clive-2.2.28.ebuild
new file mode 100644
index 000000000000..913b52ffb7d7
--- /dev/null
+++ b/media-video/clive/clive-2.2.28.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.28.ebuild,v 1.1 2011/10/24 04:39:52 radhermit Exp $
+
+EAPI=4
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND="test? ( dev-perl/Test-Pod
+ ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}