summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-08-30 13:41:34 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-08-30 13:41:34 +0000
commit2d5a4093f8caecc4b19d44b38ee63a63e88442e9 (patch)
tree003d3418d8cafc8f3cba3d1d1bf86ba0d3932521 /media-video/chaplin
parentInitial import. Ebuild by me. Theme by blackace. Since this is used on the... (diff)
downloadgentoo-2-2d5a4093f8caecc4b19d44b38ee63a63e88442e9.tar.gz
gentoo-2-2d5a4093f8caecc4b19d44b38ee63a63e88442e9.tar.bz2
gentoo-2-2d5a4093f8caecc4b19d44b38ee63a63e88442e9.zip
Added patch to work with libdvdread-0.9.6, requested in Bug #138525. General ebuild cleanup.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'media-video/chaplin')
-rw-r--r--media-video/chaplin/ChangeLog7
-rw-r--r--media-video/chaplin/chaplin-1.10-r1.ebuild16
-rw-r--r--media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch11
3 files changed, 26 insertions, 8 deletions
diff --git a/media-video/chaplin/ChangeLog b/media-video/chaplin/ChangeLog
index 9a633ea0b205..be53eafdfe4e 100644
--- a/media-video/chaplin/ChangeLog
+++ b/media-video/chaplin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/chaplin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/ChangeLog,v 1.6 2006/08/21 17:58:56 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/ChangeLog,v 1.7 2006/08/30 13:41:34 zzam Exp $
+
+ 30 Aug 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/chaplin-1.10-libdvdread-0.9.6.patch, chaplin-1.10-r1.ebuild:
+ Added patch to work with libdvdread-0.9.6, requested in Bug #138525. General
+ ebuild cleanup.
*chaplin-1.10-r1 (21 Aug 2006)
diff --git a/media-video/chaplin/chaplin-1.10-r1.ebuild b/media-video/chaplin/chaplin-1.10-r1.ebuild
index 5ef0e4b1cc02..e1b43ea0a416 100644
--- a/media-video/chaplin/chaplin-1.10-r1.ebuild
+++ b/media-video/chaplin/chaplin-1.10-r1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/chaplin-1.10-r1.ebuild,v 1.1 2006/08/21 17:58:56 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/chaplin-1.10-r1.ebuild,v 1.2 2006/08/30 13:41:34 zzam Exp $
+
+inherit eutils
IUSE="transcode vcd"
-MY_S="${WORKDIR}/chaplin"
+S="${WORKDIR}/${PN}"
DESCRIPTION="This is a program to raw copy chapters from a dvd using libdvdread"
HOMEPAGE="http://www.lallafa.de/bp/chaplin.html"
@@ -19,12 +21,12 @@ DEPEND=">=media-libs/libdvdread-0.9.4
transcode? ( >=media-video/transcode-0.6.2 )
vcd? ( >=media-video/vcdimager-0.7.2 )"
-src_compile() {
- cd ${MY_S} || die
- emake || die
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-libdvdread-0.9.6.patch"
}
src_install() {
- dobin ${MY_S}/chaplin || die
- dobin ${MY_S}/chaplin-genmenu || die
+ dobin chaplin || die "Failed installing file chaplin"
+ dobin chaplin-genmenu || die "Failed installing file chaplin-genmenu"
}
diff --git a/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch b/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch
new file mode 100644
index 000000000000..7e68dd67a692
--- /dev/null
+++ b/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch
@@ -0,0 +1,11 @@
+diff -N -u -r chaplin/chaplin.c chaplin-new/chaplin.c
+--- chaplin/chaplin.c 2004-03-21 18:45:44.000000000 +0100
++++ chaplin-new/chaplin.c 2006-06-29 22:36:54.457745979 +0200
+@@ -18,6 +18,7 @@
+ #include <ctype.h>
+ #include <string.h>
+ #include <math.h>
++#include <inttypes.h>
+
+ /* libdvdread stuff */
+ #include <dvdread/dvd_reader.h>