summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-22 13:57:40 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-22 13:57:40 +0000
commit1e520a3d7ee20945e739892ccc1bb82ff6128b88 (patch)
treefd35b0ed4f59603427ed3639d9a559dda1a154b6 /media-video/camserv
parentFixed depends for kde-4, bug 206732, thank Ingmar Vanhassel for the fix. Upda... (diff)
downloadgentoo-2-1e520a3d7ee20945e739892ccc1bb82ff6128b88.tar.gz
gentoo-2-1e520a3d7ee20945e739892ccc1bb82ff6128b88.tar.bz2
gentoo-2-1e520a3d7ee20945e739892ccc1bb82ff6128b88.zip
Attempt to fix broken libtool handling wrt #188149.
(Portage version: 2.1.4)
Diffstat (limited to 'media-video/camserv')
-rw-r--r--media-video/camserv/ChangeLog9
-rw-r--r--media-video/camserv/camserv-0.5.1-r2.ebuild35
-rw-r--r--media-video/camserv/files/camserv-0.5.1-libtool.patch92
-rw-r--r--media-video/camserv/files/camserv-0.5.1-memcpy.patch11
4 files changed, 125 insertions, 22 deletions
diff --git a/media-video/camserv/ChangeLog b/media-video/camserv/ChangeLog
index d9c7b3747e15..c103bd5ff57d 100644
--- a/media-video/camserv/ChangeLog
+++ b/media-video/camserv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/camserv
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camserv/ChangeLog,v 1.19 2007/11/27 11:58:01 zzam Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/camserv/ChangeLog,v 1.20 2008/01/22 13:57:39 drac Exp $
+
+ 22 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/camserv-0.5.1-libtool.patch, +files/camserv-0.5.1-memcpy.patch,
+ camserv-0.5.1-r2.ebuild:
+ Attempt to fix broken libtool handling wrt #188149.
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org>
camserv-0.5.1-r2.ebuild:
diff --git a/media-video/camserv/camserv-0.5.1-r2.ebuild b/media-video/camserv/camserv-0.5.1-r2.ebuild
index bb1257d1a935..5665d90f7634 100644
--- a/media-video/camserv/camserv-0.5.1-r2.ebuild
+++ b/media-video/camserv/camserv-0.5.1-r2.ebuild
@@ -1,41 +1,36 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camserv/camserv-0.5.1-r2.ebuild,v 1.10 2007/11/27 11:58:01 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camserv/camserv-0.5.1-r2.ebuild,v 1.11 2008/01/22 13:57:39 drac Exp $
-inherit eutils autotools
+WANT_AUTOCONF=2.5
+WANT_AUTOMAKE=1.6
+
+inherit autotools eutils
DESCRIPTION="A streaming video server"
-HOMEPAGE="http://cserv.sourceforge.net/"
+HOMEPAGE="http://cserv.sourceforge.net"
SRC_URI="mirror://sourceforge/cserv/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-RDEPEND=">=media-libs/jpeg-6b-r2
- >=media-libs/imlib-1.9.13-r2"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.58
- =sys-devel/automake-1.6*
- sys-devel/libtool"
+RDEPEND="media-libs/jpeg
+ media-libs/imlib"
+DEPEND="${RDEPEND}"
src_unpack() {
- # make sure it uses autoconf 2.5 as there seems to be problems.
- # See bug #106013
- export WANT_AUTOCONF="2.5"
- export WANT_AUTOMAKE="1.6"
-
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PN}-0.5-errno.patch"
+ epatch "${FILESDIR}"/${P/.1}-errno.patch
+ epatch "${FILESDIR}"/${P}-libtool.patch
+ epatch "${FILESDIR}"/${P}-memcpy.patch
AT_M4DIR="${S}/macros" eautoreconf
}
src_install() {
- make install DESTDIR="${D}" || die
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS BUGS ChangeLog NEWS README TODO javascript.txt
-
newinitd "${FILESDIR}"/camserv.init camserv
}
diff --git a/media-video/camserv/files/camserv-0.5.1-libtool.patch b/media-video/camserv/files/camserv-0.5.1-libtool.patch
new file mode 100644
index 000000000000..f7b1e478537c
--- /dev/null
+++ b/media-video/camserv/files/camserv-0.5.1-libtool.patch
@@ -0,0 +1,92 @@
+diff -ur camserv-0.5.1.orig/camserv/filter.c camserv-0.5.1/camserv/filter.c
+--- camserv-0.5.1.orig/camserv/filter.c 2002-05-12 21:05:55.000000000 +0300
++++ camserv-0.5.1/camserv/filter.c 2008-01-22 15:43:05.000000000 +0200
+@@ -20,8 +20,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <ltdl.h>
+
+-#include "ltdl.h"
+ #include "log.h"
+ #include "camconfig.h"
+ #include "filter.h"
+diff -ur camserv-0.5.1.orig/camserv/Makefile.am camserv-0.5.1/camserv/Makefile.am
+--- camserv-0.5.1.orig/camserv/Makefile.am 2002-09-16 01:17:54.000000000 +0300
++++ camserv-0.5.1/camserv/Makefile.am 2008-01-22 15:48:37.000000000 +0200
+@@ -5,8 +5,7 @@
+ LDFLAGS = @LDFLAGS@ -export-dynamic
+
+ bin_PROGRAMS = camserv
+-camserv_LDADD = $(LIBLTDL) $(top_srcdir)/common/libcommon.a
+-camserv_DEPENDENCIES = $(LIBLTDL)
++camserv_LDADD = -lltdl $(top_srcdir)/common/libcommon.a
+ camserv_SOURCES= \
+ camconfig.c \
+ camserv.c \
+diff -ur camserv-0.5.1.orig/camserv/video.c camserv-0.5.1/camserv/video.c
+--- camserv-0.5.1.orig/camserv/video.c 2002-05-12 21:05:55.000000000 +0300
++++ camserv-0.5.1/camserv/video.c 2008-01-22 15:43:05.000000000 +0200
+@@ -20,8 +20,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <ltdl.h>
+
+-#include "ltdl.h"
+ #include "log.h"
+ #include "video.h"
+
+diff -ur camserv-0.5.1.orig/common/Makefile.am camserv-0.5.1/common/Makefile.am
+--- camserv-0.5.1.orig/common/Makefile.am 2002-09-16 00:33:10.000000000 +0300
++++ camserv-0.5.1/common/Makefile.am 2008-01-22 15:43:05.000000000 +0200
+@@ -1,4 +1,4 @@
+-INCLUDES = -I$(srcdir)/include -I${top_srcdir}/libltdl
++INCLUDES = -I$(srcdir)/include
+ CFLAGS = @CFLAGS@ -g -DNDEBUG
+
+ common_sources = \
+diff -ur camserv-0.5.1.orig/common/modinfo.c camserv-0.5.1/common/modinfo.c
+--- camserv-0.5.1.orig/common/modinfo.c 2002-05-12 21:05:55.000000000 +0300
++++ camserv-0.5.1/common/modinfo.c 2008-01-22 15:43:05.000000000 +0200
+@@ -20,9 +20,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <ltdl.h>
+
+ #include "log.h"
+-#include "ltdl.h"
+ #include "modinfo.h"
+
+ #define MODNAME "modinfo"
+diff -ur camserv-0.5.1.orig/configure.in camserv-0.5.1/configure.in
+--- camserv-0.5.1.orig/configure.in 2002-05-12 21:06:12.000000000 +0300
++++ camserv-0.5.1/configure.in 2008-01-22 15:48:17.000000000 +0200
+@@ -12,12 +12,8 @@
+ AM_ACLOCAL_INCLUDE(macros)
+
+ AC_PROG_CC
+-AC_LIBLTDL_CONVENIENCE
+-AC_LIBTOOL_DLOPEN
+-AM_PROG_LIBTOOL
+-AC_SUBST(LIBLTDL)
+
+-AC_CONFIG_SUBDIRS(libltdl)
++AC_PROG_LIBTOOL
+
+ AC_CHECK_LIB(m,sqrt)
+ AC_CHECK_LIB(jpeg,jpeg_start_compress)
+diff -ur camserv-0.5.1.orig/Makefile.am camserv-0.5.1/Makefile.am
+--- camserv-0.5.1.orig/Makefile.am 2002-03-11 02:52:29.000000000 +0200
++++ camserv-0.5.1/Makefile.am 2008-01-22 15:43:05.000000000 +0200
+@@ -4,8 +4,7 @@
+
+ datadir = @datadir@/camserv
+
+-SUBDIRS = libltdl \
+- common \
++SUBDIRS = common \
+ ${camserv_subdir} \
+ include \
+ macros \
diff --git a/media-video/camserv/files/camserv-0.5.1-memcpy.patch b/media-video/camserv/files/camserv-0.5.1-memcpy.patch
new file mode 100644
index 000000000000..d3daa1cad3dc
--- /dev/null
+++ b/media-video/camserv/files/camserv-0.5.1-memcpy.patch
@@ -0,0 +1,11 @@
+diff -ur camserv-0.5.1.orig/camserv/jpg_filter.c camserv-0.5.1/camserv/jpg_filter.c
+--- camserv-0.5.1.orig/camserv/jpg_filter.c 2002-05-12 21:05:55.000000000 +0300
++++ camserv-0.5.1/camserv/jpg_filter.c 2008-01-22 01:41:14.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
++#include <string.h>
+
+ #include "camserv.h"
+ #include "log.h"