summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-30 11:56:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-30 11:56:18 +0000
commit2347940919a4fdbadef9fda806041abb69cd3c34 (patch)
treefb31c17b169e659eb96d9f3dfbd9062b07e24006 /media-video/camorama
parentVersion bump; use the tarball rather than the gem so that the tests run durin... (diff)
downloadgentoo-2-2347940919a4fdbadef9fda806041abb69cd3c34.tar.gz
gentoo-2-2347940919a4fdbadef9fda806041abb69cd3c34.tar.bz2
gentoo-2-2347940919a4fdbadef9fda806041abb69cd3c34.zip
Bump to 0.19-r1, fix sandbox violation due to gconf, bug #243274.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'media-video/camorama')
-rw-r--r--media-video/camorama/ChangeLog9
-rw-r--r--media-video/camorama/camorama-0.19-r1.ebuild36
-rw-r--r--media-video/camorama/camorama-0.19.ebuild6
-rw-r--r--media-video/camorama/files/camorama-0.19-gconf.patch40
4 files changed, 89 insertions, 2 deletions
diff --git a/media-video/camorama/ChangeLog b/media-video/camorama/ChangeLog
index 547ea6ca3433..56532636fbb0 100644
--- a/media-video/camorama/ChangeLog
+++ b/media-video/camorama/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/camorama
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/ChangeLog,v 1.17 2008/01/23 19:53:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/ChangeLog,v 1.18 2008/11/30 11:56:17 eva Exp $
+
+*camorama-0.19-r1 (30 Nov 2008)
+
+ 30 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/camorama-0.19-gconf.patch, camorama-0.19.ebuild,
+ +camorama-0.19-r1.ebuild:
+ Bump to 0.19-r1, fix sandbox violation due to gconf, bug #243274.
23 Jan 2008; Markus Meier <maekke@gentoo.org> camorama-0.19.ebuild:
x86 stable, bug #207195
diff --git a/media-video/camorama/camorama-0.19-r1.ebuild b/media-video/camorama/camorama-0.19-r1.ebuild
new file mode 100644
index 000000000000..67508ce57494
--- /dev/null
+++ b/media-video/camorama/camorama-0.19-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/camorama-0.19-r1.ebuild,v 1.1 2008/11/30 11:56:17 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="a webcam application featuring various image filters."
+HOMEPAGE="http://camorama.fixedgear.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+SCROLLKEEPER_UPDATE="0"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix sandbox access violation, bug #243274
+ epatch "${FILESDIR}/${P}-gconf.patch"
+}
diff --git a/media-video/camorama/camorama-0.19.ebuild b/media-video/camorama/camorama-0.19.ebuild
index 95d8e40fd3a8..bd9f6b9f0fe9 100644
--- a/media-video/camorama/camorama-0.19.ebuild
+++ b/media-video/camorama/camorama-0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/camorama-0.19.ebuild,v 1.3 2008/01/23 19:53:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/camorama-0.19.ebuild,v 1.4 2008/11/30 11:56:17 eva Exp $
inherit gnome2
@@ -23,3 +23,7 @@ DEPEND="${RDEPEND}
dev-util/intltool"
SCROLLKEEPER_UPDATE="0"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-schemas-install"
+}
diff --git a/media-video/camorama/files/camorama-0.19-gconf.patch b/media-video/camorama/files/camorama-0.19-gconf.patch
new file mode 100644
index 000000000000..5a1a19e9b576
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-gconf.patch
@@ -0,0 +1,40 @@
+# Make camorama respect --disable-schemas-install configure switch
+# https://bugs.gentoo.org/show_bug.cgi?id=243274
+#
+# Makefile.am | 4 ++++
+# Makefile.in | 7 ++++---
+# 2 files changed, 8 insertions(+), 3 deletions(-)
+#
+#
+--- a/data/Makefile.am 2008-11-30 12:39:56.000000000 +0100
++++ b/data/Makefile.am 2008-11-30 12:41:33.000000000 +0100
+@@ -24,9 +24,13 @@
+ cp $(app_DATA) ~/.gnome/application-registry
+ cp $(keys_DATA) ~/.gnome/mime-info/
+
++if GCONF_SCHEMAS_INSTALL
+ install-data-local:
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
+ $(GCONFTOOL) --shutdown
++else
++install-data-local:
++endif
+
+ EXTRA_DIST = $(glade_DATA) $(schema_in_files) $(stuff_DATA)
+
+--- a/data/Makefile.in 2008-11-30 12:41:10.000000000 +0100
++++ b/data/Makefile.in 2008-11-30 12:42:24.000000000 +0100
+@@ -448,9 +437,10 @@
+ cp $(app_DATA) ~/.gnome/application-registry
+ cp $(keys_DATA) ~/.gnome/mime-info/
+
+-install-data-local:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
+- $(GCONFTOOL) --shutdown
++@GCONF_SCHEMAS_INSTALL_TRUE@install-data-local:
++@GCONF_SCHEMAS_INSTALL_TRUE@ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
++@GCONF_SCHEMAS_INSTALL_TRUE@ $(GCONFTOOL) --shutdown
++@GCONF_SCHEMAS_INSTALL_FALSE@install-data-local:
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: