summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-29 01:07:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-29 01:07:03 +0000
commitf39f728f6ef9129f463ed9b4514e3e9de46678a5 (patch)
treef175c8a9f2a9573e2e4534c3e26470b7b0abc47e /media-video/came
parentold (diff)
downloadgentoo-2-f39f728f6ef9129f463ed9b4514e3e9de46678a5.tar.gz
gentoo-2-f39f728f6ef9129f463ed9b4514e3e9de46678a5.tar.bz2
gentoo-2-f39f728f6ef9129f463ed9b4514e3e9de46678a5.zip
move from net-ftp #45968
Diffstat (limited to 'media-video/came')
-rw-r--r--media-video/came/came-1.3.ebuild21
-rw-r--r--media-video/came/came-1.7.ebuild28
2 files changed, 23 insertions, 26 deletions
diff --git a/media-video/came/came-1.3.ebuild b/media-video/came/came-1.3.ebuild
index a3f8ed96ab54..e51046d8d6df 100644
--- a/media-video/came/came-1.3.ebuild
+++ b/media-video/came/came-1.3.ebuild
@@ -1,28 +1,29 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/came/came-1.3.ebuild,v 1.3 2003/07/12 21:12:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/came/came-1.3.ebuild,v 1.4 2004/03/29 01:04:12 vapier Exp $
-S=${WORKDIR}/camE-${PV}
DESCRIPTION="camE is a rewrite of the xawtv webcam app, which adds imlib2 support and a lot of new features"
-SRC_URI="http://linuxbrit.co.uk/downloads/camE-${PV}.tar.gz"
HOMEPAGE="http://linuxbrit.co.uk/camE/"
+SRC_URI="http://linuxbrit.co.uk/downloads/camE-${PV}.tar.gz"
-DEPEND=">=net-ftp/curl-7.9.1
- >=media-libs/giblib-1.2.1"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+DEPEND=">=net-misc/curl-7.9.1
+ >=media-libs/giblib-1.2.1"
+
+S=${WORKDIR}/camE-${PV}
+
src_compile() {
mv Makefile Makefile_old
sed -e "s:/usr/local:/usr:" Makefile_old > Makefile
emake || die
}
-src_install () {
+src_install() {
insinto /usr
- dobin camE
+ dobin camE || die
dodoc AUTHORS
dodoc camE_text.style
dodoc camE_title.style
diff --git a/media-video/came/came-1.7.ebuild b/media-video/came/came-1.7.ebuild
index 07cdd7e5faac..9743dac947bb 100644
--- a/media-video/came/came-1.7.ebuild
+++ b/media-video/came/came-1.7.ebuild
@@ -1,30 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/came/came-1.7.ebuild,v 1.1 2003/12/29 10:58:33 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/came/came-1.7.ebuild,v 1.2 2004/03/29 01:04:12 vapier Exp $
-S=${WORKDIR}/camE-${PV}
DESCRIPTION="camE is a rewrite of the xawtv webcam app, which adds imlib2 support and a lot of new features"
-SRC_URI="http://linuxbrit.co.uk/downloads/camE-${PV}.tar.gz"
HOMEPAGE="http://linuxbrit.co.uk/camE/"
+SRC_URI="http://linuxbrit.co.uk/downloads/camE-${PV}.tar.gz"
-DEPEND=">=net-ftp/curl-7.9.1
- >=media-libs/giblib-1.2.3"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+DEPEND=">=net-misc/curl-7.9.1
+ >=media-libs/giblib-1.2.3"
+
+S=${WORKDIR}/camE-${PV}
+
src_compile() {
sed -i -e "s:/usr/local:/usr:" Makefile
emake || die
}
-src_install () {
- insinto /usr
- dobin camE
- dodoc AUTHORS
- dodoc camE_text.style
- dodoc camE_title.style
- dodoc example.camErc
- dodoc example.camErc.ssh
+src_install() {
+ dobin camE || die
+ dodoc AUTHORS camE_text.style camE_title.style example.camErc example.camErc.ssh
}