summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-03 09:54:22 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-03 09:54:22 +0000
commit6a76d0a09b5bc25db333222c7664c39fe046cdf9 (patch)
tree6b4846295ced34060d1a21bb5e4ead72af7e582f /media-video/bcast
parentnew comments (diff)
downloadgentoo-2-6a76d0a09b5bc25db333222c7664c39fe046cdf9.tar.gz
gentoo-2-6a76d0a09b5bc25db333222c7664c39fe046cdf9.tar.bz2
gentoo-2-6a76d0a09b5bc25db333222c7664c39fe046cdf9.zip
Dependencie fixes
Diffstat (limited to 'media-video/bcast')
-rw-r--r--media-video/bcast/bcast-2000c.ebuild29
-rw-r--r--media-video/bcast/files/bcast-2000c-gentoo.diff21
2 files changed, 32 insertions, 18 deletions
diff --git a/media-video/bcast/bcast-2000c.ebuild b/media-video/bcast/bcast-2000c.ebuild
index b7be9dd9e958..67b7e51248b3 100644
--- a/media-video/bcast/bcast-2000c.ebuild
+++ b/media-video/bcast/bcast-2000c.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/bcast/bcast-2000c.ebuild,v 1.1 2001/05/10 12:15:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/bcast/bcast-2000c.ebuild,v 1.2 2001/06/03 09:54:22 achim Exp $
A=${P}-src.tar.gz
S=${WORKDIR}/${P}
@@ -9,30 +9,25 @@ DESCRIPTION="Realtime audio and video editor"
SRC_URI="ftp://heroines.sourceforge.net/pub/heroines/${A}"
HOMEPAGE="http://heroines.sourceforge.net/"
+DEPEND="virtual/glibc dev-lang/nasm-0.98
+ >=sys-devel/gcc-2.95.2
+ >=dev-libs/glib-1.2.10
+ >=media-libs/libpng-1.0.7
+ virtual/x11"
+
DEPEND="virtual/glibc
>=sys-devel/gcc-2.95.2
- >=media-sound/esound-0.2.19
- >=media-libs/jpeg-6b
- >=media-libs/tiff-3.5.5
+ >=dev-libs/glib-1.2.10
>=media-libs/libpng-1.0.7
virtual/x11"
src_unpack() {
unpack ${A}
- cd ${S}/bcast
- cp main.C main.C.orig
- sed -e "s:/usr/local/bcast/plugins:/usr/X11R6/lib/bcast/plugins:" \
- main.C.orig > main.C
- cd ${S}/esound
- cp esd.h esd.h.orig
-# sed -e "s:<audiofile\.h>:\"\.\./audiofile/audiofile\.h\":" esd.h.orig > esd.h
- cd ${S}/quicktime/libdv
- cp dvprivate.h dvprivate.h.orig
-# sed -e "s:<libraw1394/raw1394\.h>:\"\.\./\.\./libraw1394/raw1394\.h\":" dvprivate.h.orig > dvprivate.h
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
+
src_compile() {
- cd ${S}
try ./configure
try make
@@ -40,8 +35,7 @@ src_compile() {
src_install () {
- cd ${S}
- into /usr
+ into /usr/X11R6
dobin bcast/bcast2000
dolib.so bcbase/libbcbase.so
dolib.so guicast/libguicast.so
@@ -51,7 +45,6 @@ src_install () {
dodoc COPYING
docinto html
dodoc docs/*.html docs/*.png docs/*.jpg
-
}
diff --git a/media-video/bcast/files/bcast-2000c-gentoo.diff b/media-video/bcast/files/bcast-2000c-gentoo.diff
new file mode 100644
index 000000000000..8cf70c3a580c
--- /dev/null
+++ b/media-video/bcast/files/bcast-2000c-gentoo.diff
@@ -0,0 +1,21 @@
+--- bcast-2000c/bcast/Makefile~ Tue Jan 2 22:27:16 2001
++++ bcast-2000c/bcast/Makefile Sat Jun 2 16:50:30 2001
+@@ -199,6 +199,7 @@
+ -I../quicktime/libdv \
+ -I../audiofile \
+ -I../esound \
++ -I../tiff \
+ $(shell glib-config --cflags)
+
+ export CFLAGS
+--- bcast-2000c/bcast/main.C~ Tue Jan 2 22:27:16 2001
++++ bcast-2000c/bcast/main.C Sat Jun 2 16:51:24 2001
+@@ -231,7 +231,7 @@
+ char path[1024];
+
+ // get the plugin directories
+- sprintf(global_plugin_dir, "/usr/local/bcast/plugins");
++ sprintf(global_plugin_dir, "/usr/X11R6/lib/bcast/plugins");
+ defaults->get("GLOBAL_PLUGIN_DIR", global_plugin_dir);
+ sprintf(local_plugin_dir, "");
+ defaults->get("LOCAL_PLUGIN_DIR", local_plugin_dir);