summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-21 21:55:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-21 21:55:46 +0000
commit942b53eb38c0da0c784a44871c7f775560a93d68 (patch)
tree612c1542aab21fa69ddb2b79f02790a7e95aaddb /media-video/atomicparsley
parentParallel make option and fix a nasty compile bug (diff)
downloadgentoo-2-942b53eb38c0da0c784a44871c7f775560a93d68.tar.gz
gentoo-2-942b53eb38c0da0c784a44871c7f775560a93d68.tar.bz2
gentoo-2-942b53eb38c0da0c784a44871c7f775560a93d68.zip
Fix building with glibc-2.10+ wrt #278143.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/atomicparsley')
-rw-r--r--media-video/atomicparsley/ChangeLog8
-rw-r--r--media-video/atomicparsley/atomicparsley-0.9.0.ebuild21
-rw-r--r--media-video/atomicparsley/files/atomicparsley-0.9.0-glibc-2.10.patch39
3 files changed, 56 insertions, 12 deletions
diff --git a/media-video/atomicparsley/ChangeLog b/media-video/atomicparsley/ChangeLog
index a64ed3c116ad..496f790145fd 100644
--- a/media-video/atomicparsley/ChangeLog
+++ b/media-video/atomicparsley/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/atomicparsley
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/atomicparsley/ChangeLog,v 1.14 2008/04/10 07:48:34 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/atomicparsley/ChangeLog,v 1.15 2009/07/21 21:55:46 ssuominen Exp $
+
+ 21 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ atomicparsley-0.9.0.ebuild, +files/atomicparsley-0.9.0-glibc-2.10.patch:
+ Fix building with glibc-2.10+ wrt #278143.
10 Apr 2008; Samuli Suominen <drac@gentoo.org> metadata.xml,
atomicparsley-0.9.0.ebuild:
diff --git a/media-video/atomicparsley/atomicparsley-0.9.0.ebuild b/media-video/atomicparsley/atomicparsley-0.9.0.ebuild
index 4c7b0e171ff0..2022e2acd137 100644
--- a/media-video/atomicparsley/atomicparsley-0.9.0.ebuild
+++ b/media-video/atomicparsley/atomicparsley-0.9.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/atomicparsley/atomicparsley-0.9.0.ebuild,v 1.11 2008/04/10 07:49:58 drac Exp $
-
-inherit toolchain-funcs
+# $Header: /var/cvsroot/gentoo-x86/media-video/atomicparsley/atomicparsley-0.9.0.ebuild,v 1.12 2009/07/21 21:55:46 ssuominen Exp $
+EAPI=2
MY_P=AtomicParsley-source-${PV}
+inherit eutils toolchain-funcs
DESCRIPTION="command line program for reading, parsing and setting iTunes-style metadata in MPEG4 files"
HOMEPAGE="http://atomicparsley.sourceforge.net"
@@ -16,20 +16,21 @@ KEYWORDS="amd64 ~ppc ppc64 sparc x86"
IUSE=""
RDEPEND=""
-DEPEND="app-arch/unzip"
+DEPEND="app-arch/unzip
+ sys-apps/sed"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- sed -i -e "s:g++:$(tc-getCXX):g" "${S}"/build || die "sed failed."
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ sed -i -e "s:g++:$(tc-getCXX):g" build || die "sed failed"
}
src_compile() {
- ./build || die "build failed."
+ ./build || die "build failed"
}
src_install() {
- dobin AtomicParsley || die "dobin failed."
+ dobin AtomicParsley || die "dobin failed"
dodoc *.{txt,rtf}
}
diff --git a/media-video/atomicparsley/files/atomicparsley-0.9.0-glibc-2.10.patch b/media-video/atomicparsley/files/atomicparsley-0.9.0-glibc-2.10.patch
new file mode 100644
index 000000000000..0397a4e42bca
--- /dev/null
+++ b/media-video/atomicparsley/files/atomicparsley-0.9.0-glibc-2.10.patch
@@ -0,0 +1,39 @@
+diff -ur AtomicParsley-source-0.9.0.orig/AtomicParsley.cpp AtomicParsley-source-0.9.0/AtomicParsley.cpp
+--- AtomicParsley-source-0.9.0.orig/AtomicParsley.cpp 2006-09-16 02:22:33.000000000 +0300
++++ AtomicParsley-source-0.9.0/AtomicParsley.cpp 2009-07-22 00:52:48.000000000 +0300
+@@ -1447,7 +1447,7 @@
+ uint32_t atom_offsets = 0;
+ char* uuid_outfile = (char*)calloc(1, sizeof(char)*MAXPATHLEN+1); //malloc a new string because it may be a cli arg for a specific output path
+ if (output_path == NULL) {
+- char* orig_suffix = strrchr(originating_file, '.');
++ const char* orig_suffix = strrchr(originating_file, '.');
+ if (orig_suffix == NULL) {
+ fprintf(stdout, "AP warning: a file extension for the input file was not found.\n\tGlobbing onto original filename...\n");
+ path_len = strlen(originating_file);
+@@ -4462,7 +4462,7 @@
+ #endif
+
+ void APar_DeriveNewPath(const char *filePath, char* temp_path, int output_type, const char* file_kind, char* forced_suffix, bool random_filename = true) {
+- char* suffix = NULL;
++ const char* suffix = NULL;
+ if (forced_suffix == NULL) {
+ suffix = strrchr(filePath, '.');
+ } else {
+@@ -4480,7 +4480,7 @@
+ memcpy(temp_path, filePath, base_len);
+ memcpy(temp_path + base_len, file_kind, strlen(file_kind));
+ #else
+- char* file_name = strrchr(filePath, '/');
++ const char* file_name = strrchr(filePath, '/');
+ size_t file_name_len = strlen(file_name);
+ memcpy(temp_path, filePath, filepath_len-file_name_len+1);
+ memcpy(temp_path + strlen(temp_path), ".", 1);
+@@ -5006,7 +5006,7 @@
+ free_modified_name = true;
+ if (forced_suffix_type == FORCE_M4B_TYPE) { //using --stik Audiobook with --overWrite will change the original file's extension
+ uint16_t filename_len = strlen(m4aFile);
+- char* suffix = strrchr(m4aFile, '.');
++ const char* suffix = strrchr(m4aFile, '.');
+ memcpy(originating_file, m4aFile, filename_len+1 );
+ memcpy(originating_file + (filename_len - strlen(suffix) ), ".m4b", 5 );
+ }