summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-13 14:43:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-13 14:43:04 +0000
commitdf038c5026236b84b4df505cde495cc762d1fa01 (patch)
tree08c86be0eeb42f456937e93f931fd946f5115e54 /media-video/2mandvd
parentFix system-sqlite useage for current xulrunner, bug #308949 (diff)
downloadgentoo-2-df038c5026236b84b4df505cde495cc762d1fa01.tar.gz
gentoo-2-df038c5026236b84b4df505cde495cc762d1fa01.tar.bz2
gentoo-2-df038c5026236b84b4df505cde495cc762d1fa01.zip
Install missing file wrt bug #305625 and bumped to 1.3.2
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.2-r1.ebuild (renamed from media-video/2mandvd/2mandvd-1.2.ebuild)10
-rw-r--r--media-video/2mandvd/2mandvd-1.3.1-r1.ebuild73
-rw-r--r--media-video/2mandvd/2mandvd-1.3.2.ebuild (renamed from media-video/2mandvd/2mandvd-1.3.1.ebuild)10
-rw-r--r--media-video/2mandvd/ChangeLog11
4 files changed, 97 insertions, 7 deletions
diff --git a/media-video/2mandvd/2mandvd-1.2.ebuild b/media-video/2mandvd/2mandvd-1.2-r1.ebuild
index 5fbc67dfa0d6..285fa7b3bd45 100644
--- a/media-video/2mandvd/2mandvd-1.2.ebuild
+++ b/media-video/2mandvd/2mandvd-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.2.ebuild,v 1.3 2010/02/21 10:31:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.2-r1.ebuild,v 1.1 2010/03/13 14:43:04 hwoarang Exp $
EAPI="2"
@@ -14,10 +14,11 @@ SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="media-video/dvdauthor
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
media-video/ffmpegthumbnailer
media-fonts/dejavu
media-sound/sox
@@ -61,6 +62,8 @@ src_install() {
insinto /usr/share/${PN}/
doins -r Bibliotheque || die "failed to install Bibliotheque"
doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || die "failed to install fake.pl"
doicon Interface/mandvdico.png || die "doicon failed"
# Desktop icon
make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
@@ -71,4 +74,5 @@ src_install() {
[[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
done
done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
}
diff --git a/media-video/2mandvd/2mandvd-1.3.1-r1.ebuild b/media-video/2mandvd/2mandvd-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..80ea1b438d49
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.3.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.3.1-r1.ebuild,v 1.1 2010/03/13 14:43:04 hwoarang Exp $
+
+EAPI="2"
+LANGS="de en he it pl pt ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin 2ManDVD || die "dobin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || "failed to install fake.pl"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
+}
diff --git a/media-video/2mandvd/2mandvd-1.3.1.ebuild b/media-video/2mandvd/2mandvd-1.3.2.ebuild
index a2030dda93b8..58b735db25f2 100644
--- a/media-video/2mandvd/2mandvd-1.3.1.ebuild
+++ b/media-video/2mandvd/2mandvd-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.3.1.ebuild,v 1.1 2010/02/26 18:02:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.3.2.ebuild,v 1.1 2010/03/13 14:43:04 hwoarang Exp $
EAPI="2"
LANGS="de en he it pl pt ru"
@@ -18,7 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="media-video/dvdauthor
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
media-video/ffmpegthumbnailer
media-fonts/dejavu
media-sound/sox
@@ -43,7 +44,7 @@ src_prepare() {
sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
mainfrm.cpp || die "sed failed"
- qt4_src_prepare
+ qt4-r2_src_prepare
}
src_configure() {
@@ -56,6 +57,8 @@ src_install() {
insinto /usr/share/${PN}/
doins -r Bibliotheque || die "failed to install Bibliotheque"
doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || "failed to install fake.pl"
doicon Interface/mandvdico.png || die "doicon failed"
# Desktop icon
make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
@@ -66,4 +69,5 @@ src_install() {
[[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
done
done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index 3f542679d2e2..527f9dda4ca9 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.5 2010/02/26 18:02:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.6 2010/03/13 14:43:04 hwoarang Exp $
+
+*2mandvd-1.3.2 (13 Mar 2010)
+*2mandvd-1.3.1-r1 (13 Mar 2010)
+*2mandvd-1.2-r1 (13 Mar 2010)
+
+ 13 Mar 2010; Markos Chandras <hwoarang@gentoo.org> -2mandvd-1.2.ebuild,
+ +2mandvd-1.2-r1.ebuild, -2mandvd-1.3.1.ebuild, +2mandvd-1.3.1-r1.ebuild,
+ +2mandvd-1.3.2.ebuild:
+ Install missing file wrt bug #305625 and bumped to 1.3.2
*2mandvd-1.3.1 (26 Feb 2010)