summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-11-25 21:12:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-11-25 21:12:37 +0000
commit8a80ac536e69f70367e91332048958bc7d98a595 (patch)
tree50c1b29c0c75283c3f5c37f6f0cd6a2f994cecd8 /media-video/2mandvd
parentVersion bumps (diff)
downloadgentoo-2-8a80ac536e69f70367e91332048958bc7d98a595.tar.gz
gentoo-2-8a80ac536e69f70367e91332048958bc7d98a595.tar.bz2
gentoo-2-8a80ac536e69f70367e91332048958bc7d98a595.zip
Version bump
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.2.ebuild73
-rw-r--r--media-video/2mandvd/ChangeLog7
2 files changed, 79 insertions, 1 deletions
diff --git a/media-video/2mandvd/2mandvd-1.2.ebuild b/media-video/2mandvd/2mandvd-1.2.ebuild
new file mode 100644
index 000000000000..139227b204e7
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.2.ebuild,v 1.1 2009/11/25 21:12:37 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+LANGS="de en he it pl pt ru"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin 2ManDVD || die "dobin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index dbb55187d3b3..cdb9a8f47f61 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.1 2009/11/09 21:06:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.2 2009/11/25 21:12:37 hwoarang Exp $
+
+*2mandvd-1.2 (25 Nov 2009)
+
+ 25 Nov 2009; <hwoarang@gentoo.org> +2mandvd-1.2.ebuild:
+ Version bump
*2mandvd-1.1.1 (09 Nov 2009)