summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-01-10 13:00:16 +0000
committerSteve Dibb <beandog@gentoo.org>2009-01-10 13:00:16 +0000
commitfa564006f04b07b221d5bf0e0b4e06ef4b60d21a (patch)
tree2ee5adb2b0b431e633a820cc29df0b360f2b872b /media-tv
parentInitial commit, bug 250687 (diff)
downloadgentoo-2-fa564006f04b07b221d5bf0e0b4e06ef4b60d21a.tar.gz
gentoo-2-fa564006f04b07b221d5bf0e0b4e06ef4b60d21a.tar.bz2
gentoo-2-fa564006f04b07b221d5bf0e0b4e06ef4b60d21a.zip
Add X-Osd support, bug 214296
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtvplayer/ChangeLog9
-rw-r--r--media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-tv/ivtvplayer/ChangeLog b/media-tv/ivtvplayer/ChangeLog
index 6318361f19a8..d70b9c34b428 100644
--- a/media-tv/ivtvplayer/ChangeLog
+++ b/media-tv/ivtvplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtvplayer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ChangeLog,v 1.1 2008/12/12 04:44:22 beandog Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ChangeLog,v 1.2 2009/01/10 13:00:16 beandog Exp $
+
+*ivtvplayer-0.1.3-r1 (10 Jan 2009)
+
+ 10 Jan 2009; Steve Dibb <beandog@gentoo.org> +ivtvplayer-0.1.3-r1.ebuild:
+ Add X-Osd support, bug 214296
*ivtvplayer-0.1.3 (12 Dec 2008)
diff --git a/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..0f88b97d298c
--- /dev/null
+++ b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild,v 1.1 2009/01/10 13:00:16 beandog Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Simple IVTV command line TV and radio player with support of LIRC."
+HOMEPAGE="http://sourceforge.net/projects/ivtvplayer/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE="gtk xosd"
+RDEPEND="|| ( media-tv/ivtv media-tv/ivtv-utils )
+ || ( media-video/mplayer[v4l2]
+ media-video/mplayer[dvb] )
+ media-sound/alsa-utils
+ dev-perl/XML-Simple
+ gtk? ( dev-perl/gtk2-perl )
+ xosd? ( dev-perl/X-Osd )
+ >=dev-perl/Lirc-Client-1.50"
+DEPEND=""
+
+src_install() {
+ dobin bin/itv
+ dobin bin/iradio
+ if use gtk ; then
+ dobin bin/ictl
+ fi
+ dodoc doc/README doc/CHANGES
+ dodoc conf/*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Example of itv, iradio and its LIRC configuration file is located in"
+ einfo "directory /usr/share/doc/${PF}/."
+ einfo ""
+}