summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-01-15 21:30:53 +0000
committerSteve Dibb <beandog@gentoo.org>2008-01-15 21:30:53 +0000
commitf46017361aec6b3bf6ec8b92411b5bd5111eccf8 (patch)
tree2c931b21fba4be8797bab49af737d1c4a1b48fe4 /media-tv
parentMinor updates. Some cosmetic changes. (diff)
downloadgentoo-2-f46017361aec6b3bf6ec8b92411b5bd5111eccf8.tar.gz
gentoo-2-f46017361aec6b3bf6ec8b92411b5bd5111eccf8.tar.bz2
gentoo-2-f46017361aec6b3bf6ec8b92411b5bd5111eccf8.zip
Fix perl bindings configuration
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.21_pre15447.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 67ca7881723f..6d77ee45cd65 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.203 2008/01/15 20:51:19 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.204 2008/01/15 21:30:53 beandog Exp $
+
+ 15 Jan 2008; Steve Dibb <beandog@gentoo.org> mythtv-0.21_pre15447.ebuild:
+ Fix perl bindings configuration
15 Jan 2008; Steve Dibb <beandog@gentoo.org> mythtv-0.21_pre15447.ebuild:
Add ivtv configuration flag
diff --git a/media-tv/mythtv/mythtv-0.21_pre15447.ebuild b/media-tv/mythtv/mythtv-0.21_pre15447.ebuild
index 4e77f0afee9e..77151702241f 100644
--- a/media-tv/mythtv/mythtv-0.21_pre15447.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_pre15447.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre15447.ebuild,v 1.2 2008/01/15 20:51:19 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre15447.ebuild,v 1.3 2008/01/15 21:30:53 beandog Exp $
inherit flag-o-matic multilib eutils qt3 mythtv subversion toolchain-funcs
@@ -122,10 +122,10 @@ src_compile() {
use hdhomerun || myconf="${myconf} --disable-hdhomerun"
use altivec || myconf="${myconf} --disable-altivec"
use ivtv || myconf="${myconf} --disable-ivtv"
+ use perl || myconf="${myconf} --without-bindings=perl"
use xvmc && myconf="${myconf} --enable-xvmc"
use xvmc && use video_cards_via && myconf="${myconf} --enable-xvmc-pro"
use xvmc && ! use video_cards_nvidia && myconf="${myconf} --disable-xvmc-opengl"
- use perl && myconf="${myconf} --with-bindings=perl"
myconf="${myconf}
--disable-audio-arts
$(use_enable lirc)
@@ -153,6 +153,7 @@ src_compile() {
myconf="${myconf} --compile-type=release"
fi
+
## CFLAG cleaning so it compiles
MARCH=$(get-flag "march")
MTUNE=$(get-flag "mtune")