summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-27 02:54:30 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-27 02:54:30 +0000
commite1c87a6db2794138dada9aaaec8c16aad3ff6d3e (patch)
treee491ba232027762db15e39a1c431f1daef4e95ba /media-tv
parentadd a handler for gettext locale files #138113 by Santtu Pajukanta (diff)
downloadgentoo-2-e1c87a6db2794138dada9aaaec8c16aad3ff6d3e.tar.gz
gentoo-2-e1c87a6db2794138dada9aaaec8c16aad3ff6d3e.tar.bz2
gentoo-2-e1c87a6db2794138dada9aaaec8c16aad3ff6d3e.zip
Rev bump
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog8
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.6.39
-rw-r--r--media-tv/ivtv/ivtv-0.6.3.ebuild121
3 files changed, 137 insertions, 1 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 2236a9b6d947..9d9dfb4c63a7 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.47 2006/06/13 10:25:23 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.48 2006/06/27 02:54:30 cardoe Exp $
+
+*ivtv-0.6.3 (27 Jun 2006)
+
+ 27 Jun 2006; Doug Goldstein <cardoe@gentoo.org>
+ -files/ivtv-0.6.2-ppc-fix.patch, -ivtv-0.6.2.ebuild, +ivtv-0.6.3.ebuild:
+ Rev bump
13 Jun 2006; Roy Marples <uberlord@gentoo.org> ivtv-0.4.0-r3.ebuild,
ivtv-0.4.2.ebuild, ivtv-0.4.5.ebuild, ivtv-0.6.2.ebuild:
diff --git a/media-tv/ivtv/files/digest-ivtv-0.6.3 b/media-tv/ivtv/files/digest-ivtv-0.6.3
new file mode 100644
index 000000000000..780fd3147ad5
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.6.3
@@ -0,0 +1,9 @@
+MD5 8b79620abf530e44bd834a75b7cca3ee ivtv-0.6.3.tar.gz 433472
+RMD160 57143da9b921b3da5d4ff7b9468130abf390c983 ivtv-0.6.3.tar.gz 433472
+SHA256 b4a74a225b9947b52ab4dc5b0b3d67536f5d77acc6da3af39f7f3b16116c353f ivtv-0.6.3.tar.gz 433472
+MD5 f48ad2cda962879bc093cc6867dc86d2 pvr_1.18.21.22254_inf.zip 593441
+RMD160 9549dddfddacf6bee3c73def508a2c347c5e25f2 pvr_1.18.21.22254_inf.zip 593441
+SHA256 156c0cfaa2cb3f482b48f95b94a9247690e4ed2d0cb8962a52db8846c683bff1 pvr_1.18.21.22254_inf.zip 593441
+MD5 dc84a41b3b296b856da3d0f9edbb7a08 pvr_2.0.24.23035.zip 281620
+RMD160 fbd439efa5793e9a65fd6fac2093c523cd458027 pvr_2.0.24.23035.zip 281620
+SHA256 2387e7a042342f7b401222aac7f99a19b733fded8118339edd402a58279e5f95 pvr_2.0.24.23035.zip 281620
diff --git a/media-tv/ivtv/ivtv-0.6.3.ebuild b/media-tv/ivtv/ivtv-0.6.3.ebuild
new file mode 100644
index 000000000000..93d624a430ad
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.6.3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.6.3.ebuild,v 1.1 2006/06/27 02:54:30 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+
+FW_VER_DEC="pvr_1.18.21.22254_inf.zip"
+FW_VER_ENC="pvr_2.0.24.23035.zip"
+#Switched to recommended firmware by driver
+
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/0.6.x/${P}.tar.gz
+ ftp://ftp.shspvr.com/download/wintv-pvr_150-500/inf/${FW_VER_ENC}
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER_DEC}"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+IUSE=""
+
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV I2C_CHARDEV I2C"
+
+RDEPEND="sys-apps/hotplug"
+DEPEND="app-arch/unzip"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="ivtv(extra:${S}/driver)"
+
+ if kernel_is 2 6 16; then
+ CONFIG_CHECK="${CONFIG_CHECK} VIDEO_DECODER VIDEO_AUDIO_DECODER VIDEO_BT848"
+ else
+ die "This only works on 2.6.16 kernels"
+ fi
+
+ linux_chkconfig_present FB && \
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack ${FW_VER_ENC}
+
+ cd ${S}
+ sed -e "s:^VERS26=.*:VERS26=${KV_MAJOR}.${KV_MINOR}:g" \
+ -i ${S}/driver/Makefile || die "sed failed"
+}
+
+src_compile() {
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build driver "
+
+ cd ${S}/utils
+ emake || die "failed to build utils "
+}
+
+src_install() {
+ cd ${S}/utils
+ dodir /lib/firmware
+ ./ivtvfwextract.pl "${DISTDIR}"/${FW_VER_DEC} \
+ "${D}"/lib/firmware/v4l-cx2341x-enc.fw \
+ "${D}"/lib/firmware/v4l-cx2341x-dec.fw
+
+ make KERNELDIR="${KERNEL_DIR}" DESTDIR="${D}" PREFIX=/usr install || die "failed to install"
+
+ insinto /lib/firmware
+ newins "${WORKDIR}"/HcwMakoA.ROM v4l-cx25840.fw
+ newins ${S}/v4l-cx2341x-init.mpg v4l-cx2341x-init.mpg
+
+ cd ${S}
+ dodoc README doc/* utils/README.X11
+
+ cd ${S}/driver
+ linux-mod_src_install || die "failed to install modules"
+
+ # Add the aliases
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/ivtv ivtv
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # The MCE versions of the PVR cards come without remote control because (I
+ # assume) a remote control is included in Windows Media Center Edition. It
+ # is probably a good idea to just say that if your package comes with a
+ # remote then emerge lirc. Lirc should build all drivers anyway.
+ #
+ # einfo "To get the ir remote working, you'll need to emerge lirc"
+ # einfo "with the following set:"
+ # einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61 "
+ # einfo " --with-port=none --with-irq=none\" emerge lirc"
+ # echo
+ # einfo "You can also add the above LIRC_OPTS line to /etc/make.conf for"
+ # einfo "it to remain there for future updates."
+ # echo
+ # einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ # echo
+
+ # Similar checks are performed by the make install in the drivers directory.
+ BADMODS="msp3400 tda9887 tuner tveeprom"
+
+ if [ ${KV_PATCH} -le 14 ]; then
+ for MODNAME in ${BADMODS}; do
+ if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko" ] ; then
+ ewarn "You have the ${MODNAME} module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run 'modules-update'"
+ ewarn "The file to remove is ${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko"
+ echo
+ fi
+ done
+ fi
+}