summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-10-17 18:35:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-10-17 18:35:30 +0000
commitb79859500ef8934993dd136a34f487b9945a591a (patch)
tree3831f62e3feadda2c99203c2616fabcc0c7eb85a /media-tv
parentAdd patch to respect user-defined CFLAGS. (diff)
downloadgentoo-2-b79859500ef8934993dd136a34f487b9945a591a.tar.gz
gentoo-2-b79859500ef8934993dd136a34f487b9945a591a.tar.bz2
gentoo-2-b79859500ef8934993dd136a34f487b9945a591a.zip
Adding a patch to compile against >=media-libs/libquicktime-0.9.9, bug #141429
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xawtv/ChangeLog6
-rw-r--r--media-tv/xawtv/files/xawtv-3.95-libquicktime-compat.patch27
-rw-r--r--media-tv/xawtv/xawtv-3.95-r1.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/media-tv/xawtv/ChangeLog b/media-tv/xawtv/ChangeLog
index 836cc6c3bd62..d52312f47ddf 100644
--- a/media-tv/xawtv/ChangeLog
+++ b/media-tv/xawtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/xawtv
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.50 2006/10/14 20:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.51 2006/10/17 18:35:30 aballier Exp $
+
+ 17 Oct 2006; Alexis Ballier <aballier@gentoo.org>
+ +files/xawtv-3.95-libquicktime-compat.patch, xawtv-3.95-r1.ebuild:
+ Adding a patch to compile against >=media-libs/libquicktime-0.9.9, bug #141429
14 Oct 2006; Aron Griffis <agriffis@gentoo.org> xawtv-3.95-r1.ebuild:
Mark 3.95-r1 stable on ia64. #138606
diff --git a/media-tv/xawtv/files/xawtv-3.95-libquicktime-compat.patch b/media-tv/xawtv/files/xawtv-3.95-libquicktime-compat.patch
new file mode 100644
index 000000000000..a86c48d83b4e
--- /dev/null
+++ b/media-tv/xawtv/files/xawtv-3.95-libquicktime-compat.patch
@@ -0,0 +1,27 @@
+--- xawtv-3.95/libng/plugins/write-qt.c.old 2006-10-16 20:50:45.000000000 +0200
++++ xawtv-3.95/libng/plugins/write-qt.c 2006-10-17 19:36:09.000000000 +0200
+@@ -348,10 +348,10 @@
+ info[i]->name,info[i]->long_name);
+ for (j = 0; j < info[i]->num_fourccs; j++)
+ fprintf(stderr," fcc : %s\n",info[i]->fourccs[j]);
+- for (j = 0; j < info[i]->num_encoding_colormodels; j++)
++ for (j = 0; j < lqt_num_colormodels(); j++)
+ fprintf(stderr," cmodel: %d [%s]\n",
+- info[i]->encoding_colormodels[j],
+- lqt_get_colormodel_string(info[i]->encoding_colormodels[j]));
++ lqt_get_colormodel(j),
++ lqt_get_colormodel_string(j));
+ }
+
+ /* sanity checks */
+@@ -378,8 +378,8 @@
+ /* pick colormodel */
+ fmtid = VIDEO_NONE;
+ cmodel = 0;
+- for (j = 0; j < info[i]->num_encoding_colormodels; j++) {
+- cmodel = info[i]->encoding_colormodels[j];
++ for (j = 0; j < lqt_num_colormodels(); j++) {
++ cmodel = lqt_get_colormodel(j);
+ if (cmodel>= sizeof(cmodels)/sizeof(int))
+ continue;
+ if (!cmodels[cmodel])
diff --git a/media-tv/xawtv/xawtv-3.95-r1.ebuild b/media-tv/xawtv/xawtv-3.95-r1.ebuild
index e85f02f8150c..81a5a17b747e 100644
--- a/media-tv/xawtv/xawtv-3.95-r1.ebuild
+++ b/media-tv/xawtv/xawtv-3.95-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.95-r1.ebuild,v 1.17 2006/10/14 20:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.95-r1.ebuild,v 1.18 2006/10/17 18:35:30 aballier Exp $
inherit eutils font autotools flag-o-matic
@@ -74,6 +74,7 @@ src_unpack() {
cd "${S}"
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ epatch "${FILESDIR}/${P}-libquicktime-compat.patch"
eautoreconf
}