summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-11 22:51:12 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-11 22:51:12 +0000
commita180a77c495e93aee92386a15d16ca90bb5385c1 (patch)
treec774f8206af2dfe4f6f7c8b14fe56cab98ff1be5 /media-tv
parentUbundled libjpeg and cbflib (diff)
downloadgentoo-2-a180a77c495e93aee92386a15d16ca90bb5385c1.tar.gz
gentoo-2-a180a77c495e93aee92386a15d16ca90bb5385c1.tar.bz2
gentoo-2-a180a77c495e93aee92386a15d16ca90bb5385c1.zip
Remove java5 and java6 flags and cleanup per bug #304639.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/channeleditor/ChangeLog6
-rw-r--r--media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild31
2 files changed, 13 insertions, 24 deletions
diff --git a/media-tv/channeleditor/ChangeLog b/media-tv/channeleditor/ChangeLog
index ac68c1936879..1aaaaa0ba351 100644
--- a/media-tv/channeleditor/ChangeLog
+++ b/media-tv/channeleditor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/channeleditor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/ChangeLog,v 1.6 2010/01/16 17:33:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/ChangeLog,v 1.7 2010/02/11 22:51:12 caster Exp $
+
+ 11 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ channeleditor-1.9.2.1-r1.ebuild:
+ Remove java5 and java6 flags and cleanup per bug #304639.
16 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
channeleditor-1.9.2.1-r1.ebuild:
diff --git a/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild b/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
index 27b30c936a21..419bd23bed77 100644
--- a/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
+++ b/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild,v 1.2 2010/01/16 17:33:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild,v 1.3 2010/02/11 22:51:12 caster Exp $
EAPI="2"
+JAVA_PKG_IUSE="source"
inherit eutils java-pkg-2 java-ant-2
DESCRIPTION="Editor for VDR channels.conf"
@@ -13,16 +14,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE="java5 java6 source"
+IUSE=""
-RDEPEND="java6? ( >=virtual/jre-1.6 )
- !java6? ( java5? ( >=virtual/jre-1.5 ) )
- !java6? ( !java5? ( >=virtual/jre-1.4 ) )"
-
-DEPEND="java6? ( >=virtual/jdk-1.6 )
- !java6? ( java5? ( >=virtual/jdk-1.5 ) )
- !java6? ( !java5? ( >=virtual/jdk-1.4 ) )
- source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=" >=virtual/jdk-1.5"
S="${WORKDIR}/${PN}"
@@ -32,25 +27,15 @@ mainclass() {
|| die "reading Main-Class failed"
}
-src_prepare() {
+java_prepare() {
# move files out of build and remove stuff not needed in the package
mv build/* "${S}" || die "cleaning build dir failed"
rm -f src/java/org/javalobby/icons/{README,COPYRIGHT} \
|| die "removing files failed"
# copy build.xml
- if use java6; then
- sed 's:\(value=\"\)1\.4\(\"\):\11.6\2:g' \
- "${FILESDIR}/build-${PV}.xml" > build.xml \
- || die "copying build.xml failed"
- elif use java5; then
- sed 's:\(value=\"\)1\.4\(\"\):\11.5\2:g' \
- "${FILESDIR}/build-${PV}.xml" > build.xml \
- || die "copying build.xml failed"
- else
- cp -f "${FILESDIR}/build-${PV}.xml" build.xml \
- || die "copying build.xml failed"
- fi
+ cp -f "${FILESDIR}/build-${PV}.xml" build.xml \
+ || die "copying build.xml failed"
# convert CRLF to LF
edos2unix MANIFEST.MF