summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-29 19:32:00 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-29 19:32:00 +0000
commit6bd73c4349efecf748067381a4ad6c8362a0bb63 (patch)
treeb7da7de589a5d79310169c005077c6c4bbc8d4f6 /media-tv
parentVersion Bump (diff)
downloadgentoo-2-6bd73c4349efecf748067381a4ad6c8362a0bb63.tar.gz
gentoo-2-6bd73c4349efecf748067381a4ad6c8362a0bb63.tar.bz2
gentoo-2-6bd73c4349efecf748067381a4ad6c8362a0bb63.zip
QA clean up and fixing build with --as-needed wrt bug 321303. Thanks to Diego for reporting. With beandog's blessing
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv-utils/ChangeLog7
-rw-r--r--media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch99
-rw-r--r--media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild30
3 files changed, 121 insertions, 15 deletions
diff --git a/media-tv/ivtv-utils/ChangeLog b/media-tv/ivtv-utils/ChangeLog
index e19ddc2b3631..48a205e4371c 100644
--- a/media-tv/ivtv-utils/ChangeLog
+++ b/media-tv/ivtv-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtv-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ChangeLog,v 1.9 2010/05/21 01:55:17 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ChangeLog,v 1.10 2010/06/29 19:32:00 xarthisius Exp $
+
+ 29 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ ivtv-utils-1.4.0-r1.ebuild, +files/ivtv-utils-1.4.0-gentoo.patch:
+ QA clean up and fixing build with --as-needed wrt bug 321303. Thanks to
+ Diego for reporting.
21 May 2010; Steve Dibb <beandog@gentoo.org> ivtv-utils-1.4.0-r1.ebuild:
Add dep on v4l2-ctl
diff --git a/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch b/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch
new file mode 100644
index 000000000000..512e3c4ff9f0
--- /dev/null
+++ b/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch
@@ -0,0 +1,99 @@
+Fixing multiple QA issues
+ * respect user {CC,CXX,LD}FLAGS
+ * fix linking order
+ * make job server for install phase
+
+Don't install v4l2-ctl (bug #278255)
+Don't install duplicate kernel headers (bug #244584)
+
+https://bugs.gentoo.org/show_bug.cgi?id=321303
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- test/Makefile
++++ test/Makefile
+@@ -7,13 +7,13 @@
+ ivtv-osd-dma-test ivtv-fb-colormap-test \
+ ivtv-fb-16-bit-test ps-analyzer
+
+-CFLAGS = -I../utils -D_GNU_SOURCE -O2 -Wall
+-CXXFLAGS = $(CFLAGS)
+-LDFLAGS = -lm
++CFLAGS += -I../utils -D_GNU_SOURCE -Wall
++CXXFLAGS += -I../utils -D_GNU_SOURCE -Wall
++LDLIBS = -lm
+
+ all: $(EXES)
+
+-install: all
++install:
+
+ clean:
+ rm -f *.o $(EXES)
+--- utils/Makefile.orig 2010-05-24 15:35:11.321677941 +0000
++++ utils/Makefile 2010-05-24 15:35:15.595615306 +0000
+@@ -9,41 +9,39 @@
+ X86_EXES := ivtvplay ivtv-mpegindex #ivtv-encoder
+ endif
+
+-EXES := v4l2-ctl ivtv-ctl ivtv-radio $(X86_EXES)
++EXES := ivtv-ctl ivtv-radio $(X86_EXES)
+
+ BIN := $(EXES) ivtv-tune/ivtv-tune cx25840ctl/cx25840ctl
+
+
+ HEADERS := linux/ivtv.h linux/ivtvfb.h
+
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -g -I.
+-CXXFLAGS = $(CFLAGS)
++CFLAGS += -D_GNU_SOURCE -Wall -I.
++CXXFLAGS += -D_GNU_SOURCE -Wall -I.
+
+-all:: $(EXES)
+- $(MAKE) CFLAGS="$(CFLAGS)" -C ivtv-tune
+- $(MAKE) CFLAGS="$(CFLAGS)" -C cx25840ctl
++all: $(EXES)
++ $(MAKE) $(MAKEOPTS) CFLAGS="$(CFLAGS)" -C ivtv-tune
++ $(MAKE) $(MAKEOPTS) CFLAGS="$(CFLAGS)" -C cx25840ctl
+
+ ivtv-ctl: ivtv-ctl.o
+- $(CC) -lm -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ v4l2-ctl: v4l2-ctl.o
+- $(CXX) -lm -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ v4l2-dbg: v4l2-dbg.o v4l2-driverids.o v4l2-chipids.o
+- $(CXX) -lm -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ ivtvplay: ivtvplay.cc
+- $(CXX) $(CXXFLAGS) -lm -lpthread -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm -lpthread
+
+ encoder.o: encoder.c
+ $(CC) $(CFLAGS) -DVIDEO_PORT=0 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -c $^
+
+ ivtv-encoder: enc_mindex.o enc_chann.o encoder.o
+- $(CC) -lpthread -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lpthread
+
+-install: all
+- install -d $(DESTDIR)/$(HDRDIR)
+- install -m 0644 $(HEADERS) $(DESTDIR)/$(HDRDIR)
++install:
+ install -d $(DESTDIR)/$(BINDIR)
+ install -m 0755 $(BIN) $(DESTDIR)/$(BINDIR)
+
+--- Makefile
++++ Makefile
+@@ -1,6 +1,6 @@
+ all clean install:
+- make -C utils $@
+- make -C test $@
++ $(MAKE) -C utils $@
++ $(MAKE) -C test $@
+
+ distclean: clean
+
diff --git a/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild b/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild
index 0aedc6e86cc9..fb6f75e04f14 100644
--- a/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild
+++ b/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild,v 1.3 2010/05/21 01:55:17 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ivtv-utils-1.4.0-r1.ebuild,v 1.4 2010/06/29 19:32:00 xarthisius Exp $
EAPI=2
-inherit eutils linux-mod linux-info
+inherit eutils linux-mod linux-info toolchain-funcs
DESCRIPTION="IVTV utilities for Hauppauge PVR PCI cards"
HOMEPAGE="http://www.ivtvdriver.org"
@@ -57,20 +57,22 @@ pkg_setup() {
BUILD_PARAMS="KDIR=${KV_DIR}"
}
-src_install() {
- make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install"
- use perl && dobin utils/perl/*.pl
-
- # Shouldn't be installing linux headers, bug 273165
- rm "${D}"/usr/include/linux/ivtv.h
- rm "${D}"/usr/include/linux/ivtvfb.h
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
- # Installed separately now
- rm "${D}"/usr/bin/v4l2-ctl
+src_compile() {
+ tc-export CC CXX
+ emake || die
+}
- cd "${S}"
- dodoc README doc/* ChangeLog
- use perl && dodoc utils/perl/README.ptune
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "failed to install"
+ dodoc README doc/* ChangeLog || die
+ if use perl; then
+ dobin utils/perl/*.pl || die
+ dodoc utils/perl/README.ptune || die
+ fi
}
pkg_postinst() {