summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-05-29 17:59:13 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-05-29 17:59:13 +0000
commit64993cabc15bd07bada0db910b2585660150a40d (patch)
treec4343f49b367d71ec323a9cdd16e72355bfd7e20 /media-tv
parentmark ~ppc, fixes bug #94163 (diff)
downloadgentoo-2-64993cabc15bd07bada0db910b2585660150a40d.tar.gz
gentoo-2-64993cabc15bd07bada0db910b2585660150a40d.tar.bz2
gentoo-2-64993cabc15bd07bada0db910b2585660150a40d.zip
Fix up ebuild to listen to some of the user's CFLAGS
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/mythtv-0.18.1-r1.ebuild34
2 files changed, 32 insertions, 8 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 414ada158628..6221c1f8cc87 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.60 2005/05/28 00:20:46 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.61 2005/05/29 17:59:13 cardoe Exp $
+
+ 29 May 2005; Doug Goldstein <cardoe@gentoo.org> mythtv-0.18.1-r1.ebuild:
+ Changed build to use some of the user's CFLAGS, stripping out all the
+ dangerous stuff.
28 May 2005; Carsten Lohrke <carlo@gentoo.org> mythtv-0.17-r1.ebuild:
stable on x86
diff --git a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
index 47514ac8ab7c..91e41b7a642b 100644
--- a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.1 2005/05/23 06:50:30 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.2 2005/05/29 17:59:13 cardoe Exp $
inherit flag-o-matic eutils debug
@@ -27,16 +27,14 @@ DEPEND=">=media-libs/freetype-2.0
nvidia? ( media-video/nvidia-glx )
oggvorbis? ( media-libs/libvorbis )
opengl? ( virtual/opengl )
- ieee1394? ( >=sys-libs/libraw1394-1.2.0 )
+ ieee1394? ( >=sys-libs/libraw1394-1.2.0
+ >=sys-libs/libavc1394-0.4.1 )
|| ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )
!x11-base/xfree
!<x11-base/xorg-x11-6.8"
# ieee1394 also needs >=sys-libs/libiec61883-1.0.0
-RDEPEND="${DEPEND}
- !media-tv/mythfrontend"
-
pkg_setup() {
if ! built_with_use x11-libs/qt mysql ; then
@@ -53,8 +51,10 @@ pkg_setup() {
fi
einfo
- einfo "Please note, this ebuild does not use your CFLAGS and CXXFLAGS. It determines"
- einfo "a sane set and uses those. Please do not attempt to override this behavior."
+ einfo "This ebuild now uses a heavily stripped down version of your CFLAGS"
+ einfo "Don't complain because your -momfg-fast-speed CFLAG is being stripped"
+ einfo "Only additional CFLAG issues that will be addressed are for binary"
+ einfo "package building."
einfo
}
@@ -102,6 +102,26 @@ src_compile() {
myconf="${myconf} --compile-type=release"
fi
+ ## CFLAG cleaning so it compiles
+ MARCH=$(get-flag "march")
+ MTUNE=$(get-flag "mtune")
+ MCPU=$(get-flag "mcpu")
+ strip-flags
+ filter-flags "-march=*" "-mtune=*" "-mcpu=*"
+ filter-flags "-O" "-O?"
+
+ if [[ -n "${MARCH}" ]]; then
+ myconf="${myconf} --arch=${MARCH}"
+ fi
+ if [[ -n "${MTUNE}" ]]; then
+ myconf="${myconf} --tune=${MTUNE}"
+ fi
+ if [[ -n "${MCPU}" ]]; then
+ myconf="${myconf} --cpu=${MCPU}"
+ fi
+
+ myconf="${myconf} --extra-cflags=${CFLAGS}"
+
hasq distcc ${FEATURES} || myconf="${myconf} --disable-distcc"
hasq ccache ${FEATURES} || myconf="${myconf} --disable-ccache"