summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-10 15:25:48 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-10 15:25:48 +0000
commit415916f2d79ba7a81ed9d0b7627c0bf32f8fc895 (patch)
treec32c1c23204972ff67d60389b681b4addbe22ffc /media-tv
parentcomment out setting CFLAGS and CXXFLAGS to "" for bug #279944 (diff)
downloadgentoo-2-415916f2d79ba7a81ed9d0b7627c0bf32f8fc895.tar.gz
gentoo-2-415916f2d79ba7a81ed9d0b7627c0bf32f8fc895.tar.bz2
gentoo-2-415916f2d79ba7a81ed9d0b7627c0bf32f8fc895.zip
fix bug #292481
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.22_p22778.ebuild12
2 files changed, 12 insertions, 5 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 4616a262acd5..511d5f3202d7 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.291 2009/11/10 15:24:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.292 2009/11/10 15:25:48 cardoe Exp $
+
+ 10 Nov 2009; Doug Goldstein <cardoe@gentoo.org> mythtv-0.22_p22778.ebuild:
+ fix bug #292481
10 Nov 2009; Doug Goldstein <cardoe@gentoo.org> mythtv-0.22_p22778.ebuild:
comment out setting CFLAGS and CXXFLAGS to "" for bug #279944
diff --git a/media-tv/mythtv/mythtv-0.22_p22778.ebuild b/media-tv/mythtv/mythtv-0.22_p22778.ebuild
index 3c253db73940..c0994e861fcb 100644
--- a/media-tv/mythtv/mythtv-0.22_p22778.ebuild
+++ b/media-tv/mythtv/mythtv-0.22_p22778.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_p22778.ebuild,v 1.2 2009/11/10 15:24:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_p22778.ebuild,v 1.3 2009/11/10 15:25:48 cardoe Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt4 mythtv toolchain-funcs python
@@ -100,9 +100,13 @@ src_configure() {
use jack || myconf="${myconf} --disable-audio-jack"
use vdpau && myconf="${myconf} --enable-vdpau"
- #from bug #220857
- use xvmc && myconf="${myconf} --enable-xvmc --enable-xvmcw \
- --disable-xvmc-vld"
+ #from bug #220857 and fixed for bug #292481
+ use xvmc && myconf="${myconf} --enable-xvmc --enable-xvmcw"
+ if use video_cards_via && use xvmc; then
+ myconf="${myconf} --enable-xvmc-vld";
+ else
+ myconf="${myconf} --disable-xvmc-vld";
+ fi
# according to the Ubuntu guys, this works better being always on
myconf="${myconf} --enable-glx-procaddrarb"