summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo Azzali <mattepiu@gentoo.org>2006-06-01 13:47:19 +0000
committerMatteo Azzali <mattepiu@gentoo.org>2006-06-01 13:47:19 +0000
commit3f1e0de13cb9e606b566c6dcd190de8ff1bc8dff (patch)
treeea9f0fbec9dcce07b8a3441640fd3c5ce1ac6db7 /media-tv
parenthomepage fix by James (diff)
downloadgentoo-2-3f1e0de13cb9e606b566c6dcd190de8ff1bc8dff.tar.gz
gentoo-2-3f1e0de13cb9e606b566c6dcd190de8ff1bc8dff.tar.bz2
gentoo-2-3f1e0de13cb9e606b566c6dcd190de8ff1bc8dff.zip
Changed de_tvtoday patch and changed ebuild to patch only when needed.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xmltv/ChangeLog5
-rw-r--r--media-tv/xmltv/files/tv_grab_de_tvtoday-0.5.43.diff9
-rw-r--r--media-tv/xmltv/xmltv-0.5.43-r3.ebuild4
3 files changed, 7 insertions, 11 deletions
diff --git a/media-tv/xmltv/ChangeLog b/media-tv/xmltv/ChangeLog
index 3dc2debe5ddb..d21e18f26f5a 100644
--- a/media-tv/xmltv/ChangeLog
+++ b/media-tv/xmltv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/xmltv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/ChangeLog,v 1.42 2006/06/01 10:05:53 mattepiu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/ChangeLog,v 1.43 2006/06/01 13:47:19 mattepiu Exp $
+
+ 1 Jun 2006; Matteo Azzali <mattepiu@gentoo.org> xmltv-0.5.43-r3.ebuild:
+ Changed de_tvtoday patch and changed ebuild to patch only when needed.
1 Jun 2006; Matteo Azzali <mattepiu@gentoo.org> +xmltv-0.5.43-r3.ebuild,
Bumped to a more updated, useful verion. bug #95166 and #116612 and #94101
diff --git a/media-tv/xmltv/files/tv_grab_de_tvtoday-0.5.43.diff b/media-tv/xmltv/files/tv_grab_de_tvtoday-0.5.43.diff
index 6c843a4844b7..5f4b280198e6 100644
--- a/media-tv/xmltv/files/tv_grab_de_tvtoday-0.5.43.diff
+++ b/media-tv/xmltv/files/tv_grab_de_tvtoday-0.5.43.diff
@@ -6,15 +6,6 @@ retrieving revision 1.45
diff -p -u -r1.42 -r1.45
--- grab/de_tvtoday/tv_grab_de_tvtoday.in 21 Apr 2006 17:17:21 -0000 1.42
+++ grab/de_tvtoday/tv_grab_de_tvtoday.in 25 May 2006 17:10:18 -0000 1.45
-@@ -99,7 +99,7 @@ at http://sourceforge.net/projects/xmltv
-
- use warnings;
- use strict;
--use XMLTV::Version '$Id: tv_grab_de_tvtoday-0.5.43.diff,v 1.1 2006/06/01 10:05:53 mattepiu Exp $ ';
-+use XMLTV::Version '$Id: tv_grab_de_tvtoday-0.5.43.diff,v 1.1 2006/06/01 10:05:53 mattepiu Exp $ ';
- use XMLTV::Capabilities qw/baseline manualconfig cache share/;
- use XMLTV::Description 'Germany (www.tvtoday.de)';
- use Date::Manip;
@@ -138,6 +138,7 @@ BEGIN {
else {
*t = \&Log::TraceMessages::t;
diff --git a/media-tv/xmltv/xmltv-0.5.43-r3.ebuild b/media-tv/xmltv/xmltv-0.5.43-r3.ebuild
index e7e918199833..d2eacd0aab8b 100644
--- a/media-tv/xmltv/xmltv-0.5.43-r3.ebuild
+++ b/media-tv/xmltv/xmltv-0.5.43-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.43-r3.ebuild,v 1.1 2006/06/01 10:05:53 mattepiu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.43-r3.ebuild,v 1.2 2006/06/01 13:47:19 mattepiu Exp $
inherit eutils perl-module
@@ -235,7 +235,9 @@ src_unpack() {
unpack "${A}"
cd "${S}"
+ if [ -z "${XMLTV_OPTS}" ] || has tv_grab_de_tvtoday ${XMLTV_OPTS} ; then
epatch "${FILESDIR}/tv_grab_de_tvtoday-0.5.43.diff"
+ fi
}
src_compile() {