summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-02 08:52:23 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-02 08:52:23 +0000
commit2f6fb480189f5175956eadc4b131299e5d2f671d (patch)
tree50324e9df582fbd983220b45b31f34fc3cbe7735 /media-tv
parentversion bump to 3.1.0 as per bug #83682. (diff)
downloadgentoo-2-2f6fb480189f5175956eadc4b131299e5d2f671d.tar.gz
gentoo-2-2f6fb480189f5175956eadc4b131299e5d2f671d.tar.bz2
gentoo-2-2f6fb480189f5175956eadc4b131299e5d2f671d.zip
Use bash builtins for testing. Added MYTH_NICE option.
(Portage version: 2.0.51.18)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/files/mythbackend.conf11
-rw-r--r--media-tv/mythtv/files/mythbackend.rc623
3 files changed, 26 insertions, 14 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 2eafe490f53a..4e8ac03de0d3 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.45 2005/02/28 08:53:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.46 2005/03/02 08:52:23 eradicator Exp $
+
+ 02 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ files/mythbackend.conf, files/mythbackend.rc6:
+ Use bash builtins for testing. Added MYTH_NICE option.
28 Feb 2005; Doug Goldstein <cardoe@gentoo.org> mythtv-0.17.ebuild:
added some notices about ieee1394 and cle266 USE flags
diff --git a/media-tv/mythtv/files/mythbackend.conf b/media-tv/mythtv/files/mythbackend.conf
index 359d38ddfbfb..9b5e67e86ef0 100644
--- a/media-tv/mythtv/files/mythbackend.conf
+++ b/media-tv/mythtv/files/mythbackend.conf
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.conf,v 1.4 2004/09/11 12:06:33 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.conf,v 1.5 2005/03/02 08:52:23 eradicator Exp $
# Uncomment this to disable the permission warnings.
MYTH_WARN=yes
@@ -22,5 +22,12 @@ MYTH_LOG=/var/log/mythtv/mythbackend.log
# Specify in which file to store the backend process id.
MYTH_PID=/var/run/mythtv/mythbackend.pid
-# Specify debug-level in log
+# Specify debug-level in log.
+# Accepts any combination (separated by comma) of:
+# all,none,quiet,record,playback,channel,osd,file,
+# schedule,network,commflag,audio,libav,jobqueue
MYTH_VERBOSE="none"
+
+# Set the nice level (see nice(1)). To give mythbackend a higher
+# priority, you may want to set this to -15.
+MYTH_NICE="0"
diff --git a/media-tv/mythtv/files/mythbackend.rc6 b/media-tv/mythtv/files/mythbackend.rc6
index f49411fb9daf..36bccdd8684c 100644
--- a/media-tv/mythtv/files/mythbackend.rc6
+++ b/media-tv/mythtv/files/mythbackend.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.rc6,v 1.4 2004/09/11 12:06:33 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.rc6,v 1.5 2005/03/02 08:52:23 eradicator Exp $
depend() {
need net
@@ -10,15 +10,15 @@ depend() {
checkconfig() {
for i in $(groups "${MYTH_USER/:*/}") ; do
- [ "${i}" = "audio" ] && audio="yes"
- [ "${i}" = "video" ] && video="yes"
+ [[ "${i}" == "audio" ]] && audio="yes"
+ [[ "${i}" == "video" ]] && video="yes"
done
if [ -z "${audio}" -o -z "${video}" ] ; then
ewarn ""
- [ -z "${audio}" ] && \
+ [[ -z "${audio}" ]] && \
ewarn "${HILITE}${MYTH_USER/:*/}${NORMAL} is not in the audio group"
- [ -z "${video}" ] && \
+ [[ -z "${video}" ]] && \
ewarn "${HILITE}${MYTH_USER/:*/}${NORMAL} is not in the video group"
ewarn ""
ewarn "insufficient permissions discovered"
@@ -28,10 +28,11 @@ checkconfig() {
}
start() {
- [ -z "${MYTH_USER}" ] && MYTH_USER="nobody:nobody"
- [ -z "${MYTH_LOG}" ] && MYTH_LOG="/var/log/mythtv/mythbackend.log"
- [ -z "${MYTH_PID}" ] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
- [ -z "${MYTH_WARN}" -o "${MYTH_WARN}" = "yes" ] && checkconfig
+ [[ -z "${MYTH_USER}" ]] && MYTH_USER="nobody:nobody"
+ [[ -z "${MYTH_LOG}" ]] && MYTH_LOG="/var/log/mythtv/mythbackend.log"
+ [[ -z "${MYTH_PID}" ]] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
+ [[ -z "${MYTH_WARN}" || "${MYTH_WARN}" == "yes" ]] && checkconfig
+ [[ -z "${MYTH_NICE}" ]] && MYTH_NICE="0"
HOME="$(dirname "${MYTH_PID}")"
QTDIR=/usr/qt/3
@@ -42,14 +43,14 @@ start() {
ebegin "Starting myth backend"
start-stop-daemon --start --quiet --chuid "${MYTH_USER}" \
- --exec /usr/bin/mythbackend -- \
+ --exec /usr/bin/mythbackend --nicelevel "${MYTH_NICE}" -- \
--daemon --pidfile "${MYTH_PID}" --logfile "${MYTH_LOG}" \
--verbose ${MYTH_VERBOSE}
eend $?
}
stop () {
- [ -z "${MYTH_PID}" ] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
+ [[ -z "${MYTH_PID}" ]] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
ebegin "Stopping myth backend"
start-stop-daemon --stop --quiet --pidfile="${MYTH_PID}"