summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-05-30 07:15:53 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-05-30 07:15:53 +0000
commit2d6ea3aa84ade6d3cb141ceb7a04a4ee2a8ea49a (patch)
tree8c80bc191dcca6277d14831055154f010462ca24 /media-tv
parentmarked ~amd64 after tested that it compiles. (diff)
downloadgentoo-2-2d6ea3aa84ade6d3cb141ceb7a04a4ee2a8ea49a.tar.gz
gentoo-2-2d6ea3aa84ade6d3cb141ceb7a04a4ee2a8ea49a.tar.bz2
gentoo-2-2d6ea3aa84ade6d3cb141ceb7a04a4ee2a8ea49a.zip
finally firewire support natively in Gentoo. Fixes bug #89957
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.18.1-r1.ebuild10
2 files changed, 7 insertions, 8 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 6221c1f8cc87..ac8383a23ffd 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.61 2005/05/29 17:59:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.62 2005/05/30 07:15:53 cardoe Exp $
+
+ 30 May 2005; Doug Goldstein <cardoe@gentoo.org> mythtv-0.18.1-r1.ebuild:
+ Firewire support!!! Hoorah!
29 May 2005; Doug Goldstein <cardoe@gentoo.org> mythtv-0.18.1-r1.ebuild:
Changed build to use some of the user's CFLAGS, stripping out all the
diff --git a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
index 91e41b7a642b..fd515cb9ef70 100644
--- a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.2 2005/05/29 17:59:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.3 2005/05/30 07:15:53 cardoe Exp $
inherit flag-o-matic eutils debug
@@ -28,13 +28,11 @@ DEPEND=">=media-libs/freetype-2.0
oggvorbis? ( media-libs/libvorbis )
opengl? ( virtual/opengl )
ieee1394? ( >=sys-libs/libraw1394-1.2.0
- >=sys-libs/libavc1394-0.4.1 )
+ >=media-libs/libiec61883-1.0.0 )
|| ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )
!x11-base/xfree
!<x11-base/xorg-x11-6.8"
-# ieee1394 also needs >=sys-libs/libiec61883-1.0.0
-
pkg_setup() {
if ! built_with_use x11-libs/qt mysql ; then
@@ -86,6 +84,7 @@ src_compile() {
$(use_enable oggvorbis vorbis)
$(use_enable nvidia xvmc)
$(use_enable xv)
+ $(use_enable ieee1394 firewire)
--disable-directfb
--enable-x11
--enable-proc-opt"
@@ -125,9 +124,6 @@ src_compile() {
hasq distcc ${FEATURES} || myconf="${myconf} --disable-distcc"
hasq ccache ${FEATURES} || myconf="${myconf} --disable-ccache"
- # depends on bug # 89799
- # $(use_enable ieee1394 firewire)
-
if use frontendonly; then
##Backend Removal
cd ${S}