summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-07 23:21:54 +0000
committerMax Kalika <max@gentoo.org>2003-08-07 23:21:54 +0000
commit1570a3db4dfc997a409a6679acfa65fe47e69e1d (patch)
tree8475094afff389c655d9e54982b76f8978cd6d37 /media-tv
parentstable (diff)
downloadgentoo-2-1570a3db4dfc997a409a6679acfa65fe47e69e1d.tar.gz
gentoo-2-1570a3db4dfc997a409a6679acfa65fe47e69e1d.tar.bz2
gentoo-2-1570a3db4dfc997a409a6679acfa65fe47e69e1d.zip
Block media-tv/mythfrontend.
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/Manifest4
-rw-r--r--media-tv/mythtv/mythtv-0.10.ebuild19
3 files changed, 12 insertions, 16 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 0a759ac10aad..c2af2cb700b8 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.4 2003/07/21 22:25:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.5 2003/08/07 23:21:52 max Exp $
+
+ 07 Aug 2003; Max Kalika <max@gentoo.org> mythtv-0.10.ebuild:
+ Block media-tv/mythfrontend.
21 Jul 2003; Max Kalika <max@gentoo.org> mythtv-0.10.ebuild:
Correct and simplify the compile process.
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 86336c5a45b8..4e1293462c9c 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,5 +1,5 @@
-MD5 2a607b274955c1ce80b6db7e1386bbdd ChangeLog 2963
-MD5 95febd2e83193d3fbad863a469767b72 mythtv-0.10.ebuild 2826
+MD5 dc7af004185c06b98d9aacf1ef56deaf ChangeLog 3058
+MD5 b8fae8fa9619130ec1f3072a0c82e37d mythtv-0.10.ebuild 2843
MD5 ce8c4dae21199ea11abd156b16cc3b8a files/mythbackend.conf 867
MD5 897368570b822b7a42c9693e16f1f052 files/mythbackend.rc6 1670
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythtv-0.10 65
diff --git a/media-tv/mythtv/mythtv-0.10.ebuild b/media-tv/mythtv/mythtv-0.10.ebuild
index 3df6b3582d35..28d113a6c5aa 100644
--- a/media-tv/mythtv/mythtv-0.10.ebuild
+++ b/media-tv/mythtv/mythtv-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.10.ebuild,v 1.3 2003/07/21 22:25:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.10.ebuild,v 1.4 2003/08/07 23:21:52 max Exp $
inherit flag-o-matic
@@ -13,28 +13,26 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND=">=x11-libs/qt-3
+DEPEND="virtual/x11
+ >=x11-libs/qt-3
=media-tv/xmltv-0.5.14*
>=media-sound/lame-3.92
>=media-libs/freetype-2.0
>=sys-apps/sed-4
- virtual/x11"
-
-RDEPEND="${DEPEND}
lcd? ( app-misc/lcdproc )"
-src_unpack() {
+RDEPEND="${DEPENED}
+ !media-tv/mythfrontend"
+src_unpack() {
unpack ${A}
for i in `grep -lr usr/local "${S}"` ; do
sed -e "s:usr/local:usr:" -i "${i}" || die "sed failed"
done
-
}
src_compile() {
-
cpu="`get-flag march`"
if [ -n "${cpu}" ] ; then
sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
@@ -46,11 +44,9 @@ src_compile() {
# Parallel build doesn't work.
make || die "compile problem"
-
}
src_install() {
-
make INSTALL_ROOT="${D}" install || die "make install failed"
newbin "setup/setup" "mythsetup"
@@ -74,11 +70,9 @@ src_install() {
dohtml docs/*.html
keepdir /var/{log,run}/mythtv
-
}
pkg_postinst() {
-
ewarn "Please note that /usr/share/mythtv/setup has been moved"
ewarn "to /usr/bin/mythsetup"
echo
@@ -106,5 +100,4 @@ pkg_postinst() {
ewarn "which need to be performed or this package will not work"
ewarn "properly."
echo
-
}