summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-08-21 20:44:32 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-08-21 20:44:32 +0000
commite8523399df5869e0e923a14d4c27c81d02503e09 (patch)
tree553d5e4e2e5c618bfaeb8ea433e979b4905fb651 /media-tv/mythtv
parentAdd ~amd64. (diff)
downloadgentoo-2-e8523399df5869e0e923a14d4c27c81d02503e09.tar.gz
gentoo-2-e8523399df5869e0e923a14d4c27c81d02503e09.tar.bz2
gentoo-2-e8523399df5869e0e923a14d4c27c81d02503e09.zip
add pkg_info and pkg_config functions to trunk ebuilds
(Portage version: 2.1.3.6)
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/mythtv-0.21_pre14153.ebuild12
-rw-r--r--media-tv/mythtv/mythtv-0.21_pre14241.ebuild12
3 files changed, 27 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index ea992e818cce..6dff26757655 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.166 2007/08/21 15:34:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.167 2007/08/21 20:44:32 cardoe Exp $
+
+ 21 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
+ mythtv-0.21_pre14153.ebuild, mythtv-0.21_pre14241.ebuild:
+ add pkg_info and pkg_config functions to trunk ebuilds
*mythtv-0.21_pre14241 (21 Aug 2007)
diff --git a/media-tv/mythtv/mythtv-0.21_pre14153.ebuild b/media-tv/mythtv/mythtv-0.21_pre14153.ebuild
index 6d4ba69c1cbb..f0d5a510072c 100644
--- a/media-tv/mythtv/mythtv-0.21_pre14153.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_pre14153.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre14153.ebuild,v 1.2 2007/08/08 19:07:08 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre14153.ebuild,v 1.3 2007/08/21 20:44:32 cardoe Exp $
inherit flag-o-matic multilib eutils qt3 mythtv subversion
@@ -255,3 +255,13 @@ pkg_postinst() {
fi
}
+
+pkg_info() {
+ /usr/bin/mythfrontend --version
+}
+
+pkg_config() {
+ echo "Creating mythtv MySQL user and mythconverg database if it does not"
+ echo "already exist. You will be prompted for your MySQL root password."
+ /usr/bin/mysql -u root -p < /usr/share/mythtv/database/mc.sql
+}
diff --git a/media-tv/mythtv/mythtv-0.21_pre14241.ebuild b/media-tv/mythtv/mythtv-0.21_pre14241.ebuild
index b87e12296a13..619197b333a4 100644
--- a/media-tv/mythtv/mythtv-0.21_pre14241.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_pre14241.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre14241.ebuild,v 1.1 2007/08/21 15:34:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre14241.ebuild,v 1.2 2007/08/21 20:44:32 cardoe Exp $
inherit flag-o-matic multilib eutils qt3 mythtv subversion
@@ -255,3 +255,13 @@ pkg_postinst() {
fi
}
+
+pkg_info() {
+ /usr/bin/mythfrontend --version
+}
+
+pkg_config() {
+ echo "Creating mythtv MySQL user and mythconverg database if it does not"
+ echo "already exist. You will be prompted for your MySQL root password."
+ /usr/bin/mysql -u root -p < /usr/share/mythtv/database/mc.sql
+}