summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-13 10:47:16 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-13 10:47:16 +0000
commitd5198d0661d7eaf417c98f1c659b335a242d479b (patch)
treef26429d21b7d089fe6286b293298dae2a572d535 /media-tv/mythtv
parentfix node updating script (Manifest recommit) (diff)
downloadgentoo-2-d5198d0661d7eaf417c98f1c659b335a242d479b.tar.gz
gentoo-2-d5198d0661d7eaf417c98f1c659b335a242d479b.tar.bz2
gentoo-2-d5198d0661d7eaf417c98f1c659b335a242d479b.zip
Added patch from cvs
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/files/mythtv-0.16-cx88.patch16
-rw-r--r--media-tv/mythtv/mythtv-0.16.ebuild6
3 files changed, 24 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index dca0cc58615b..3988631961c3 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.35 2004/09/12 10:07:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.36 2004/09/13 10:47:16 aliz Exp $
+
+ 13 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.16.ebuild:
+ Added patch from CVS to fix cx88 related crashes.
12 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.16.ebuild:
Make compilation distcc friendly, closing #63672.
diff --git a/media-tv/mythtv/files/mythtv-0.16-cx88.patch b/media-tv/mythtv/files/mythtv-0.16-cx88.patch
new file mode 100644
index 000000000000..d62377cad2d1
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.16-cx88.patch
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /var/lib/mythcvs/mythtv/libs/libmythtv/NuppelVideoRecorder.cpp,v
+retrieving revision 1.178
+retrieving revision 1.179
+diff -u -r1.178 -r1.179
+--- mythtv/libs/libmythtv/NuppelVideoRecorder.cpp 2004/08/19 02:02:19 1.178
++++ mythtv/libs/libmythtv/NuppelVideoRecorder.cpp 2004/09/12 19:05:49 1.179
+@@ -1300,7 +1300,7 @@
+
+ uint8_t *y_plane = conversion_buffer;
+ uint8_t *cb_plane = y_plane + w * h;
+- uint8_t *cr_plane = cr_plane + w * h / 4;
++ uint8_t *cr_plane = cb_plane + w * h / 4;
+
+ uint8_t *src = buffers[frame];
+
diff --git a/media-tv/mythtv/mythtv-0.16.ebuild b/media-tv/mythtv/mythtv-0.16.ebuild
index a9de4b2a4537..8e41f9212162 100644
--- a/media-tv/mythtv/mythtv-0.16.ebuild
+++ b/media-tv/mythtv/mythtv-0.16.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.5 2004/09/12 10:07:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.6 2004/09/13 10:47:16 aliz Exp $
-inherit myth flag-o-matic
+inherit myth flag-o-matic eutils
DESCRIPTION="Homebrew PVR project"
HOMEPAGE="http://www.mythtv.org/"
@@ -141,6 +141,8 @@ src_unpack() {
filter-flags -fforce-addr -fPIC
myth_src_unpack
+
+ epatch ${FILESDIR}/${P}-cx88.patch
}